Wierd printer issue

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
Bryan88
Level 3
Level 3
Posts: 155
Joined: Sun Apr 13, 2014 3:29 am
Location: South Africa

Wierd printer issue

Post by Bryan88 »

I am having a problem printing anything from Libreoffice. I have an old HP lazer printer which is tempramental but generally works fine, which I originally blamed. But, I can print pdf's and test pages. The problem arises when I try to print from Libre, my printers big light flashes like there is no paper, then it goes off and won't print ANYTHING after that. If I restart the pc, it will then print again (pdf's and test pages). As soon as I try to print from Libre, the whole process stars again. Is anybody else having this problem with Libre, or do I have to change/reinstall something?
Many thanks.

Oldbwl
Level 2
Level 2
Posts: 53
Joined: Thu May 09, 2013 2:38 am

Re: Wierd printer issue

Post by Oldbwl »

Can you advise a bit more detail? What operating system are you using, which version of LO? Which driver is installed etc

User avatar
nomko
Level 9
Level 9
Posts: 2986
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Re: Wierd printer issue

Post by nomko »

Most probably a driver issue. What happens when you run the following terminal command:

Code: Select all

sudo hp-setup
This command will download the required driver and set up an new printer. Make sure you delete the "old" printer when the "new" printer works to avoid selecting the wrong one. Also inform us if this solution helped you solve your problem or not.

Bryan88
Level 3
Level 3
Posts: 155
Joined: Sun Apr 13, 2014 3:29 am
Location: South Africa

Re: Weird printer issue

Post by Bryan88 »

Thanks guys. Sorry for the lack of info, just wasn't sure if it was a Libre problem. I am using LM17 XFCE 32bit. My printer is an old HP lazerjet which is connected via a usb to parallel converter cable ( I had to buy that to make it work when I switched to LM15 from XP)
After I upgraded to LM17 I installed it via the "add printer" option and it was working fine until about 2 days ago.

Here are the results from the terminal.

bryan@bryan-OEM ~ $ sudo hp-setup
[sudo] password for bryan:

HP Linux Imaging and Printing System (ver. 3.14.3)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-13 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Searching... (bus=usb, search=(None), desc=1)
error: No devices found on bus: usb

Done.
bryan@bryan-OEM ~ $

Funny thing is, thinking the usb port was starting to pack up, I changed i to another one. A "new printer found" box popped up on my desktop, while the terminal is busy telling me there is nothing connected????

Bryan88
Level 3
Level 3
Posts: 155
Joined: Sun Apr 13, 2014 3:29 am
Location: South Africa

Re: Wierd printer issue

Post by Bryan88 »

Edit - It seems to be working from the new usb port, printed a test page and something from Libre. I deleted the old printer for good messure. Does this qualify as {SOLVED}? :? Thanks again for the help and apologies for my dodgy spelling.

Post Reply

Return to “Hardware Support”