SCSI Adapter Causes Boot Error solved

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Bill Auclair

SCSI Adapter Causes Boot Error solved

Postby Bill Auclair » Tue Sep 30, 2008 8:48 pm


I could use some help with a problem I've been having. I recently attempted to add an Adaptec 2940U SCSI adapter to my system in order to run a HP ScanJet 4C scanner. After I installed the card, I could no longer boot (except to BusyBox)-- apparently the mappings to my root directory were now referencing another, non-bootable drive in my system (I have 2 internal SATA drives and 3 external USB drives connected).

I was getting errors such as "Target file system doesn't have /sbin/init", indicating that directories that the OS was searching for were no longer there. When I removed the Adaptec card, all returned to normal. It's obvious to me that the SCSI card's presence is somehow shifting my drive mappings, even though I'm referring to the drives by UUID in fstab.

My question is this-- is there a way to disable automatic mapping of SCSI drives in Linux Mint, so that the root drive mapping is not affected by the SCSI adapter's presence? I'll appreciate any and all recommendations, workarounds and comments on this one, as I really need to use my scanner and don't want to have to pull my Windows laptop out of mothballs to get these scan jobs done.

Bill Auclair

P.S.-- Here is a dump of my fstab file (without the SCSI adapter installed):

# /etc/fstab: static file system information.
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda1
UUID=88811c46-a23e-4860-bcd6-ceff24a80aec / ext3 relatime,errors=remount-ro 0 1
# /dev/sda5
UUID=b2c05e0b-895b-44bd-ac29-014958c7cecb none swap sw 0 0
UUID=279c5a91-9f98-42a4-b88e-bb1845c294f8 /media/disk xfs
UUID=25971e15-b140-40f1-894d-3b5ce4a56981 /media/disk-1 xfs
UUID=0ec25bc2-cbce-4de3-b2b9-57e49b9399ed /media/disk-2 xfs
UUID=6a2dc2b8-8d54-4b23-a2b3-82ac53650f29 /media/disk-3 xfs
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/scd1 /media/cdrom1 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0

Level 23
Level 23
Posts: 18703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: SCSI Adapter Causes Boot Error

Postby Husse » Wed Oct 01, 2008 6:37 am

I only have to read the first lines of your post to know the problem
The scssi card is seen as a "new disk" one way or another and the numbering of the disk is changed (sda becomes sdb and so on)
Solution here ... annot_boot
Odd tough this happens without disks connected
Don't fix it if it ain't broken, don't break it if you can't fix it

Bill Auclair

Re: SCSI Adapter Causes Boot Error (SOLVED)

Postby Bill Auclair » Wed Oct 01, 2008 10:45 pm

Thanks for your post, Husse-- changing the /dev/sdx nomenclature to the UUID of my boot drive in MENU.LST did the trick. I'm now able to use my Adaptec SCSI card and HP scanner without adversely affecting my SATA and USB drive mappings. Yet another successful step away from that O/S that starts with "W"..... :-))

-Bill Auclair

Return to “Hardware Support”