Can't install Catalyst 14.6 on linux Mint 17 KDE.

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
TEOn00b
Level 1
Level 1
Posts: 1
Joined: Sat Jun 07, 2014 6:42 pm

Can't install Catalyst 14.6 on linux Mint 17 KDE.

Post by TEOn00b »

First, I must mention that I'm still e newbie in Linux and I'd like to learn as much as possible.

So, I try to install the latest drivers from AMD (14.6) on Linux Mint 17 KDE (I have no drivers installed right now, so everything is clean).
This is how I tried to do it and below is a screenshot with the erros.

Code: Select all

mkdir catalyst14-6 && cd catalyst14-6
wget --referer='http://support.amd.com/en-us/download/desktop?os=Linux%20x86_64#amd-catalyst-packages' www2.ati.com/drivers/beta/linux-amd-catalyst-14.6-beta-v1.0-jul11.zip
unzip linux-amd-catalyst-14.6-beta-v1.0-jul11.zip
It downloads it and everything is OK.

Code: Select all

chmod +x fglrx-14.20/amd-driver-installer-14.20-x86.x86_64.run
sudo ./fglrx-14.20/amd-driver-installer-14.20-x86.x86_64.run --buildpkg Ubuntu/trusty
The package is built and I put my last code before the error appears.

Code: Select all

sudo dpkg -i fglrx*.deb
then the error appear (it is shown in the screenshot). Please help me and try to explain it aswell (because I'm trying to learn and every bit of help is welcome).
Attachments
snapshot2.png
Toetje583
Level 1
Level 1
Posts: 1
Joined: Wed Sep 10, 2014 6:22 pm

Re: Can't install Catalyst 14.6 on linux Mint 17 KDE.

Post by Toetje583 »

Code: Select all

sudo dpkg -i fglrx*.deb
Yes it wil fail again now run:

Code: Select all

sudo apt-get install -f
this will resolve the missing dependencies! :D
Mark Phelps
Level 7
Level 7
Posts: 1856
Joined: Mon Jun 10, 2013 4:39 pm

Re: Can't install Catalyst 14.6 on linux Mint 17 KDE.

Post by Mark Phelps »

(I have no drivers installed right now, so everything is clean).
Actually, you DO have video drivers installed, otherwise, you would not be seeing anything on the screen.

Can't tell what AMD video chipset you're using from the screenshot.

So, open up a terminal and enter "inxi -Gx" and post the output.
Don_Pedro
Level 4
Level 4
Posts: 226
Joined: Sun Jun 23, 2013 11:54 am
Location: Dominican Republic

Re: Can't install Catalyst 14.6 on linux Mint 17 KDE.

Post by Don_Pedro »

Once again here the easiest way to install AMD Catalyst is inside this post : http://forums.linuxmint.com/viewtopic.p ... &t=176939
Cordially
P.
Mint 17 "Qiana", Cinnamon 64-bit 2.0.14 Kernel 3.13.0-27-generic x86_64 Dual Boot W8
Toshiba Satellite Satellite L50D-B Ram:8 GB Quad core AMD A6-6310 APU with AMD Radeon R4 Graphics Firefox/Thunderbird inxi Fxz File
Mark Phelps
Level 7
Level 7
Posts: 1856
Joined: Mon Jun 10, 2013 4:39 pm

Re: Can't install Catalyst 14.6 on linux Mint 17 KDE.

Post by Mark Phelps »

I would strongly caution AGAINST simply forcing the installation of fglrx drivers -- unless you have a relatively recent AMD video chipset.

If you have an older AMD video chipest (AMD HD 2x/3x/4x-series card or older), forcing the installation of these drivers will corrupt your display. Then, you will have to go through a LOT of trouble removing them, only to reinstall the default Radeon drivers that are installed automatically during setup.

You should post the results of the command I asked you to run. That will tell us what AMD video chipset you have in your PC.
Post Reply

Return to “Hardware Support”