Asus: Fn for toggling trackpad

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
jeenuv
Level 2
Level 2
Posts: 67
Joined: Tue Jun 04, 2013 3:34 pm

Asus: Fn for toggling trackpad

Post by jeenuv »

Hi,

I just replaced Mint 17 on my Asus X55C laptop which previously had Mint 15. After installation I noticed that the one Fn key for toggling trackpad doesn't work. It used to work fine on Mint 15. Also it worked fine when I tested Mint 17 on live CD; but somehow stops to function after installation. Interestingly, other Fn keys work, viz. suspend, increase and decrease volume and brightness, mute etc.; it's only with the trackpad that I face the problem.

FWIW, I've both acpi and acpi-support packages installed. I can see there are files for ACPI events under /etc/acpi/events but none that relates to trackpad.

Please suggest how to add event/support for toggling trackpad.

Thanks.

--
Jeenu
Last edited by jeenuv on Sat Sep 06, 2014 6:03 am, edited 2 times in total.

jeenuv
Level 2
Level 2
Posts: 67
Joined: Tue Jun 04, 2013 3:34 pm

Re: Asus: Fn for toggling trackpad

Post by jeenuv »

Bump

jeenuv
Level 2
Level 2
Posts: 67
Joined: Tue Jun 04, 2013 3:34 pm

Re: Asus: Fn for toggling trackpad

Post by jeenuv »

This is getting extremely annoying. I notice that the track pad is enabled at the login screen but can't be controlled using Fn+F9 key. It goes disabled probably 2 seconds into the login process, and thereafter stays disabled. It can't be toggled using the Fn+F9 key any more. Enabling the track pad using pointing device settings doesn't make any difference either - the track pad stays disabled through the entire log in session. I can't find any logs of enable/disable in either dmesg or /var/log/Xorg.log. If I log out of the session, the track pad is back enabled automatically.

Please suggest as to what might be going wrong. What logs can I look at to identify the problem?

JeremyB
Level 20
Level 20
Posts: 11403
Joined: Fri Feb 21, 2014 8:17 am

Re: Asus: Fn for toggling trackpad

Post by JeremyB »

lets see

Code: Select all

rfkill list

Code: Select all

lsmod | grep asus
Sometimes it can be as easy as editing grub to include acpi_osi=Linux

Code: Select all

sudo gedit /etc/default/grub
and go to the line that begins with GRUB_CMDLINE and has "quiet splash" and change it to "acpi_osi=Linux quiet splash"

Save, exit gedit

Code: Select all

sudo update-grub
and reboot. Try the trackpad toggle

jeenuv
Level 2
Level 2
Posts: 67
Joined: Tue Jun 04, 2013 3:34 pm

Re: Asus: Fn for toggling trackpad

Post by jeenuv »

Sometimes it can be as easy as editing grub to include acpi_osi=Linux

Code: Select all

sudo gedit /etc/default/grub
and go to the line that begins with GRUB_CMDLINE and has "quiet splash" and change it to "acpi_osi=Linux quiet splash"

Save, exit gedit

Code: Select all

sudo update-grub
and reboot. Try the trackpad toggle
Yay, it worked! Thank you!

FWIW, here are the output you asked for:

rkill list

Code: Select all

0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: asus-wlan: Wireless LAN
	Soft blocked: no
	Hard blocked: no
2: asus-bluetooth: Bluetooth
	Soft blocked: yes
	Hard blocked: no
lsmod | grep asus

Code: Select all

asus_nb_wmi            16990  0 
asus_wmi               24191  1 asus_nb_wmi
sparse_keymap          13948  1 asus_wmi
wmi                    19177  1 asus_wmi
video                  19476  2 i915,asus_wmi
I shall mark this thread as solved and repost if my system craps out again.

jeenuv
Level 2
Level 2
Posts: 67
Joined: Tue Jun 04, 2013 3:34 pm

Re: Asus: Fn for toggling trackpad

Post by jeenuv »

I notice that this works most of the time. But there are times where the touch pad remains in the state it was during last shut down. When this happens, the touch pad no more responds to Fn+F9 key toggling! I don't know what triggers it though. Then I should try my luck by rebooting or go to 'Pointing Device' and toggle touch pad there.

JeremyB
Level 20
Level 20
Posts: 11403
Joined: Fri Feb 21, 2014 8:17 am

Re: Asus: Fn for toggling trackpad

Post by JeremyB »

jeenuv wrote:I notice that this works most of the time. But there are times where the touch pad remains in the state it was during last shut down. When this happens, the touch pad no more responds to Fn+F9 key toggling! I don't know what triggers it though. Then I should try my luck by rebooting or go to 'Pointing Device' and toggle touch pad there.
Not sure why that would happen, but when the FN+F9 doesn't work, look at

Code: Select all

synclient | grep Touch
And you can also use xinput to see if it is enabled

Code: Select all

xinput
should give you a list, just find the id number for the touchpad and

Code: Select all

 xinput list-props 11 | grep -i enabled
Just replace 11 with whatever the id is for your touchpad

jeenuv
Level 2
Level 2
Posts: 67
Joined: Tue Jun 04, 2013 3:34 pm

Re: Asus: Fn for toggling trackpad

Post by jeenuv »

All of the above do reflect current status of touch pad. For example the synclient output has TouchpadOff value of 1 or 0 depending on whether I have it disabled or enabled, respectively. But I doubt if there's anything that links the Fn key bindings to toggling the hardware :?

jeenuv
Level 2
Level 2
Posts: 67
Joined: Tue Jun 04, 2013 3:34 pm

Re: Asus: Fn for toggling trackpad

Post by jeenuv »

FWIW, xinput list-props 12 | grep -i enabled has this

Code: Select all

	Device Enabled (134):	1
And this is regardless of whether I've had it enabled using 'Pointing Devices' check box!

jeenuv
Level 2
Level 2
Posts: 67
Joined: Tue Jun 04, 2013 3:34 pm

Re: Asus: Fn for toggling trackpad

Post by jeenuv »

I've posted a bug report.

jeenuv
Level 2
Level 2
Posts: 67
Joined: Tue Jun 04, 2013 3:34 pm

Re: Asus: Fn for toggling trackpad

Post by jeenuv »

OK, after some trial and error, I've somewhat isolated the mantra to retain sanity: have touchpad disabled via. Pointing device settings. That way I can toggle touchpad using Fn + F9 key. It's weird!

Post Reply

Return to “Hardware Support”