Page 1 of 1

[SOLVED] Disable NFC chip

Posted: Tue Sep 02, 2014 6:56 pm
by inate71
My laptop has an NFC chip built in. In Windows, there is a way to disable it--however, I have reason to believe that the NFC chip is active when in Linux, despite no feasible way to take advantage of it; I have no use for it, and kept it disabled in Windows anyways.

Upon running the command

Code: Select all

sudo tlp stat
There is a line that sticks out to me:

Code: Select all

Bus 002 Device 002 ID 04cc:2533 control = auto, autosuspend_delay_ms =  2000 -- ST-Ericsson NFC device (PN533) (pn533)
Does that mean it's running and using battery power? I'd like a way to disable it upon reboots. More or less, I just need the command to disable it (I can handle the per reboot).

I appreciate any and all help!

Re: [Q] Disable NFC chip

Posted: Tue Sep 02, 2014 7:09 pm
by JeremyB
Is it listed in

Code: Select all

rfkill list[code]
If the module enabling it is listed in [code]lsmod
you can always blacklist the module, and are there any option in BIOS for this NFC?

Re: [Q] Disable NFC chip

Posted: Tue Sep 02, 2014 7:14 pm
by inate71
JeremyB wrote:Is it listed in

Code: Select all

rfkill list
If the module enabling it is listed in

Code: Select all

lsmod
you can always blacklist the module, and are there any option in BIOS for this NFC?
Yes it is.

Code: Select all

1: nfc0: NFC
	Soft blocked: no
	Hard blocked: no
lsmod reveals

Code: Select all

nfc                    95012  1 pn533
There is no option in the BIOS.

Re: [Q] Disable NFC chip

Posted: Wed Sep 03, 2014 5:04 am
by JeremyB
You might be able to add a line to rc.local to use rfkill to soft block the device.

Code: Select all

sudo gedit /etc/rc.local
And above the line that says exit 0 put

Code: Select all

rfkill block nfc
and save, reboot and

Code: Select all

rfkill list
to see if it is soft blocked

Re: [Q] Disable NFC chip

Posted: Wed Sep 03, 2014 9:34 am
by inate71
JeremyB wrote:You might be able to add a line to rc.local to use rfkill to soft block the device.

Code: Select all

sudo gedit /etc/rc.local
And above the line that says exit 0 put

Code: Select all

rfkill block nfc
and save, reboot and

Code: Select all

rfkill list
to see if it is soft blocked

That did the trick! I appreciate the help. :)