Unable to mount MP3 player - Mint 17 [SOLVED]

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
ClutchDisc
Level 5
Level 5
Posts: 633
Joined: Wed Mar 26, 2014 12:31 pm
Location: Detroit area

Unable to mount MP3 player - Mint 17 [SOLVED]

Post by ClutchDisc »

Hey guys, I got my dad going on Mint 17 Mate instead of Mint 13 Mate. Everything is great, however his MP3 player won't mount. Here is the error message I get when I try to mount the MP3 player.

Code: Select all

Unable to mount Sansa Clip Zip
Unable to open MTP device '[usb:001,009]'
I don't know where to go from there... any help is greatly appreciated. Here is the output of inxi -F from my dads computer:

Code: Select all

~ $ inxi -F
System:    Kernel: 3.13.0-24-generic i686 (32 bit) Desktop: N/A Distro: Linux Mint 17 Qiana
Machine:   System: ASUSTeK product: C51-MCP51
           Mobo: ASUSTek model: Pyrite version: 1.02 Bios: Phoenix version: 5.02 date: 11/30/2006
CPU:       Dual core AMD Athlon 64 X2 3800+ (-MCP-) cache: 1024 KB flags: (lm nx sse sse2 sse3 svm) 
           Clock Speeds: 1: 1000.00 MHz 2: 1000.00 MHz
Graphics:  Card: NVIDIA C51 [GeForce 6150 LE] 
           X.Org: 1.15.1 drivers: (unloaded: fbdev,vesa) FAILED: nouveau Resolution: 1280x1024@60.0hz 
           GLX Renderer: Gallium 0.4 on NV4E GLX Version: 2.1 Mesa 10.1.3
Audio:     Card: NVIDIA MCP51 High Definition Audio driver: snd_hda_intel Sound: ALSA ver: k3.13.0-24-generic
Network:   Card-1: NVIDIA MCP51 Ethernet Controller driver: forcedeth 
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: 00:1a:92:0f:86:30
           Card-2: Gemtek WUBR-177G [Ralink RT2571W] driver: rt73usb 
           IF: wlan0 state: down mac: 00:1a:73:08:87:c5
Drives:    HDD Total Size: 500.1GB (69.8% used) 1: id: /dev/sda model: ST3250820AS size: 250.1GB 
           2: USB id: /dev/sdf model: Storage_Device size: 250.1GB 
Partition: ID: / size: 228G used: 164G (76%) fs: ext4 ID: swap-1 size: 2.08GB used: 0.00GB (0%) fs: swap 
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 160 Uptime: 8:40 Memory: 689.2/1951.5MB Client: Shell inxi: 1.8.4
Last edited by ClutchDisc on Sat Sep 06, 2014 5:35 pm, edited 1 time in total.
Custom build
OS: Linux Mint 18.1 Cinnamon
CPU: Intel Core i5 2.70GHz quad core
RAM: 8GB DDR4
OS drive: 120GB SSD
Data drive: 2TB HDD

User avatar
PatH57
Level 13
Level 13
Posts: 4572
Joined: Tue Mar 25, 2014 12:11 pm
Location: here and there

Re: Unable to mount MP3 player - Mint 17

Post by PatH57 »

Hi,

drive attached:

Code: Select all

lsusb

Code: Select all

mtp-detect
People disagree with me. I just ignore them.
(Linus Torvalds, regarding the use of C++ for the Linux kernel.)

Please Add [Solved] to the topic-title of your first post when appropriate so others know they might find a solution here.

User avatar
mbohets
Level 2
Level 2
Posts: 97
Joined: Sun Apr 28, 2013 8:26 am
Location: Belgium

Re: Unable to mount MP3 player - Mint 17

Post by mbohets »

Can you mount it on another PC ?
Perhaps you need to change a setting on the mp3 player to put it in mpt mode
or perhaps it is defective, or the usb port is defective
Je suis Charlie, how many more people have to die for religion

ClutchDisc
Level 5
Level 5
Posts: 633
Joined: Wed Mar 26, 2014 12:31 pm
Location: Detroit area

Re: Unable to mount MP3 player - Mint 17

Post by ClutchDisc »

Here is the output of "lsusb"

Code: Select all

~ $ lsusb
Bus 001 Device 004: ID 15a9:0004 Gemtek WUBR-177G [Ralink RT2571W]
Bus 001 Device 003: ID 058f:6362 Alcor Micro Corp. Flash Card Reader/Writer
Bus 001 Device 011: ID 0781:74e4 SanDisk Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 0d62:a100 Darfon Electronics Corp. Optical Mouse
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Output of "mtp-detect"

Code: Select all

~ $ mtp-detect
Unable to open ~/.mtpz-data for reading, MTPZ disabled.libmtp version: 1.1.6

Listing raw device(s)
Device 0 (VID=0781 and PID=74e4) is a SanDisk Sansa Clip Zip.
   Found 1 device(s):
   SanDisk: Sansa Clip Zip (0781:74e4) @ bus 1, dev 13
Attempting to connect device(s)
PTP_ERROR_IO: failed to open session, trying again after resetting USB interface
LIBMTP libusb: Attempt to reset device
LIBMTP PANIC: failed to open session on second attempt
Unable to open raw device 0
OK.
Last edited by ClutchDisc on Sat Sep 06, 2014 5:20 pm, edited 1 time in total.
Custom build
OS: Linux Mint 18.1 Cinnamon
CPU: Intel Core i5 2.70GHz quad core
RAM: 8GB DDR4
OS drive: 120GB SSD
Data drive: 2TB HDD

ClutchDisc
Level 5
Level 5
Posts: 633
Joined: Wed Mar 26, 2014 12:31 pm
Location: Detroit area

Re: Unable to mount MP3 player - Mint 17

Post by ClutchDisc »

mbohets wrote:Can you mount it on another PC ?
Perhaps you need to change a setting on the mp3 player to put it in mpt mode
or perhaps it is defective, or the usb port is defective
Going to try another PC now. I don't think its either the USB port, or the player as both worked fine in Mint 13. Don't see any options on the player to put it in mpt mode.
Custom build
OS: Linux Mint 18.1 Cinnamon
CPU: Intel Core i5 2.70GHz quad core
RAM: 8GB DDR4
OS drive: 120GB SSD
Data drive: 2TB HDD

Buzzsaw
Level 6
Level 6
Posts: 1310
Joined: Sat Aug 23, 2014 12:53 pm

Re: Unable to mount MP3 player - Mint 17

Post by Buzzsaw »

To use this mp3 player in Linux, you need to set it to 'MSC' mode, via Settings > System > USB mode.

ClutchDisc
Level 5
Level 5
Posts: 633
Joined: Wed Mar 26, 2014 12:31 pm
Location: Detroit area

Re: Unable to mount MP3 player - Mint 17

Post by ClutchDisc »

Buzzsaw wrote:To use this mp3 player in Linux, you need to set it to 'MSC' mode, via Settings > System > USB mode.
Just figured that out playing around with it! Tried setting it to mpt on the player and it wouldn't show the music files. Switched it to MSC and it works just like it did on Mint 13. Thanks all!! This is now solved. :)
Custom build
OS: Linux Mint 18.1 Cinnamon
CPU: Intel Core i5 2.70GHz quad core
RAM: 8GB DDR4
OS drive: 120GB SSD
Data drive: 2TB HDD

Post Reply

Return to “Hardware Support”