[SOLVED] Microphone does not work on Asus VivoBook S400CA

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
math1985
Level 1
Level 1
Posts: 8
Joined: Mon Jun 23, 2014 3:59 pm

[SOLVED] Microphone does not work on Asus VivoBook S400CA

Post by math1985 » Mon Sep 08, 2014 4:02 pm

My microphone does not work under Linux Mint 17 (64 bit) on my Asus VivoBook S400CA.

In the Sound dialogue, under 'Input' I both see 'Microphone' and 'Analogue Input'. Input Volume is at 100%. When I speak, I see no green lines under 'Input level'. However, when I tick against my case, I see green lines, and on the recording in Audacity I hear a click. I'm testing this under Cinnamon.

Some more details:

Code: Select all

$ uname -a
Linux pc 3.13.0-30-generic #55-Ubuntu SMP Fri Jul 4 21:40:53 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

$ lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
Does anyone have any idea what could cause this?
Last edited by math1985 on Sun Sep 21, 2014 4:48 pm, edited 1 time in total.

User avatar
PatH57
Level 13
Level 13
Posts: 4576
Joined: Tue Mar 25, 2014 12:11 pm
Location: here and there

Re: Microphone does not work on Asus VivoBook S400CA

Post by PatH57 » Tue Sep 09, 2014 3:52 am

Hi,

try this.
Open a terminal

Code: Select all

alsamixer
In this user interface, you can do the following:

Select your correct sound card using F6 and select F5 to see recording controls as well
Move around with left and right arrow keys.
Increase and decrease volume with up and down arrow keys.
Mute/Unmute with the “M” key. An “MM” means muted, and “OO” means unmuted.
Exit from alsamixer with the Esc key.

A caveat here: When you mute or unmute something, pulseaudio might pick it up and mute and unmute other controls, as well as PulseAudio’s main mute.
People disagree with me. I just ignore them.
(Linus Torvalds, regarding the use of C++ for the Linux kernel.)

Please Add [Solved] to the topic-title of your first post when appropriate so others know they might find a solution here.

math1985
Level 1
Level 1
Posts: 8
Joined: Mon Jun 23, 2014 3:59 pm

Re: Microphone does not work on Asus VivoBook S400CA

Post by math1985 » Sun Sep 21, 2014 4:48 pm

Thanks. The problem was the Mic Boost setting, which was set at 100 (by default, I would guess). The microphone only worked with a Mic Boost value of 51 and lower. Thanks again for your help.

jjberk
Level 1
Level 1
Posts: 2
Joined: Wed Dec 23, 2015 2:49 pm

Re: [SOLVED] Microphone does not work on Asus VivoBook S400C

Post by jjberk » Wed Dec 23, 2015 3:31 pm

I had the same problem: microphone working in other applications, but NOT in Skype. This thread had part of the solution, but other steps were necessary.
My system: Asus S400CA with Linux Mint Cinnamon, kernel 3.19.0 (I updated the kernel in the hope it solved this problem, which it didn't) (double boot setup with Windows 8.1, but for the rest of this story Windoze was never booted).

Here is how I solved it:
1) Check if, at boot, udev finds your sound device. (It did).
2) Check if the alsa driver uses it correctly. In my case, I added the line

Code: Select all

    options snd-hda-intel model=auto
at the end of /etc/motprobe.d/alsa-base.conf.
3) Check the settings of the alsa driver in alsamixer. As reported here, the Mic Boost should be reduced. I set it at 51 for both L and R channel.
4) Check the working of Pulse Audio with pavucontrol. Configuration was Analog Stereo Duplex, input device was Analog Input.

Pavucontrol now showed a working microphone. However, after I started Skype, the microphone stopped working. By opening pavucontrol in a terminal window and switching the configuration to something else and then back to Analog Stereo Duplex the microphone worked again in pavucontrol, and it did TOO in Skype!
Conclusion: when Skype starts up, it clobbers somehow the sound settings (Note: "Allow Skype to automatically adjust my mixer levels" was already off.)
So, I closed Skype, edited ~/.Skype/shared.xml and commented out two sections:

Code: Select all

    <Audio>
      <AGCLevel>
        <n48d46d25>24319</n48d46d25>
      </AGCLevel>
      <AGCRange>
        <n48d46d25>65535</n48d46d25>
      </AGCRange>
    </Audio>
and

Code: Select all

      <MicVolume>
        <_1>100</_1>
        <PulseAudio.20server>37</PulseAudio.20server>
      </MicVolume>
and restarted Skype. This time the microphone WORKED, and after rebooting STILL worked in Skype.
Funnily enough, the sections I commented out were added again by Skype, but that made NO difference. Microphone works still after a few cold boots.

I hope others may find this of use.

Post Reply

Return to “Hardware Support”