Resolved----Latitude D600 loads Debian but not Mint-17

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
dvanman
Level 1
Level 1
Posts: 4
Joined: Fri Nov 21, 2014 9:35 pm

Resolved----Latitude D600 loads Debian but not Mint-17

Post by dvanman » Fri Nov 28, 2014 1:26 pm

How can I successfully load Mint-17 onto a Dell Latitude D600 Laptop???
Having successfully loaded MINT-17 on several desktops and laptops I tried to change both of my Dell Latitude D600 laptops from Debian to Mint-17. Using the 32-bit version the initial boot (either DVD or USB stick) starts fine with the LINUX logo on the screen. The computer then freezes with the logo displayed and a row of multicolored pixels across the top of the screen. Computer CPU is Pentium-M @1.66GHZ, 2G RAM.

SOLUTION:
Having tried several flavors of MINT-17 on this Latitude D600 laptop I have found one that works. The Linux Mint "Debian" - 201403 MATE 32 bit downloaded from http://www.linuxmint.com/edition.php?id=99 onto a flash drive installed with no problems or error messages. Both of my D600 laptops have now been converted from XP to MINT-17 under Debian. Attempts to load UBUNTU based versions ended with a frozen screen showing only the LINUX logo and a row of colored pixels across the top of the screen. Evidently the graphics package for UBUNTU based versions conflicts with the graphic hardware of this laptop but the Debian version works just fine.

Thanks to all who responded with suggestions and encouragement.
Last edited by dvanman on Thu Dec 04, 2014 10:40 pm, edited 1 time in total.

User avatar
Kalyk
Level 5
Level 5
Posts: 771
Joined: Wed Mar 12, 2014 5:29 pm
Location: The Netherlands

Re: Latitude D600 loads Debian but not Mint-17

Post by Kalyk » Tue Dec 02, 2014 11:20 am

Hello and welcome to this forum!!

It's most likely a graphics problem.
Before trying to solve this you might first want to try Mint 17.1.
That version solved all my problems where Mint 17 wouldn't boot.
Add (Solved) to the topic-title of the first post when appropriate so others know they might find a solution here.

dvanman
Level 1
Level 1
Posts: 4
Joined: Fri Nov 21, 2014 9:35 pm

Re: Latitude D600 loads Debian but not Mint-17

Post by dvanman » Thu Dec 04, 2014 10:42 am

Thanks for the suggestion. I did try Mint-17.1 and also added another 1-gig stick of Ram but get the same problem. Looks like the old Latitude D600 graphics is just not compatible with Mint. It works fine with PUPPY, IDS, DEBIAN and UBUNTU. I wonder what is so different about MINT????

all41
Level 15
Level 15
Posts: 5670
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: Latitude D600 loads Debian but not Mint-17

Post by all41 » Thu Dec 04, 2014 12:50 pm

This is something unexpected. Here is the inxi output of a lesser Latitude:

Code: Select all

uno@uno-Latitude-D510 ~ $ inxi -Fxz
System:    Host: uno-Latitude-D510 Kernel: 3.13.0-24-generic i686 (32 bit, gcc: 4.8.2) 
           Desktop: N/A Distro: Linux Mint 17.1 Rebecca
Machine:   System: Dell product: Latitude D510
           Mobo: Dell model: 0N8719 Bios: Dell version: A04 date: 12/27/2005
CPU:       Single core Intel Pentium M (-UP-) cache: 2048 KB flags: (nx sse sse2) bmips: 1596.48 clocked at 800.00 MHz 
Graphics:  Card: Intel Mobile 915GM/GMS/910GML Express Graphics Controller bus-ID: 00:02.0 
           X.Org: 1.15.1 drivers: intel (unloaded: fbdev,vesa) Resolution: 1024x768@60.0hz 
           GLX Renderer: Mesa DRI Intel 915GM x86/MMX/SSE2 GLX Version: 1.4 Mesa 10.1.0 Direct Rendering: Yes
Audio:     Card: Intel 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller driver: snd_intel8x0 ports: ed00 ec40 bus-ID: 00:1e.2
           Sound: Advanced Linux Sound Architecture ver: k3.13.0-24-generic
Network:   Card-1: Broadcom BCM4318 [AirForce 54g] 802.11a/b/g PCI Express Transceiver driver: b43-pci-bridge bus-ID: 02:03.0
           IF: wlan0 state: up mac: <filter>
           Card-2: Broadcom BCM4401-B0 100Base-TX driver: b44 ver: 2.0 bus-ID: 02:00.0
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 80.0GB (7.5% used) 1: id: /dev/sda model: HTS548080M9AT00 size: 80.0GB 
Partition: ID: / size: 9.1G used: 5.2G (61%) fs: ext4 ID: /home size: 37G used: 436M (2%) fs: ext4 
           ID: swap-1 size: 2.00GB used: 0.00GB (0%) fs: swap 
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 34.5C mobo: N/A 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 137 Uptime: 19 min Memory: 267.7/993.8MB Runlevel: 2 Gcc sys: 4.8.2 Client: Shell inxi: 1.8.4 
uno@uno-Latitude-D510 ~ $ 
It is dual boot with xp pro

kurotsugi
Level 6
Level 6
Posts: 1038
Joined: Fri Jan 25, 2013 3:54 am

Re: Latitude D600 loads Debian but not Mint-17

Post by kurotsugi » Thu Dec 04, 2014 1:53 pm

if ubuntu works you can use the cinnamon flavour then 'mintify' your system by adding mint's repo into your repo list then install mint's meta packages. I guess that's the easiest way to get mint 17 without debugging your system. since you have old processor the problem might lies on the kernel or the graphic driver as mentioned above. we can try to debug it but it will take long time and there's no guarantee it will succes, especially if mint is using non-compatible kernel.

Post Reply

Return to “Hardware Support”