Touchpad strange behaviour in Mint 17.1

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
cyttorak
Level 1
Level 1
Posts: 38
Joined: Wed Oct 02, 2013 4:24 am

Touchpad strange behaviour in Mint 17.1

Post by cyttorak » Thu Dec 04, 2014 2:30 pm

Hi

When I had Linux Mint 17 Qiana Touchpad worked fine, but now with linux mint 17.1 Rebecca sometimes when I click left button is like I had clicked the right button, in other works, sometimes (no always) left button fire the context menu.

any idea of how fix that?

My laptop is a Acer Aspire Timeline 1810tz

User avatar
DrHu
Level 17
Level 17
Posts: 7539
Joined: Wed Jun 17, 2009 8:20 pm

Re: Touchpad strange behaviour in Mint 17.1

Post by DrHu » Thu Dec 04, 2014 3:03 pm

Your model, ArchLinux info, check touchpad section..
https://wiki.archlinux.org/index.php/Ac ... ine_1810tz

Other data..
http://www.linlap.com/acer_aspire_1410
  • Acer Aspire 1410 (Known as Timeline 1810T or 1810TZ in some parts of Europe)
  • Enable scrolling with the touchpad (right edge of the touchpad area) in the Ubuntu menu under “System” > “Preferences” > “Mouse”. Then select the touchpad tab and enable the two finger scrolling.
    Two-finger scroll is enabled by typing these lines in a terminal window :
    synclient EmulateTwoFingerMinW=7
    synclient EmulateTwoFingerMinZ=20
    synclient VertTwoFingerScroll=1
Mint should be similar..

Based on your description of what a left click looks like to you, I might suspect finger droop on the pad ??

pgyure
Level 1
Level 1
Posts: 7
Joined: Tue Dec 04, 2012 7:13 pm

Re: Touchpad strange behaviour in Mint 17.1

Post by pgyure » Tue Dec 09, 2014 12:17 pm

Hi!

I just did an update to the latest kernel, and worked fine. ;)

Give it a try!

jadek
Level 1
Level 1
Posts: 38
Joined: Sun Sep 05, 2010 9:30 pm

Re: Touchpad strange behaviour in Mint 17.1

Post by jadek » Thu Dec 11, 2014 3:43 pm

Similarly, edge-scrolling worked fine for me with an MSI laptop and LM 16. Now with a Lenovo B50 and Rebecca it does not. Selecting that option in the Mouse and Touchpad area of Settings has no effect.

Pgyure, when you say it worked fine upon updating to the latest the kernel, is that doing that on your own, in other words not through the Update Manager?

Next month marks the 3rd year anniversary of moving to Linux Mint (from Windows) as my main O.S. The more time goes by, the more glad I am.

P.S. - If it makes a difference, the terminal reveals that it is an Elantech touchpad.

greg_t
Level 1
Level 1
Posts: 2
Joined: Sat Jan 03, 2015 12:59 am

Re: Touchpad strange behaviour in Mint 17.1

Post by greg_t » Sat Jan 03, 2015 1:14 am

Same problem here, on a Lenovo Thinkpad x201. I've experimented with this enough to know that it's more than a case of me accidentally hitting the touchpad while using the left mouse button. There's something going wrong, but only intermittently, which is the worst kind of bug to diagnose. Before seeing this thread, I'd even tried disassembling my laptop and cleaning the contact pads on the mouse buttons. I've tried using Update Manager to upgrade to the latest kernel, but it didn't help. I'm using a USB mouse as a workaround.

cyttorak
Level 1
Level 1
Posts: 38
Joined: Wed Oct 02, 2013 4:24 am

Re: Touchpad strange behaviour in Mint 17.1

Post by cyttorak » Sat Jan 03, 2015 7:01 am

Hi

My problem finally was that in touchpad preferences I had checked "Emular botón central pulsando simultaneamente los botones izquierdo y derecho" or "Emulación de click de dos dedos" (now I can't remember well)

My mint is in Spanish, so I don't know how are called that preferences in English but it was ones set the behaviour when you use two finger in the touchpad or do click in right and left bottom as the same time. The problem was that with that configuration I was doing right click inadvertently.

greg_t
Level 1
Level 1
Posts: 2
Joined: Sat Jan 03, 2015 12:59 am

Re: Touchpad strange behaviour in Mint 17.1

Post by greg_t » Sun Jan 04, 2015 9:17 pm

Thanks. I had already disabled "Emulate middle click" under the "Mouse" tab, but hadn't noticed the "Options for single-button touchpads" under the "Touchpad" tab. Mine has two buttons, so I disabled both options and that seems to have helped.

abrams
Level 1
Level 1
Posts: 3
Joined: Fri Sep 20, 2013 1:39 pm

Re: Touchpad strange behaviour in Mint 17.1

Post by abrams » Tue Jan 06, 2015 3:22 am

Hi,
I have same behavior on Lenovo W520. It occours after closing the laptop, wait till sleep and reopen it. But it affects also only the bottom Touchpad buttons. The top Buttons works good. But after a while it seems to switch the touchpat buttons also.
System:
Linux Mint Cinnamon 17.1 64Bit
Kernel 3.13.0.37
NVidia Optimus Card in NVidia only Mode

This is just for Information, can live with that. Can do some tests if wanted.

stranda
Level 1
Level 1
Posts: 1
Joined: Sat Jan 10, 2015 10:57 am

Re: Touchpad strange behaviour in Mint 17.1

Post by stranda » Sat Jan 10, 2015 11:24 am

Hi,

I am also having these touchpad issues in 17.1 on a fresh install on a fujitsu t900. Previous posters have described the problem perfectly.
I've updated to the latest kernel and the version is 3.13.0-37-generic.
Unlike two previous posters, I don't seem to have the ability to choose between single and two button trackpads under mouse and touchpad properties, however.

FYI...

Post Reply

Return to “Hardware Support”