Linux mint 17 sound problem

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
ticesevra
Level 1
Level 1
Posts: 5
Joined: Tue Dec 30, 2014 4:42 pm

Linux mint 17 sound problem

Post by ticesevra » Tue Dec 30, 2014 4:46 pm

First, I installed mint 13 xfce and I didn't get any sound at all. That was few days ago. Today, I installed mint 17 xfce and again, no sound. I did apt-get update and apt-get upgrade and now I have 17.1, right? Anyway, sound doesn't work neither.
I don't hear any sound in vlc player and on youtube. Can someone help me? I came through few topics about this problem, I upgraded the system as you see but the problem is still here and I didn't find any solution on topics I read :/

This is my sound card: http://www.dodaj.rs/f/15/nO/2BwHeCpW/sc ... 4-2133.png

Thanks in advance

P.S. On windows xp, everything is fine.

User avatar
nomko
Level 10
Level 10
Posts: 3026
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Re: Linux mint 17 sound problem

Post by nomko » Wed Dec 31, 2014 7:43 am

Ok first things first, you're sure that you enabled your soundcard? And also turned on the volume? It seems to be a rather old sound device. Try this:
  • Open a terminal
  • Type the following command:

    Code: Select all

    sudo leafpad /etc/modprobe.d/alsa-base.conf
  • At the bottom of the file add the following line:
    options snd-hda-intel model=generic
  • Reboot your system

ticesevra
Level 1
Level 1
Posts: 5
Joined: Tue Dec 30, 2014 4:42 pm

Re: Linux mint 17 sound problem

Post by ticesevra » Sun Jan 04, 2015 9:46 am

Did that, but the problem is still there :/

User avatar
Flemur
Level 16
Level 16
Posts: 6098
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Linux mint 17 sound problem

Post by Flemur » Sun Jan 04, 2015 10:54 am

Linux is terrible with audio....

Today, I installed mint 17 xfce and again, no sound. I did apt-get update and apt-get upgrade and now I have 17.1, right?

It's still Mint17.

I don't hear any sound in vlc ...

Did you try vlc->audio->Audio Device ? Are there entries there besides "discard"?

Mine shows about 20 "sound devices" even though there's really only one...<sigh>.
They're called "HDA Nvidia ...buncha nonsense",
Yours should be something like "HDA Intel..." Like I said, linux is terrible with sound.
You probably want to select "Pulseaudio sound server" (the first real "device" in my list even tho it's not installed). Did I mention that linux is terrible with sound?

There are several places where you can mute the sound, check:
- alsamixer (e.g. your picture); set all outputs to loudest. If you see "digital", set it to the middle (alsamixer is too primitive to let you enter numerical values. qasmixer is a much better mixer.)
- pavucontrol (might have to install). On my system, muting via the sound icon couldn't be un-muted except by pavucontrol. Look thru all the tabs.

Try removing /home/username/.pulse* file(s). Reboot.

Good luck!
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

ticesevra
Level 1
Level 1
Posts: 5
Joined: Tue Dec 30, 2014 4:42 pm

Re: Linux mint 17 sound problem

Post by ticesevra » Tue Jan 06, 2015 3:42 am

Yes, in vlc there is built-in audio analog stereo. Nothing happens when I select it though...

I don't have any .pulse files in home/username and yes, I searched for hidden files but nothing.

antcj
Level 2
Level 2
Posts: 98
Joined: Thu Jun 28, 2012 11:17 pm

Re: Linux mint 17 sound problem

Post by antcj » Tue Jan 06, 2015 2:06 pm

had similar issues, seems card on pc was defective.i got past it by buying a usb audio adaptor online.
http://www.aliexpress.com/item/1pcs-Hig ... 90660.html.

ticesevra
Level 1
Level 1
Posts: 5
Joined: Tue Dec 30, 2014 4:42 pm

Re: Linux mint 17 sound problem

Post by ticesevra » Tue Jan 20, 2015 4:38 am

antcj wrote:had similar issues, seems card on pc was defective.i got past it by buying a usb audio adaptor online.
http://www.aliexpress.com/item/1pcs-Hig ... 90660.html.
This one works on Windows XP, as I said in the first post :P

ticesevra
Level 1
Level 1
Posts: 5
Joined: Tue Dec 30, 2014 4:42 pm

Re: Linux mint 17 sound problem

Post by ticesevra » Thu Feb 26, 2015 10:17 am

I bought usb sound card and I solved the problem.
Thanks everyone for help :)

Post Reply

Return to “Hardware Support”