Device that formerly mounted with GVFS now mounts with MTP

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
dpitch40
Level 1
Level 1
Posts: 35
Joined: Sun Nov 11, 2012 7:12 pm

Device that formerly mounted with GVFS now mounts with MTP

Postby dpitch40 » Tue Mar 24, 2015 12:23 am

When I was using an older version of Linux Mint (I believe 14), my Sony Walkman would automatically mount with GVFS and be accessible as a normal external file system. Ever since I installed 17 (and now 17.1), it mounts as an MTP device which is slower and can't be accessed like a normal file system; in particular, it is no longer accessible to Python except through a hard-to-use and buggy module, which breaks the script I had been using to sync to it. It also no longer works in conjunction with Banshee, even though Bansee is supposed to support MTP. I think that this PPA is supposed to allow MTP devices to be accessed via GVFS, which sounds just like what I used to be able to do. Has it been removed from newer Linux Mint installations? I tried the following steps to install it:

Code: Select all

sudo add-apt-repository ppa:langdalepl/gvfs-mtp
sudo apt-get update
sudo apt-get dist-upgrade


But this does not appear to have solved the problem. What am I doing wrong?

User avatar
mank_in
Level 6
Level 6
Posts: 1359
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: Device that formerly mounted with GVFS now mounts with M

Postby mank_in » Tue Mar 24, 2015 3:06 am

ppa:langdalepl/gvfs-mtp is for ubuntu 12.04,12.10, and 13.04 (LM 13,14 and 15 ), not for LM 17 ( based on ubuntu 14.04)

what is your sony device id , maybe we can try blocking libmtp for detecting it as mtp device.
connect device to computer and post output of terminal command:

Code: Select all

lsusb


Edit : I found this article, maybe it will help you : http://ducakedhare.co.uk/?p=1317
Image
Sorry for my bad English , I am Indonesian.

dpitch40
Level 1
Level 1
Posts: 35
Joined: Sun Nov 11, 2012 7:12 pm

Re: Device that formerly mounted with GVFS now mounts with M

Postby dpitch40 » Tue Mar 24, 2015 7:01 pm

Code: Select all

Bus 002 Device 005: ID 5986:0364 Acer, Inc
Bus 002 Device 004: ID 1852:7022 GYROCOM C&C Co., LTD
Bus 002 Device 006: ID 054c:05a6 Sony Corp.
Bus 002 Device 003: ID 0461:4d42 Primax Electronics, Ltd
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 10ab:0816 USI Co., Ltd
Bus 001 Device 003: ID 0bda:0139 Realtek Semiconductor Corp. RTS5139 Card Reader Controller
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I'm guessing it's the Sony one. I would rather not have to manually mount/unmount the Walkman with a terminal command; I did not need to do this before.

dpitch40
Level 1
Level 1
Posts: 35
Joined: Sun Nov 11, 2012 7:12 pm

Re: Device that formerly mounted with GVFS now mounts with M

Postby dpitch40 » Tue Mar 24, 2015 8:04 pm

mank_in wrote:ppa:langdalepl/gvfs-mtp is for ubuntu 12.04,12.10, and 13.04 (LM 13,14 and 15 ), not for LM 17 ( based on ubuntu 14.04)


Is this why my device automatically mounted as GVFS in Linux Mint 14?

User avatar
mank_in
Level 6
Level 6
Posts: 1359
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: Device that formerly mounted with GVFS now mounts with M

Postby mank_in » Wed Mar 25, 2015 12:56 am

dpitch40 wrote:Is this why my device automatically mounted as GVFS in Linux Mint 14?


From that PPA description :
13.10 (Saucy) and newer versions of Ubuntu contain all of these changes, so you don't need to use this ppa any more.

MTP is slower because :quote from Wikipedia :
MTP allows no parallelism, unlike USB mass storage or NAS. MTP has been built to only allow a single operation at a time (for example, read, write or delete operation), while no other operation can be executed until the previous operation is complete.

I don't know if this will work but you can try edit : /lib/udev/rules.d/69-libmtp.rules
search for # Sony NWZ-E464
It will show you the rule for device is:
ATTR{idVendor}=="054c", ATTR{idProduct}=="05a6", SYMLINK+="libmtp-%k", MODE="660", GROUP="audio", ENV{ID_MTP_DEVICE}="1", ENV{ID_MEDIA_PLAYER}="1"

add # in front of line ATTR to disable the rule, to:

#ATTR{idVendor}=="054c", ATTR{idProduct}=="05a6", SYMLINK+="libmtp-%k", MODE="660", GROUP="audio", ENV{ID_MTP_DEVICE}="1", ENV{ID_MEDIA_PLAYER}="1"

Reboot , If not working or your walkman not recognize you can remove the # again
You can try change ENV{ID_MTP_DEVICE}="1" and ENV{ID_MEDIA_PLAYER}="1" to "0" too
Image
Sorry for my bad English , I am Indonesian.

dpitch40
Level 1
Level 1
Posts: 35
Joined: Sun Nov 11, 2012 7:12 pm

Re: Device that formerly mounted with GVFS now mounts with M

Postby dpitch40 » Wed Mar 25, 2015 11:07 pm

When I try that, the Walkman mounts as gphoto2://[usb:002,006]/. When I start Banshee, my Walkman unmounts and is unable to be mounted again even after I quit Banshee, saying something about a camera error (which is strange since it doesn't have a camera)... Ever since my Walkman started mounting as MTP, it has been incompatible with Banshee; I can't have it mounted when Banshee is running. (Even though Banshee is supposed to have MTP support...) Why is this happening if newer versions of Ubuntu contain the PPA already?


Return to “Hardware Support”