Can't get Nvida drivers working [SOLVED]

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
Yatoom
Level 1
Level 1
Posts: 16
Joined: Mon Sep 15, 2014 12:00 am

Can't get Nvida drivers working [SOLVED]

Post by Yatoom » Thu Apr 23, 2015 4:57 pm

Hi, I have tried almost everything (see list of things I tried below). I hope anyone can help me with setting up my nvidia drivers properly. I'm running Mint 17.

The system has Nvidia Optimus technology, but I'm currently in Discrete Graphics mode, so only the Nvidia driver is relevant for now.

Code: Select all

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108GLM [Quadro 1000M] (rev a1
To have a clear initial state, I removed all nvidia and bumblebee drivers.

Code: Select all

# apt purge nvidia* bumblebee* 
Then, I installed the nvidia-331 drivers, and executed nvidia-xconfig to make my xorg config file, and then rebooted.

Code: Select all

# apt install nvidia-331
# nvidia-xconfig
# reboot
That's it. Well, it does not work. :roll: More info?

Code: Select all

$ lspci -nnk | grep -i vga -A2
00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09)
        Subsystem: Lenovo Device [17aa:21d1]
        Kernel driver in use: i915
--
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108GLM [Quadro 1000M] [10de:0dfa] (rev a1)
        Subsystem: Lenovo Device [17aa:21d1]
        Kernel driver in use: nvidia

$ modinfo nvidia
modinfo: ERROR: Module nvidia not found.

$modinfo nvidia-331
filename:       /lib/modules/3.13.0-37-generic/kernel/drivers/char/drm/nvidia_331.ko
alias:          char-major-195-*
version:        331.113
supported:      external
license:        NVIDIA
alias:          pci:v000010DEd00000E00sv*sd*bc04sc80i00*
alias:          pci:v000010DEd00000AA3sv*sd*bc0Bsc40i00*
alias:          pci:v000010DEd*sv*sd*bc03sc02i00*
alias:          pci:v000010DEd*sv*sd*bc03sc00i00*
depends:        drm
vermagic:       3.13.0-37-generic SMP mod_unload modversions 
parm:           NVreg_Mobile:int
parm:           NVreg_ResmanDebugLevel:int
parm:           NVreg_RmLogonRC:int
parm:           NVreg_ModifyDeviceFiles:int
parm:           NVreg_DeviceFileUID:int
parm:           NVreg_DeviceFileGID:int
parm:           NVreg_DeviceFileMode:int
parm:           NVreg_RemapLimit:int
parm:           NVreg_UpdateMemoryTypes:int
parm:           NVreg_InitializeSystemMemoryAllocations:int
parm:           NVreg_UsePageAttributeTable:int
parm:           NVreg_MapRegistersEarly:int
parm:           NVreg_RegisterForACPIEvents:int
parm:           NVreg_CheckPCIConfigSpace:int
parm:           NVreg_EnablePCIeGen3:int
parm:           NVreg_EnableMSI:int
parm:           NVreg_MemoryPoolSize:int
parm:           NVreg_RegistryDwords:charp
parm:           NVreg_RmMsg:charp
parm:           NVreg_AssignGpus:charp
Did something go wrong there with the naming?

Okay, lastly, I'll drop the xorg.conf.

Code: Select all

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 331.113  (buildmeister@swio-display-x64-rhel04-03)  Mon Dec  1 21:15:34 PST 2014


Section "ServerLayout"
    Identifier     "TwinLayout"
    Screen      0  "metaScreen" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "keyboard"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    Option         "Enable" "true"
EndSection

Section "Monitor"
    Identifier     "Monitor1"
    Option         "Enable" "true"
EndSection

Section "Device"

    #refer to the link below for more information on each of the following options.
    Identifier     "Card0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "metaScreen"
    Device         "Card0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "True"
    Option         "HorizSync" "DFP-0: 28-33; DFP-1 28-33"
    Option         "VertRefresh" "DFP-0: 43-73; DFP-1 43-73"
    Option         "MetaModes" "1600x900, 1600x900"
    Option         "ConnectedMonitor" "DFP-0, DFP-1"
    Option         "MetaModeOrientation" "DFP-1 LeftOf DFP-0"
    SubSection     "Display"
        Depth       24
        Modes      "1600x900"
    EndSubSection
EndSection
List of things I have tried:
http://askubuntu.com/questions/451335/c ... nvidia-gpu (fixed that specific issue for me)
http://www.unixreich.com/blog/2013/linu ... ly-solved/ (could not install intel-virtual-output)
https://bugs.launchpad.net/ubuntu/+sour ... ug/1247528 (could not create a deb file for intel-virtual-output)
https://help.ubuntu.com/community/Binar ... wto/Nvidia (no success)
http://askubuntu.com/questions/290443/b ... s-detected (don't know if anything changed)
http://www.nvidia.com/download/driverRe ... 4043/en-us (installed but no success)
https://bugs.launchpad.net/ubuntu/+sour ... ug/1268257 (reconfigured nvidia-331 and installed nvidia-uvm)
http://forums.linuxmint.com/viewtopic.php?f=59&t=178414 (All of that stuff, OP is me)
https://bbs.archlinux.org/viewtopic.php?id=84296 (no answer)
https://wiki.archlinux.org/index.php/Bumblebee (all of this stuff)
https://wiki.archlinux.org/index.php/NVIDIA_Optimus (and this stuff too)
https://github.com/Bumblebee-Project/Bu ... itor-setup (for multi-monitor setup)

And nothing worked.
Last edited by Yatoom on Thu Apr 23, 2015 7:19 pm, edited 1 time in total.

User avatar
Pjotr
Level 20
Level 20
Posts: 10960
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Can't get Nvida drivers working

Post by Pjotr » Thu Apr 23, 2015 5:02 pm

You might try this:
Install the nvidia-349 by means of the mamarley PPA:
https://sites.google.com/site/easylinux ... nvidia-PPA
(item 1, left column)
Tip: 10 things to do after installing Linux Mint 19 Tara
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

User avatar
Flemur
Level 16
Level 16
Posts: 6184
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Can't get Nvida drivers working

Post by Flemur » Thu Apr 23, 2015 5:06 pm

Code: Select all

Kernel driver in use: nvidia
What makes you think it's not working? What do you get from
$ nvidia-settings
?
(or $ sudo nvidia-settings)
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

Yatoom
Level 1
Level 1
Posts: 16
Joined: Mon Sep 15, 2014 12:00 am

Re: Can't get Nvida drivers working

Post by Yatoom » Thu Apr 23, 2015 5:24 pm

Flemur wrote:

Code: Select all

Kernel driver in use: nvidia
What makes you think it's not working? What do you get from
$ nvidia-settings
?
(or $ sudo nvidia-settings)
Because there is no nvidia spash screen, glxgears does not run, and cinnamon goes into fallback mode.
Output of nvidia-settings below, screenshot here.

Code: Select all

nvidia-settings
** Message: PRIME: Requires offloading
** Message: PRIME: is it supported? yes

Yatoom
Level 1
Level 1
Posts: 16
Joined: Mon Sep 15, 2014 12:00 am

Re: Can't get Nvida drivers working

Post by Yatoom » Thu Apr 23, 2015 5:29 pm

This might be relevant as well:

Code: Select all

# cat Xorg.0.log | grep "(EE)"
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    46.414] (EE) No devices detected.
[    46.585] (EE) [drm] KMS not enabled
[    46.664] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)

zerozero
Level 16
Level 16
Posts: 6506
Joined: Tue Jul 07, 2009 2:29 pm

Re: Can't get Nvida drivers working

Post by zerozero » Thu Apr 23, 2015 6:20 pm

i'm not absolutely sure about the support that the 331 drivers have for your card; you might need an updated driver that better supports it;

but i'm sure that
Yatoom wrote:and executed nvidia-xconfig to make my xorg config file
breaks the bumblebee config
https://github.com/Bumblebee-Project/Bu ... leshooting
https://wiki.debian.org/NvidiaGraphicsDrivers#configure
Image

[ bliss of ignorance ]

Yatoom
Level 1
Level 1
Posts: 16
Joined: Mon Sep 15, 2014 12:00 am

Re: Can't get Nvida drivers working

Post by Yatoom » Thu Apr 23, 2015 6:47 pm

zerozero wrote:but i'm sure that
Yatoom wrote:and executed nvidia-xconfig to make my xorg config file
breaks the bumblebee config
I was not using bumblebee, but you led me to the right direction :)
If you've generated /etc/X11/xorg.conf using nvidia-xconfig, remove that file. It's not compatible with Optimus laptops
So, it breaks it even when bumblebee is not installed.

I'm kind of sure that 331 drivers have support for my card, since I got nvidia running with it (except in small screen resolution due to another problem), but I think it also worked before. But I installed the 340 drivers anyway, and those work as well.

Yatoom
Level 1
Level 1
Posts: 16
Joined: Mon Sep 15, 2014 12:00 am

Re: Can't get Nvida drivers working

Post by Yatoom » Thu Apr 23, 2015 7:18 pm

Okay, good job guys, everything works :D

So, steps to get a working system:

1. Clean all previous drivers and their configuration files:

Code: Select all

# apt purge nvidia* bumblebee*
2. Remove xorg.conf

Code: Select all

# sudo rm /etc/X11/xorg.conf
3. You could install nvidia-331 drivers, but it is probably better to follow instructions on https://sites.google.com/site/easylinux ... nvidia-PPA
a) Determine which driver supports your graphics card
b) Install that one (I think you also have to install all suggested and recommended packages (except maybe bumblebee, but I don't think it will harm) which you will see somewhere on top when you do the apt install.

4. Reboot
I think this also sets your xorg.conf right.

-- Optional part for multi-monitor setup --

5. Edit Xorg.conf configuration for multi-monitor setup
You must outcomment this line.

Code: Select all

#    Option "IgnoreDisplayDevices" "CRT"
6. Reboot

7. Install and run arandr, so you can easily setup your monitors. (I got some issues here previously where X would crash if I tried to put my laptop-screen to the right of the extended screen, but now they seem to be fixed (maybe because of nvidia-340 drivers?))

EDIT: Previously I told you guys to outcomment Option "AllowEmptyInitialConfiguration" "on" as well. Don't do this! This option allows the X server to start with screens that are not configured (a second monitor). When it is outcommented, the X server does not start and reconfigures itself, resetting the xorg.conf file.

Post Reply

Return to “Hardware Support”