[problem] Screen not displaying with full-screen apps

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
User avatar
gravity0
Level 1
Level 1
Posts: 7
Joined: Sat Dec 13, 2008 9:48 am

[problem] Screen not displaying with full-screen apps

Postby gravity0 » Sat Dec 13, 2008 10:00 am

Hello,
I am new to the forum and I have a big problem. When I try to start full-screen applications (like games) my monitor becomes black and says "Not optimal resoltuion, Suggested: 1280x1024 @ 60 Hz" (it should be a sort of safe handling of strange resolutions or refresh rates). I am using Linux Mint 5 x64 Edition, with all the updates of the case with the NVIDIA Official Drivers.

My specs:
Amd Athlon 64 3500+
1 GB RAM
NVIDIA 7600 GS 256 MB
Samsung Syncmaster 741MP.

A strange thing i noticed is that in the NVIDIA Control Panel (nvidia-settings) the screen refresh rates are correct (60Hz and 75Hz) but in the GNOME Control Panel they are 50Hz, 51Hz and 90Hz. Could be these wrong values my problem? Maybe the XOrg server cannot detect correctly my monitor refresh rates?

Thanks in advance for the help,

EDIT: I need help cause all my linux distros had this problem and I need them to play my games on lin (so winzoz will be removed)

Mattias
Documentation is like sex.
When it's well made, it's well made.
When it's not well made, it's better than nothing.
When there isn't, it's a desperation!

Husse
Level 23
Level 23
Posts: 19593
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: [problem] Screen not displaying with full-screen apps

Postby Husse » Sat Dec 13, 2008 6:19 pm

Try to add

Code: Select all

Option "DynamicTwinView" "False"

to Section "Device" in your /etc/xorg.conf file

Code: Select all

gksu gedit  /etc/xorg.conf

in main
After that nvidia-settings may no work but it could help.
Obviously don't do it if you have more than one monitor
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

User avatar
gravity0
Level 1
Level 1
Posts: 7
Joined: Sat Dec 13, 2008 9:48 am

Re: [problem] Screen not displaying with full-screen apps

Postby gravity0 » Sun Dec 14, 2008 9:24 am

thank you... np I have only one monitor! :)


Return to “Hardware Support”

Who is online

Users browsing this forum: Bing [Bot] and 5 guests