Fresh Install, No sound, as much detail inside as i know!

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
alexdodd
Level 1
Level 1
Posts: 3
Joined: Mon Jul 27, 2015 4:43 pm

Fresh Install, No sound, as much detail inside as i know!

Post by alexdodd » Mon Jul 27, 2015 5:29 pm

Hey guys!

This is my inxi output:

Code: Select all

System:    Host: alex-Lenovo Kernel: 3.16.0-38-generic i686 (32 bit, gcc: 4.8.2) 
           Desktop: Cinnamon 2.6.13  Distro: Linux Mint 17.2 Rafaela
Machine:   System: Acer product: Aspire 5600
           Mobo: Acer model: Bodensee2 Bios: Acer version: v0.3119 date: 06/08/06
CPU:       Dual core Intel CPU T2300 (-MCP-) cache: 2048 KB flags: (nx pae sse sse2 sse3) bmips: 6667.08 
           Clock Speeds: 1: 1667.00 MHz 2: 1667.00 MHz
Graphics:  Card: Intel Mobile 945GM/GMS 943/940GML Express Integrated Graphics Controller bus-ID: 00:02.0 
           X.org: 1.15.1 drivers: intel (unloaded: fbdev,vesa) tty size: 144x34 Advanced Data: N/A for root 
Audio:     Card: Intel NM10/ICH7 Family High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0 
           Sound: Advanced Linux Sound Architecture ver: k3.16.0-38-generic
Network:   Card-1: Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter 
           driver: 8139too ver: 0.9.28 port: 2000 bus-ID: 0a:00.0
           IF: eth1 state: down mac: <filter>
           Card-2: Intel PRO/Wireless 3945ABG [Golan] Network Connection driver: iwl3945 ver: in-tree:s bus-ID: 02:00.0
           IF: wlan0 state: up mac: <filter>
Drives:    HDD Total Size: 80.0GB (6.9% used) 1: id: /dev/sda model: HTS541080G9AT00 size: 80.0GB temp: 35C 
Partition: ID: / size: 73G used: 5.2G (8%) fs: ext4 ID: swap-1 size: 1.06GB used: 0.27GB (26%) fs: swap 
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 50.0C mobo: N/A 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 163 Uptime: 1:56 Memory: 322.4/994.2MB Runlevel: 2 Gcc sys: 4.8.4 
           Client: Shell (bash 4.3.11) inxi: 1.9.17 
and my lsmod:

Code: Select all

Module                  Size  Used by
btrfs                 884339  0 
xor                    26221  1 btrfs
raid6_pq               97455  1 btrfs
ufs                    73628  0 
qnx4                   13099  0 
hfsplus                93074  0 
hfs                    49390  0 
minix                  31317  0 
ntfs                   95670  0 
msdos                  17093  0 
jfs                   170051  0 
xfs                   804242  0 
libcrc32c              12543  1 xfs
ctr                    12905  1 
ccm                    17496  1 
rfcomm                 58045  0 
bnep                   18895  2 
bluetooth             391253  10 bnep,rfcomm
6lowpan_iphc           18262  1 bluetooth
binfmt_misc            13140  1 
snd_hda_codec_si3054    12928  1 
snd_hda_codec_realtek    70514  1 
acer_wmi               31770  0 
snd_hda_codec_generic    62931  1 snd_hda_codec_realtek
sparse_keymap          13708  1 acer_wmi
arc4                   12536  2 
snd_hda_intel          29285  3 
snd_hda_controller     29252  1 snd_hda_intel
iwl3945                63639  0 
snd_hda_codec         120400  5 snd_hda_codec_realtek,snd_hda_codec_si3054,snd_hda_codec_generic,snd_hda_intel,snd_hda_controller
iwlegacy               87977  1 iwl3945
snd_hwdep              13272  1 snd_hda_codec
mac80211              563196  2 iwl3945,iwlegacy
snd_pcm                87194  6 snd_hda_codec_si3054,snd_hda_codec,snd_hda_intel,snd_hda_controller
snd_seq_midi           13324  0 
snd_seq_midi_event     14475  1 snd_seq_midi
cfg80211              422935  3 iwl3945,iwlegacy,mac80211
snd_rawmidi            25722  1 snd_seq_midi
snd_seq                56592  2 snd_seq_midi_event,snd_seq_midi
snd_seq_device         14137  3 snd_seq,snd_rawmidi,snd_seq_midi
dm_multipath           22373  0 
snd_timer              28648  2 snd_pcm,snd_seq
pcmcia                 51828  0 
scsi_dh                14458  1 dm_multipath
coretemp               13201  0 
snd                    66670  15 snd_hda_codec_realtek,snd_hda_codec_si3054,snd_hwdep,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel,snd_seq_device
lpc_ich                16877  0 
joydev                 17113  0 
yenta_socket           40215  0 
soundcore              14599  2 snd,snd_hda_codec
serio_raw              13251  0 
tifm_7xx1              13182  0 
pcmcia_rsrc            18319  1 yenta_socket
tifm_core              15133  1 tifm_7xx1
shpchp                 32143  0 
pcmcia_core            22328  3 pcmcia,pcmcia_rsrc,yenta_socket
parport_pc             32021  0 
tpm_infineon           16979  0 
ppdev                  17391  0 
lp                     13299  0 
mac_hid                13059  0 
parport                40836  3 lp,ppdev,parport_pc
dm_mirror              21756  0 
dm_region_hash         20121  1 dm_mirror
dm_log                 18072  2 dm_region_hash,dm_mirror
i915                  808675  4 
i2c_algo_bit           13197  1 i915
8139too                32588  0 
8139cp                 27183  0 
sdhci_pci              18640  0 
drm_kms_helper         55007  1 i915
mii                    13654  2 8139cp,8139too
psmouse                99602  0 
sdhci                  38345  1 sdhci_pci
drm                   255469  6 i915,drm_kms_helper
pata_acpi              12901  0 
wmi                    18689  1 acer_wmi
video                  19475  2 i915,acer_wmi
I've tried a few different tutorials googling around, and i'm worried i'll do more harm than good before time. A little knowledge etc... :D

Sound seems to be somewhat of an issue it seems? :( Essentially I only have the dummy mixer visible. Driver issue?

Any help much appreciated, as this laptop is for my mum and I only really need it to play music (spotify) and have the internet and writer! 2 out of 3 so far 8)
Last edited by alexdodd on Mon Jul 27, 2015 11:11 pm, edited 1 time in total.

alexdodd
Level 1
Level 1
Posts: 3
Joined: Mon Jul 27, 2015 4:43 pm

Re: Fresh Install, No sound, as much detail inside as i know

Post by alexdodd » Mon Jul 27, 2015 10:46 pm

As a little update I have now worked my way through all the 3.16.0-xx kernels available, and 3.19.0-18. Currently reverted back to 3.16.0-45 (last of the 3.16.0-xx's) for now, as 17.2 was built around that :)

glhallway
Level 1
Level 1
Posts: 42
Joined: Thu Jun 13, 2013 4:29 pm

Re: Fresh Install, No sound, as much detail inside as i know

Post by glhallway » Tue Jul 28, 2015 11:46 am

Go to menu-system settings-sound and be sure it isn't set for S/PDIF but to HDMI (or what ever sound output device you have). When I first installed Mint it set the sound to S/PDIF instead of HDMI all I had to do was change to HDMI and it worked. It's worth a try.

alexdodd
Level 1
Level 1
Posts: 3
Joined: Mon Jul 27, 2015 4:43 pm

Re: Fresh Install, No sound, as much detail inside as i know

Post by alexdodd » Wed Jul 29, 2015 10:13 pm

Ok so I now have to do everything remotely because i'm back in Edinburgh, and this is in my mums poesession in the Liverpool.

Anyhoo, although I haven't tried that, I'm not sure it is that, since the sound settings are only using the dummy mixed as hardware?

I'll try and get her to check when I get the chance, just in case :)

Post Reply

Return to “Hardware Support”