Touchpad driver not loading after reboot

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 3
Joined: Tue Aug 18, 2015 6:29 am

Touchpad driver not loading after reboot

Post by stianlagstad »

Moving the mouse and using the buttons below the touchpad works. Scrolling of any kind does not, even though the settings for it is on at "Mouse and Touchpad" -> "Touchpad".

synclient -l
Couldn't find synaptics properties. No synaptics driver loaded?
xinput list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ PS/2 Generic Mouse id=14 [slave pointer (2)]
sudo apt-get install xserver-xorg-input-synaptics
Reading package lists... Done
Building dependency tree
Reading state information... Done
xserver-xorg-input-synaptics is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
I've tried reinstalling the package to no avail.

It worked just as it should yesterday. I'm using Linux Mint 17.2 "Rafaela" - Cinnamon (64-bit) on an Acer Aspire v3-571g. Looks like I'm at kernel 3.16.0-38 (3.16.7-ckt10).

Any ideas?

If it helps, the touchpad is of type "ELAN PS/2 Port Smart-Pad".

Things I've tried which didn't work:
- Updating to kernel 3.19, which worked for this guy, did not work for me.
- Using xserver-xorg-input-synaptics-lts-trusty as suggested here had no effect.
Level 1
Level 1
Posts: 1
Joined: Sat Sep 26, 2015 10:01 am

Re: Touchpad driver not loading after reboot

Post by Kat2380 »

I was testing Linux Mint on a Toshiba L50-C-12V, a live test from the bootable usb. I am getting the same problem with Elan Smartpad, I can move, click and drag with my touchpad but cannot scroll at all. I don't know what to do as I've never used linux before and I don't want to risk installing if I can't fix the scrolling issue
Post Reply

Return to “Hardware Support”