using touchpad and nvidia causes freeze revisisted

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
ack0329
Level 1
Level 1
Posts: 42
Joined: Tue Feb 25, 2014 11:42 pm

using touchpad and nvidia causes freeze revisisted

Post by ack0329 »

Using the touchpad while the nvidia driver is active causes random and constant screen freeze :!:

An old topic without any new suggestions??

Any other ideas, other than
1/ disabling the touchpad and using a mouse (fine but defeats the point)
2/ constantly tty1 and tty8'ing (infuriating)
3/ new nvidia drivers (tried dozens so far currently using nvidia-346-updates)
4/ editing one line in /etc/default/grub to read ....."GRUB_CMDLINE_LINUX_DEFAULT="nouveau.blacklist=1 quiet splash"
5/ using the nouveaux driver (works but again defeats the point)

Seriously Nvidia get your act together (a problem for over 4 years)

Any new light on the subject :idea: , cheers and thanks :?
ack0329
Level 1
Level 1
Posts: 42
Joined: Tue Feb 25, 2014 11:42 pm

Re: using touchpad and nvidia causes freeze revisisted

Post by ack0329 »

Ok, here is the culprit I found ...

...not the proprietary nvidia drivers itself but Prime used for optimus support!

Here is the solution which also helps or eliminates screen tearing (caused by Prime as well)
my notes as follows:

Screen Tearing with Nvidia Optimus and Screen Freezing with using the Touchpad
∘ This is caused when have dual graphics (intel integrated and nvidia) and using Driver Manager to use proprietary nvidia drivers and Prime.
‣ However!!! Bumblebee will fix it because it runs two instances of X11 servers and implements buffering and syncing much much better. Albeit at a cost in performance. But in my case it was neglible. So I needed to switch to bumblebee to get vsync.
• 1/ Change to Intel instead of Nvidia Prime in Nvidia Settings (reboot was required for me) Now you'll be on your integrated graphics.
• 2/ Lets get bumblebee and all the other stuff installed correctly.
∘ sudo apt-get install bumblebee bumblebee-nvidia primus linux-headers-generic primus-libs-ia32
∘ sudo apt-get install virtualgl
• Note "referred to by another package"
∘ $ apt-cache search virtualgl (shows which package)
bumblebee - NVIDIA Optimus support for Linux
primus - client-side GPU offloading for NVIDIA Optimus
∘ sudo apt-get install virtualgl-libs-ia32 SAA
∘ sudo apt-get install primus
∘ sudo apt-get install primus-libs-ia32
• 3/ Edit your bumblebee.conf to reflect your current nvidia drivers (mine was 346-updates because that is what I chose in driver manager way back when)
∘ sudo gedit /etc/bumblebee/bumblebee.conf
• Change line 22 "Driver=" to "Driver=nvidia"
• Change line 55 "KernelDriver=nvidia-current" or whatever it says to "KernelDriver=nvidia-346-updates" or "=nvidia-331" or whatever your current nvidia driver is
• Change line 58 to "LibraryPath=/usr/lib/nvidia-346-updates:/usr/lib32/nvidia-346-updates" or whatever your current nvidia driver is
• Change line 61 to "XorgModulePath=/usr/lib/nvidia-331-updates/xorg,/usr/lib/xorg/modules" or whatever your current nvidia driver is
‣ Reboot
∘ Test bumblebee by
∘ optirun glxgears -info
Note - use "optirun" in terminal to run anything with the nvidia card
ex. in terminal use
optirun firefox
‣ It should show you using your nvidia card.
Post Reply

Return to “Hardware Support”