Mint Rafaela 17.2 - No ethernet with onboard Intel I217-V

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
ThinkingMonkey
Level 1
Level 1
Posts: 7
Joined: Fri Oct 16, 2015 3:26 pm

Mint Rafaela 17.2 - No ethernet with onboard Intel I217-V

Postby ThinkingMonkey » Fri Oct 16, 2015 4:24 pm

Hi all,

As my subject line states, I have recently installed Linux Mint 17.2.

It appears to have correctly identified every internal device (except one) and every peripheral device.

However, one of the most critical devices of all, the ethernet adapter, won't work. I get a constant message
about every 2 minutes that I am NOT connected.

I got the driver for the adapter from Intel, although Intel themselves say that a newer driver may be available at
SourceForge. But I hesitate at this because I have seen several posts that suggested that it was best to stay away
from a third party driver developer, such as SourceForge developing Intel NIC drivers.
This attitude may be pure nonsense, I don't know enough about it.

Okay, my adapter is an onboard (EVGA Z87) Intel Ethernet Connection I217-V. Intel calls the Linux driver for this device 'e1000e'.

The driver I downloaded from them is named 'e1000e-3.2.4.2.tar.gz', a driver that was posted only this summer and says it is the latest driver.

***Newbie Alert***
From here on, my ignorance is going to be very annoying to an experiened Mint user, I'm sure. But please bear with me.

What in the heck do I do with the 'e1000e-3.2.4.2.tar.gz' file? The instructions that come with the driver, seen once the
file is unpacked with WinZip, gives the direction for RedHat only. It first starts off with how to make an RPM file with the driver,
which of course won't work for Mint. So I'm stuck before I even get started.

Can someone please instruct me (maybe as if talking to a 3rd grader) step-by-step how to compile and install this driver.
As you can imagine, it's extremely boring to stare at the Mint desktop and have no Internet connection.

The file is located on a secondary drive that both Windows 10 and Mint can access. I know I have to be booted into Mint to
accomplish whatever instructions someone may provide.

Any help provided is greatly appreciated.

As always,
Hugh

EDIT: I seem to have gotten the drivers installed and working. Now, the Ethernet card itself seems to be working fine but still no Internet.
I've changed IP4 address, subnet mask, default gateway, etc. to no avail (yet).

So the help I currently need is how to get a (working) Ethernet card to connect to the Internet using Linux Mint 17.2


.

User avatar
karlchen
Level 18
Level 18
Posts: 8021
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Mint Rafaela 17.2 - No ethernet with onboard Intel I217-

Postby karlchen » Mon Oct 19, 2015 6:03 am

Hello, ThinkingMonkey.

I am a bit amazed that it should be necessary to download and install any driver package from the Intel homepage for your internal Intel ethernet card at all, because Linux Mint should have detected and loaded the right driver automatically.
The fact that you get a warning every 2 minutes that you are not connected, does not necessarily imply that Mint has not loaded the right driver; rather it suggests that Mint tries to get a connection to whatever you connected the ethernet cable to, but cannot do so or loses the connection again.

To start with, here are 2 questions / requests:
  • To which device have you connected your Mint 17.2 machine? The ethernet cable connects your machine to which network device?
    (Example: my machine here is connected via ethernet cable to my AVM Fritz!Box, which is a DSL router.)
  • I assume that your Mint 17.2 is not connected to the internet via WLAN? As a result at the time being you cannot post anything directly from the Mint 17.2 machine, right?
  • Could you please create an inxi report on the Mint 17.2 system, transfer this report to the machine that you use to post here and post the inxi report please?
    (inxi creates a concise overview of your system hardware and configuration and will show which driver Mint 17.2 has loaded for your internal ethernet network card.)
    Here is how to create the inxi report:
    • On the Mint 17.2 system open a terminal window. Execute this command line exactly as it is shown here:

      Code: Select all

      inxi -c 0 -Fxz > ~/inxi_report.txt
    • Use a USB pendrive e.g. and copy the file ~/inxi_report.txt to the USB pendrive.
    • Attach the USB pendrive to the machine which you use for posting here and post the content of the file inxi_report.txt here in your next reply.
With respect to the downloaded .tar.gz archive file:
At this point in time my advice will be: keep it, but do not try to install anything from it, yet. We do not even know whether it will be necessary to do so.
(Oops, too late, you seem to have installed it. Then let us hope it is the right one. :-) inxi report would be helpful as a starting point nonetheless.)

Best regards,
Karl
Image
Old bugs good, new bugs bad! Updates are evil: might fix old bugs and introduce no new ones.

ThinkingMonkey
Level 1
Level 1
Posts: 7
Joined: Fri Oct 16, 2015 3:26 pm

[SOLVED] - No ethernet with onboard Intel I217-V

Postby ThinkingMonkey » Thu Nov 12, 2015 6:24 pm

Hi karichen,

I'm sorry about the long delay in replying. I fixed my issue and then attempted to update that fact to the 2 or 3 forums where I had posted this problem. Evidently I missed the most important one, namely, here at linuxmint.com.

Thank you for your help.

TL;DR
Turn off WoL in BIOS and Windows (if using Windows)

For anyone else that may have this problem and is still seeking a solution, I'll post the answer to your request here and then tell you how I fixed the problem. (Very odd, BTW)

First, I did a complete re-install and this time did NOT separately install the driver provided by Intel. I let it detect and use it's own driver (which is the same as the one provided by Intel, the 'e1000e' driver.)

Then, running this command in a terminal:

Code: Select all

inxi -c 0 -Fxz > ~/inxi_report.txt:


Results:

Code: Select all

System:    Host: mint-Z87 Kernel: 3.16.0-52-generic x86_64 (64 bit, gcc: 4.8.2)
           Desktop: Cinnamon 2.6.13  Distro: Linux Mint 17.2 Rafaela
Machine:   System: EVGA product: N/A
           Mobo: EVGA model: 141-HW-E877 version: 1.2 Bios: American Megatrends version: 4.6.5 date: 10/09/2014
CPU:       Dual core Intel Pentium CPU G3258 (-MCP-) cache: 3072 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 12770.3
           Clock Speeds: 1: 3200.00 MHz 2: 3200.00 MHz
Graphics:  Card: NVIDIA GK107 [GeForce GTX 650] bus-ID: 01:00.0
           X.Org: 1.15.1 drivers: nvidia (unloaded: fbdev,vesa,nouveau) Resolution: 1680x1050@60.0hz
           GLX Renderer: GeForce GTX 650/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 346.72 Direct Rendering: Yes
Audio:     Card-1: Intel 8 Series/C220 Series High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2: NVIDIA GK107 HDMI Audio Controller driver: snd_hda_intel bus-ID: 01:00.1
           Sound: Advanced Linux Sound Architecture ver: k3.16.0-52-generic
Network:   Card: Intel Ethernet Connection I217-V driver: e1000e ver: 2.3.2-k port: f040 bus-ID: 00:19.0
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 1620.4GB (0.5% used) 1: id: /dev/sda model: OCZ size: 120.0GB temp: 0C
           2: id: /dev/sdb model: ST3500418AS size: 500.1GB temp: 27C 3: id: /dev/sdc model: ST3500418AS size: 500.1GB temp: 28C
           4: id: /dev/sdd model: WDC_WD5000AAKS size: 500.1GB temp: 30C
Partition: ID: / size: 46G used: 6.9G (16%) fs: ext4 ID: swap-1 size: 10.13GB used: 0.00GB (0%) fs: swap
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 0.0:34C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 188 Uptime: 6 min Memory: 813.7/7936.6MB Runlevel: 2 Gcc sys: 4.8.4
           Client: Shell (bash 4.3.11) inxi: 1.9.17


So there's that information.

Here's the way I got it to work: (Pardon me in advance for a long post)

The root of all my headaches.

It was a hardware issue. I began to suspect that may be possible after I applied the changes per various forum instructions and it seemed to work fine until I rebooted to Windows 10 then back to Linux (currently Mint 17.2, although as I may have mentioned (or not), the same problem was present with Ubuntu, Debian, and openSUSE).

What was also suspicious was when I wiped openSUSE once again and re-reinstalled Mint 17.2, the automatic network detection and setup (about the 3rd step in the setup, as you know) seemed to go just fine. After a reboot, it did not.

So step by step, what it was doing was (and yes I wrote this down trying to find a clue and it wasn't apparent at first, only in retrospect):

- Using Windows 10, network all fine and working
- Reboot with (any) Linux install DVD inserted and there were quickly problems (The dreaded "Your DHCP is not working" message)
- Complete the Linux install anyway
- Boot back to Windows to get online to read advice on what to check next.
- Reboot to Linux, still no network (Internet)

That was the never ending cycle for several days. I was periodically doing complete re-installs of either openSUSE, Debian 8.2, and Mint thinking that if someone did provide a fix, all the previous failed entries I had made concerning the network might have goofed it up so that correct advice couldn't have helped. So I was trying to keep a relatively clean Linux install as much as possible.

Ok. So coincidentally, I had a monitor flickering problem that I usually fix by completely powering off the monitor and computer for about a minute then back on and it will be good for several days or more. Not only powered off, but unplugged. (Yes, I need to replace this monitor and I will sooner or later).

So I did that. Well, I had the notion to boot into Mint while I was at the GRUB menu, so I did and the network (Internet) was working flawlessly!

I had no idea what had been changed or not changed at that point. So I looked back over my notes and was pretty sure I had rebooted after each change so I rebooted into Windows to check my e-mail for notes. Couldn't find anything that caught my eye so I booted back into Mint to celebrate and guess what? No Internet.

SO I was thinking to myself that something or the other was existing in Windows that was changed in Linux but had no idea what, then I started to think of hardware settings.

After a lot of experimentation, here's all I did:

Disable the Wake-on-LAN (WoL) in both the BIOS and the network adapter settings in Device Manager in Windows (it's the same for 7, 8, 8.1, and 10). I had both off when I realized I could boot back and forth from Windows and Linux and still have Internet every single time without fail and I'm not about to re-enable one or the other to see if it makes a difference. They're both staying off.

I would have to guess that it being off in the BIOS will prevent it from being enabled in Windows but I really don't care at this point. Somebody besides me can check into that.

So getting a pure, virgin, cold boot straight into Linux without booting to Windows first is what made it work then I figured out how to make it stay working through cold or warm boot, both.

I don't know if it's this particular board (EVGA Z-87 FTW), or just the built-in adapter (Intel I217-V)) or both, but if you cannot get a Linux distro to automatically configure your network during setup, something it's been able to do for many, many years now, and you have the same setup I have, simply disable the Wake-on-LAN in the BIOS and in Windows' Device Manager.

I also imagine that someone who wasn't dual-booting would not have this problem since there would be no Windows to goof up the WoL to start with.

Thanks again for the help provided here.

As always,
Hugh

EDIT: I forgot to mention that I had spent half a day setting up a Belkin router that I got for my office and only used for a couple of weeks then boxed up, brought home and forgotten about. It's a Belkin N600 DualBand N+. I was basically just using it for 4 additional Ethernet ports. Plus it has a USB connection so you can make non-wireless printers, external storage, etc. wireless, or enable quick and easy NAS, etc. It's a good router. What I had been using at home prior was the combination modem/router that's supplied by my ISP, Windstream.
I turned off all DHCP, WiFI, and just about everything else in the modem and enabled it all in the Belkin router because I had suspected at one point that maybe the Linux install just simply wasn't going to work with that modem.

So I set Linux to get DHCP, etc. from the router, which was assigned a single, static IP from the modem. I was letting the router run the whole show but nothing improved. Same problem as before, namely no Internet in Linux.

It was the WoL problem all along.



.

ThinkingMonkey
Level 1
Level 1
Posts: 7
Joined: Fri Oct 16, 2015 3:26 pm

UPDATE - Mint Rafaela 17.2 - No ethernet with Intel I217-V

Postby ThinkingMonkey » Tue Nov 17, 2015 11:50 pm

Hi all,

This original post was marked as solved but an issue has come up.

For those who are dual booting like me with Windows 10 and Linux Mint 17.2 (or any distro, actually), if you used the fix that I posted here, it may have stopped working.

The cause is that the newest Microsoft 'Fall Update' that was released recently, Build 10586, (it was a rolling update so some received it a while back and some may be yet to receive it. I got it yesterday (16 Nov 2015)), installs new NIC drivers that roll back any WoL (Wake-on-LAN) setting you may have turned off to allow rebooting from Windows 10 into Linux and have the network automatically detected and set up.

I turned off any settings that seemed related to the problem but still no fix. I tried turning off several power features but none worked. Unfortunately, there is no longer a simple option for 'Turn off Wake-on-LAN'.

So, I went to Intel's site and downloaded and installed the newest Windows generic driver for my network adapter. It's the Intel I217-V, which uses the PROWin64.exe driver

Download it here:
https://downloadcenter.intel.com/download/25016


After that, go to Device Manager > Network Adapters > right-click Intel I217-V adapter and select Properties.

Turn off any and all items listed that pertain to actions done to a sleeping LAN. Disable them all. As in my last fix, I'm not sure which of the settings really turned off the WoL, and I'm not interested in turning them all back on one by one to see which works.

After this you should then again be able to warm (re)boot to Linux Mint without powering the system completely off then back on after being in Windows 10..

I don't use the Wake-on-LAN feature, as there is only 1 system on the network, thus not needing LAN activity to turn it on.

I hope this helps someone.

As always,
Hugh


.


Return to “Hardware Support”