[solved] how to -truly- disable mouse acceleration?

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
j03k3rr
Level 4
Level 4
Posts: 208
Joined: Fri Aug 28, 2015 7:03 am

[solved] how to -truly- disable mouse acceleration?

Post by j03k3rr »

I moved the bar closests to Slow under System Settings > Hardware > Mouse and Touchpad.

But this is not disabling it. How do I disable mouse acceleration for touchpad and mouse both?
Last edited by j03k3rr on Tue Dec 29, 2015 4:14 am, edited 1 time in total.
● Windows 10 Pro 64
VMware Workstation 12 ○ Mint 18 ○ Elementary OS 0.3
● Ubuntu Server 14.04.03 Headless
Virtualbox 5.0.26 ○ Windows 7 64
● Linux Mint 18 Cinnamon 64

User avatar
roblm
Level 11
Level 11
Posts: 3812
Joined: Sun Feb 24, 2013 2:41 pm

Re: how to -truly- disable mouse acceleration?

Post by roblm »

Type this command in the Terminal: xinput
Get the id number of the touchpad or mouse, or both if you use both.

Then use the command below, substituting the X with the id number:

Code: Select all

xinput --set-prop X "Device Accel Velocity Scaling" 1
You can test the mouse or touchpad immediately without rebooting. If that doesn't work, then use this command:

Code: Select all

xinput list-props X
Where X is the id number. Do this for both devices if using both.

Then post the output in the Mint forum reply window by selecting “code” in the menu and pasting it between the two code words.

Also use this command and post the output: inxi -Fx

j03k3rr
Level 4
Level 4
Posts: 208
Joined: Fri Aug 28, 2015 7:03 am

Re: how to -truly- disable mouse acceleration?

Post by j03k3rr »

Code: Select all

⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ SiliconWin mouse                        	id=11	[slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad              	id=13	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Video Bus                               	id=8	[slave  keyboard (3)]
    ↳ Sleep Button                            	id=9	[slave  keyboard (3)]
    ↳ USB2.0 HD UVC WebCam                    	id=10	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=12	[slave  keyboard (3)]
It worked for touchpad but not the mouse. Also after restart touchpad is also back to acceleration. I mean touchpad acceleration is definitely gone I can notice it, but I can't tell the same for mouse.

mouse before terminal code:

Code: Select all

Device 'SiliconWin mouse':
	Device Enabled (134):	1
	Coordinate Transformation Matrix (136):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	Device Accel Profile (258):	0
	Device Accel Constant Deceleration (259):	1.000000
	Device Accel Adaptive Deceleration (260):	1.000000
	Device Accel Velocity Scaling (261):	10.000000
	Device Product ID (251):	0, 14369
	Device Node (252):	"/dev/input/event5"
	Evdev Axis Inversion (262):	0, 0
	Evdev Axes Swap (264):	0
	Axis Labels (265):	"Rel X" (144), "Rel Y" (145), "Rel Vert Wheel" (257)
	Button Labels (266):	"Button Left" (137), "Button Middle" (138), "Button Right" (139), "Button Wheel Up" (140), "Button Wheel Down" (141), "Button Horiz Wheel Left" (142), "Button Horiz Wheel Right" (143), "Button Side" (255), "Button Extra" (256), "Button Unknown" (254), "Button Unknown" (254), "Button Unknown" (254), "Button Unknown" (254)
	Evdev Middle Button Emulation (267):	0
	Evdev Middle Button Timeout (268):	50
	Evdev Third Button Emulation (269):	0
	Evdev Third Button Emulation Timeout (270):	1000
	Evdev Third Button Emulation Button (271):	3
	Evdev Third Button Emulation Threshold (272):	20
	Evdev Wheel Emulation (273):	0
	Evdev Wheel Emulation Axes (274):	0, 0, 4, 5
	Evdev Wheel Emulation Inertia (275):	10
	Evdev Wheel Emulation Timeout (276):	200
	Evdev Wheel Emulation Button (277):	4
	Evdev Drag Lock Buttons (278):	0
mouse after code:

Code: Select all

Device 'SiliconWin mouse':
	Device Enabled (134):	1
	Coordinate Transformation Matrix (136):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	Device Accel Profile (258):	0
	Device Accel Constant Deceleration (259):	1.000000
	Device Accel Adaptive Deceleration (260):	1.000000
	Device Accel Velocity Scaling (261):	1.000000
	Device Product ID (251):	0, 14369
	Device Node (252):	"/dev/input/event5"
	Evdev Axis Inversion (262):	0, 0
	Evdev Axes Swap (264):	0
	Axis Labels (265):	"Rel X" (144), "Rel Y" (145), "Rel Vert Wheel" (257)
	Button Labels (266):	"Button Left" (137), "Button Middle" (138), "Button Right" (139), "Button Wheel Up" (140), "Button Wheel Down" (141), "Button Horiz Wheel Left" (142), "Button Horiz Wheel Right" (143), "Button Side" (255), "Button Extra" (256), "Button Unknown" (254), "Button Unknown" (254), "Button Unknown" (254), "Button Unknown" (254)
	Evdev Middle Button Emulation (267):	0
	Evdev Middle Button Timeout (268):	50
	Evdev Third Button Emulation (269):	0
	Evdev Third Button Emulation Timeout (270):	1000
	Evdev Third Button Emulation Button (271):	3
	Evdev Third Button Emulation Threshold (272):	20
	Evdev Wheel Emulation (273):	0
	Evdev Wheel Emulation Axes (274):	0, 0, 4, 5
	Evdev Wheel Emulation Inertia (275):	10
	Evdev Wheel Emulation Timeout (276):	200
	Evdev Wheel Emulation Button (277):	4
	Evdev Drag Lock Buttons (278):	0
I compared these two with Meld
Setting for

Code: Select all

	Device Accel Velocity Scaling (261):	10.000000
changed to

Code: Select all

	Device Accel Velocity Scaling (261):	1.000000
Let me know if you also need touchpad results and thanks for the interest

inxi -Fx result:

Code: Select all

System:    Host: csdmint Kernel: 3.16.0-52-generic x86_64 (64 bit, gcc: 4.8.2) 
           Desktop: Gnome Distro: Linux Mint 17.2 Rafaela
Machine:   Mobo: CASPER BILGISAYAR SISTEMLERI A.S model: C15B version: 1.0
           Bios: American Megatrends version: C15B.616 date: 03/18/2014
CPU:       Dual core Intel Core i5-4210M CPU (-HT-MCP-) cache: 3072 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10376 
           Clock Speeds: 1: 2600.00 MHz 2: 3009.804 MHz 3: 2600.304 MHz 4: 2600.203 MHz
Graphics:  Card: Intel 4th Gen Core Processor Integrated Graphics Controller bus-ID: 00:02.0 
           X.Org: 1.15.1 drivers: intel (unloaded: fbdev,vesa) Resolution: 1366x768@60.0hz 
           GLX Renderer: Mesa DRI Intel Haswell Mobile GLX Version: 3.0 Mesa 10.1.3 Direct Rendering: Yes
Audio:     Card-1: Intel 8 Series/C220 Series High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0 
           Card-2: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller driver: snd_hda_intel bus-ID: 00:03.0 
           Sound: Advanced Linux Sound Architecture ver: k3.16.0-52-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller 
           driver: r8169 ver: 2.3LK-NAPI port: c000 bus-ID: 04:00.0
           IF: eth0 state: down mac: d8:97:ba:da:2a:41
           Card-2: Realtek RTL8723AE PCIe Wireless Network Adapter driver: rtl8723ae port: d000 bus-ID: 03:00.0
           IF: wlan0 state: up mac: dc:85:de:c5:91:c2
Drives:    HDD Total Size: 500.1GB (11.2% used) 1: id: /dev/sda model: WDC_WD5000LPVX size: 500.1GB 
Partition: ID: / size: 20G used: 9.7G (52%) fs: ext4 ID: swap-1 size: 2.05GB used: 0.00GB (0%) fs: swap 
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 43.0C mobo: N/A 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 192 Uptime: 11 min Memory: 1216.8/5878.1MB Runlevel: 2 Gcc sys: 4.8.4 
           Client: Shell (bash 4.3.11) inxi: 1.9.17
● Windows 10 Pro 64
VMware Workstation 12 ○ Mint 18 ○ Elementary OS 0.3
● Ubuntu Server 14.04.03 Headless
Virtualbox 5.0.26 ○ Windows 7 64
● Linux Mint 18 Cinnamon 64

User avatar
roblm
Level 11
Level 11
Posts: 3812
Joined: Sun Feb 24, 2013 2:41 pm

Re: how to -truly- disable mouse acceleration?

Post by roblm »

j03k3rr wrote:It worked for touchpad but not the mouse. Also after restart touchpad is also back to acceleration.
That was a test to see if the command worked. To make the change persistent after a restart, create a new Startup Program in Startup Applications, and add the xinput command to the Command window.

For the mouse, more than one command may be needed in addition to the first command:

Code: Select all

xinput --set-prop 11 "Device Accel Velocity Scaling" 1
xinput --set-prop 11 "Device Accel Profile" -1
xinput --set-prop 11 "Device Accel Adaptive Deceleration" 4
Also, this command, if those don't work. This one worked for me when used alone:

Code: Select all

xinput --set-prop 11 "Device Accel Constant Deceleration" 4
In the two Deceleration commands, the default value is 1, you can also test 2 and 3, if 4 slows acceleration down too much.

If that fails, then try using these commands, where the property names has been replaced with the property id numbers:

Code: Select all

xinput --set-prop 11 261 1
xinput --set-prop 11 258 -1
xinput --set-prop 11 260 4
xinput --set-prop 11 259 4
If that doesn't work, then try the method in THIS WEB PAGE. Go to the bottom, under Disabling mouse acceleration.

First create the xorg.conf.d folder by using this command:

Code: Select all

sudo mkdir /etc/X11/xorg.conf.d
Then use this command to create the 50-mouse-acceleration.conf file:

Code: Select all

gksudo gedit /etc/X11/xorg.conf.d/50-mouse-acceleration.conf
In the opened empty file, add the lines in that article:

Code: Select all

Section "InputClass"
	Identifier "My Mouse"
	MatchIsPointer "yes"
	Option "AccelerationProfile" "-1"
	Option "AccelerationScheme" "none"
	Option "AccelSpeed" "-1"
EndSection
Reboot.

j03k3rr
Level 4
Level 4
Posts: 208
Joined: Fri Aug 28, 2015 7:03 am

Re: how to -truly- disable mouse acceleration?

Post by j03k3rr »

roblm wrote:

Code: Select all

xinput --set-prop 11 "Device Accel Velocity Scaling" 1
xinput --set-prop 11 "Device Accel Profile" -1
xinput --set-prop 11 "Device Accel Adaptive Deceleration" 4
Actually this worked fine. 4 was too slow made it 2.
Again same speed and acceleration after restart. I also created that file you said but no luck.
● Windows 10 Pro 64
VMware Workstation 12 ○ Mint 18 ○ Elementary OS 0.3
● Ubuntu Server 14.04.03 Headless
Virtualbox 5.0.26 ○ Windows 7 64
● Linux Mint 18 Cinnamon 64

User avatar
roblm
Level 11
Level 11
Posts: 3812
Joined: Sun Feb 24, 2013 2:41 pm

Re: how to -truly- disable mouse acceleration?

Post by roblm »

j03k3rr wrote:Again same speed and acceleration after restart. I also created that file you said but no luck.
I tested a xinput command on two systems and added it to Startup Applications. Strangely, on the first, the command didn't work, so I created a script with the
command and it worked. Then I disabled the script and tested the Startup App again and it now worked. On the second system, the Startup App worked the first time.

You can create a script that executes the xinput commands. Open the File Manager, right click in the empty space and select Create New Document > Empty Document.
Name it .xinput (the dot before the name will make it hidden). Open the file and add these lines:

Code: Select all

#!/bin/sh
xinput --set-prop 11 "Device Accel Velocity Scaling" 1
xinput --set-prop 11 "Device Accel Profile" -1
xinput --set-prop 11 "Device Accel Adaptive Deceleration" 2
Save the file and create a new Startup Program in Startup Applications with the name xinput. In the Command window, type:

Code: Select all

sh /home/your-user-name/.xinput
Change your-user-name to your actual user name. Log out and back in to test.

Summerof69
Level 3
Level 3
Posts: 165
Joined: Sun Oct 25, 2015 11:52 am
Location: Mainland,Denmark

Re: how to -truly- disable mouse acceleration?

Post by Summerof69 »

Sorry if I'm interfering, you may consider to ad a "&" at the end if you want to make sure that the script keeps running in the background.

I use an old mx518 logitech mouse and I use the following in a script file placed in /home, as described by "roblm" above

Code: Select all

#!/bin/sh
xinput --set-prop 9 "Device Accel Constant Deceleration" 3 &
The use of the switch "&" at the end makes the command persistent, and constantly running in the background, when logged in.
If not used, the script may fail, if you plug in another usb device.
For millions of years mankind lived much like the animals
Then something happened which unleashed the power of our imagination
We learned to talk
All we need to do is make sure we keep talking
Stephen Hawkin's voice on Keep Talking by Pink Floyd

j03k3rr
Level 4
Level 4
Posts: 208
Joined: Fri Aug 28, 2015 7:03 am

Re: how to -truly- disable mouse acceleration?

Post by j03k3rr »

I appreciate the help guys well it's not working, not even from terminal. May this be because I am now using Kernel: 3.19.0-32-generic x86_64 ?

Code: Select all

$ xinput --set-prop 11 "Device Accel Velocity Scaling" 1
property 'Device Accel Velocity Scaling' doesn't exist, you need to specify its type and format
xinput result is same id11 is my usb mouse. I don't wanna revert back to older kernel this one seems fine with Realtek wifi driver. :?
● Windows 10 Pro 64
VMware Workstation 12 ○ Mint 18 ○ Elementary OS 0.3
● Ubuntu Server 14.04.03 Headless
Virtualbox 5.0.26 ○ Windows 7 64
● Linux Mint 18 Cinnamon 64

User avatar
roblm
Level 11
Level 11
Posts: 3812
Joined: Sun Feb 24, 2013 2:41 pm

Re: how to -truly- disable mouse acceleration?

Post by roblm »

Before upgrading the kernel, did you test making the script described in my last post, and did it work?

Try using this command:

Code: Select all

xinput --set-prop 11 --type=float --format=32 "Device Accel Velocity Scaling" 1

j03k3rr
Level 4
Level 4
Posts: 208
Joined: Fri Aug 28, 2015 7:03 am

Re: how to -truly- disable mouse acceleration?

Post by j03k3rr »

roblm wrote:Before upgrading the kernel, did you test making the script described in my last post, and did it work?

Try using this command:

Code: Select all

xinput --set-prop 11 --type=float --format=32 "Device Accel Velocity Scaling" 1
No I didn't test it before 3.19 kernel it was working on terminal it should have worked on start-up. I will test both wifi and mouse acceleration with 3.18 kernel version.

UPDATE
I revert back to 3.16.x

Still not working. This is unbelievable, a code that worked in terminal now it's not working. Only thing I changed in my system is to upgrade to a newer kernel and revert back to same one.

Also last code you gave:

Code: Select all

$ xinput --set-prop 11 --type=float --format=32 "Device Accel Velocity Scaling" 1
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  131 (XInputExtension)
  Minor opcode of failed request:  57 ()
  Value in failed request:  0x105
  Serial number of failed request:  19
  Current serial number in output stream:  20
I give up.
● Windows 10 Pro 64
VMware Workstation 12 ○ Mint 18 ○ Elementary OS 0.3
● Ubuntu Server 14.04.03 Headless
Virtualbox 5.0.26 ○ Windows 7 64
● Linux Mint 18 Cinnamon 64

User avatar
roblm
Level 11
Level 11
Posts: 3812
Joined: Sun Feb 24, 2013 2:41 pm

Re: how to -truly- disable mouse acceleration?

Post by roblm »

j03k3rr wrote:
roblm wrote:Still not working. This is unbelievable, a code that worked in terminal now it's not working.
I see this sometimes with my testing. Did you test this line with the 3.19 kernel, where the type and format was asked for, which is unusual:

Code: Select all

xinput --set-prop 11 --type=float --format=32 "Device Accel Velocity Scaling" 1
If your're back to the 3.16 kernel, then use the original command:

Code: Select all

xinput --set-prop 11 "Device Accel Velocity Scaling" 1

j03k3rr
Level 4
Level 4
Posts: 208
Joined: Fri Aug 28, 2015 7:03 am

Re: how to -truly- disable mouse acceleration?

Post by j03k3rr »

roblm wrote:
j03k3rr wrote:
roblm wrote:Still not working. This is unbelievable, a code that worked in terminal now it's not working.
I see this sometimes with my testing. Did you test this line with the 3.19 kernel, where the type and format was asked for, which is unusual:

Code: Select all

xinput --set-prop 11 --type=float --format=32 "Device Accel Velocity Scaling" 1
If your're back to the 3.16 kernel, then use the original command:

Code: Select all

xinput --set-prop 11 "Device Accel Velocity Scaling" 1
I tried both in 3.16 no luck. Thing is I didn't even change the usb port that mouse is connected. Oddly enough codes are working for touchpad but not the usb mouse.
I wonder if it happened because I launched 3.16 from Grub's Other options. Didn't select recovery though, went with generic.

I just installed 4.1.6 kernel and same error occurs.

Code: Select all

xinput --set-prop 11 "Device Accel Velocity Scaling" 1
property 'Device Accel Velocity Scaling' doesn't exist, you need to specify its type and format

Code: Select all

xinput --set-prop 11 --type=float --format=32 "Device Accel Velocity Scaling" 1
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  131 (XInputExtension)
  Minor opcode of failed request:  57 ()
  Value in failed request:  0x108
  Serial number of failed request:  19
  Current serial number in output stream:  20
However for touchpad worked fine.
● Windows 10 Pro 64
VMware Workstation 12 ○ Mint 18 ○ Elementary OS 0.3
● Ubuntu Server 14.04.03 Headless
Virtualbox 5.0.26 ○ Windows 7 64
● Linux Mint 18 Cinnamon 64

User avatar
roblm
Level 11
Level 11
Posts: 3812
Joined: Sun Feb 24, 2013 2:41 pm

Re: how to -truly- disable mouse acceleration?

Post by roblm »

It's possible that the mouse's id number changed. Use the xinput command again to check that.

Also try the other command I listed in my second post for the mouse, which is also the same command user Summerof69 said he was using for his mouse:

Code: Select all

xinput --set-prop 11 "Device Accel Constant Deceleration" 4
If that fails, then try using this command:

Code: Select all

xinput --set-prop 11 261 1
Where 261 is the id number for the property Device Accel Velocity Scaling, as shown from using the command: xinput list-props 11

j03k3rr
Level 4
Level 4
Posts: 208
Joined: Fri Aug 28, 2015 7:03 am

Re: how to -truly- disable mouse acceleration?

Post by j03k3rr »

roblm wrote:It's possible that the mouse's id number changed. Use the xinput command again to check that.

Also try the other command I listed in my second post for the mouse, which is also the same command user Summerof69 said he was using for his mouse:

Code: Select all

xinput --set-prop 11 "Device Accel Constant Deceleration" 4
If that fails, then try using this command:

Code: Select all

xinput --set-prop 11 261 1
Where 261 is the id number for the property Device Accel Velocity Scaling, as shown from using the command: xinput list-props 11
Same error

Code: Select all

property 'Device Accel Constant Deceleration' doesn't exist, you need to specify its type and format
xinput shows ID is still 11 for usb mouse.

Code: Select all

⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ SiliconWin mouse                        	id=11	[slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad              	id=13	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Video Bus                               	id=8	[slave  keyboard (3)]
    ↳ Sleep Button                            	id=9	[slave  keyboard (3)]
    ↳ USB2.0 HD UVC WebCam                    	id=10	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=12	[slave  keyboard (3)]
I connected to a different usb port, nothing.
● Windows 10 Pro 64
VMware Workstation 12 ○ Mint 18 ○ Elementary OS 0.3
● Ubuntu Server 14.04.03 Headless
Virtualbox 5.0.26 ○ Windows 7 64
● Linux Mint 18 Cinnamon 64

User avatar
roblm
Level 11
Level 11
Posts: 3812
Joined: Sun Feb 24, 2013 2:41 pm

Re: how to -truly- disable mouse acceleration?

Post by roblm »

Try using these commands:

Code: Select all

xinput --set-prop 11 "Device Accel Velocity Scaling" 1.0
xinput --set-prop 11 "Device Accel Velocity Scaling" 1.000000
xinput --set-prop 11 --type=float --format=32 "Device Accel Velocity Scaling" 1.0
xinput --set-prop 11 --type=float --format=32 "Device Accel Velocity Scaling" 1.000000

j03k3rr
Level 4
Level 4
Posts: 208
Joined: Fri Aug 28, 2015 7:03 am

Re: how to -truly- disable mouse acceleration?

Post by j03k3rr »

roblm wrote:Try using these commands:

Code: Select all

xinput --set-prop 11 "Device Accel Velocity Scaling" 1.0
xinput --set-prop 11 "Device Accel Velocity Scaling" 1.000000
xinput --set-prop 11 --type=float --format=32 "Device Accel Velocity Scaling" 1.0
xinput --set-prop 11 --type=float --format=32 "Device Accel Velocity Scaling" 1.000000
I will test it out with VMs tomorrow.
So far no luck at all.

Code: Select all

 ~ $ xinput --set-prop 11 "Device Accel Velocity Scaling" 1.0
property 'Device Accel Velocity Scaling' doesn't exist, you need to specify its type and format
 ~ $ xinput --set-prop 11 "Device Accel Velocity Scaling" 1.000000
property 'Device Accel Velocity Scaling' doesn't exist, you need to specify its type and format
 ~ $ xinput --set-prop 11 --type=float --format=32 "Device Accel Velocity Scaling" 1.0
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  131 (XInputExtension)
  Minor opcode of failed request:  57 ()
  Value in failed request:  0x108
  Serial number of failed request:  19
  Current serial number in output stream:  20
 ~ $ xinput --set-prop 11 --type=float --format=32 "Device Accel Velocity Scaling" 1.000000
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  131 (XInputExtension)
  Minor opcode of failed request:  57 ()
  Value in failed request:  0x108
  Serial number of failed request:  19
  Current serial number in output stream:  20
● Windows 10 Pro 64
VMware Workstation 12 ○ Mint 18 ○ Elementary OS 0.3
● Ubuntu Server 14.04.03 Headless
Virtualbox 5.0.26 ○ Windows 7 64
● Linux Mint 18 Cinnamon 64

User avatar
roblm
Level 11
Level 11
Posts: 3812
Joined: Sun Feb 24, 2013 2:41 pm

Re: how to -truly- disable mouse acceleration?

Post by roblm »

Are you seeing the same error messages when using these two commands:

Code: Select all

xinput --set-prop 11 "Device Accel Profile" -1
xinput --set-prop 11 "Device Accel Adaptive Deceleration" 2
The error message “integer parameter out of range for operation” could mean the value of 1 is not supported by your mouse, although it worked the first time. Try starting with 9, and if it works, then try lower values:

Code: Select all

xinput --set-prop 11 --type=float --format=32 "Device Accel Velocity Scaling" 9.0 
Try rearranging the command:

Code: Select all

xinput --set-prop --type=float --format=32 11 "Device Accel Velocity Scaling" 9.0
Try using the actual name of the mouse instead of it's id number:

Code: Select all

xinput --set-prop --type=float --format=32 "SiliconWin mouse" "Device Accel Velocity Scaling" 9.0
Using the command xinput --help gives the syntax to use for the xinput commands. The syntax for the command your're trying to use is this:

Code: Select all

xinput set-prop <device> [--type=atom|float|int] [--format=8|16|32] <property> <val> [<val> …]
The options for --type are atom, float and int
Where float refers to a value that can have a fraction and int refers to a whole number. I forgot what atom refers to. The options for --format are 8, 16, and 32 (bits, I think). The values I told you to use are the only ones that worked while testing xinput commands with my mouse. Perhaps you need to use a different value.
From using the xinput list-props 11 command, the value for Device Accel Velocity Scaling is 10.000000, which shows that a fractional number can be use, instead of just a whole number. So using float for the --type appears correct. You could try changing the --format value from 32 to 16 and 8:

Code: Select all

xinput --set-prop 11 --type=float --format=16 "Device Accel Velocity Scaling" 1.0
xinput --set-prop 11 --type=float --format=16 "Device Accel Velocity Scaling" 1.000000
xinput --set-prop 11 --type=float --format=8 "Device Accel Velocity Scaling" 1.0
xinput --set-prop 11 --type=float --format=8 "Device Accel Velocity Scaling" 1.000000
As a last resort, try changing float to int:

Code: Select all

xinput --set-prop 11 --type=int --format=32 "Device Accel Velocity Scaling" 9
EDITED: The xinput commands didn't work for me in VirtualBox but they should work using the Installation DVD or USB drive.

j03k3rr
Level 4
Level 4
Posts: 208
Joined: Fri Aug 28, 2015 7:03 am

Re: how to -truly- disable mouse acceleration?

Post by j03k3rr »

@roblm
Thanks for your efforst none worked in my system. I need to reinstall Mint and re-arrange my partitions as I cut down my Windows usage to only for gaming. Mint 17.3 release is good time for me to do that.
● Windows 10 Pro 64
VMware Workstation 12 ○ Mint 18 ○ Elementary OS 0.3
● Ubuntu Server 14.04.03 Headless
Virtualbox 5.0.26 ○ Windows 7 64
● Linux Mint 18 Cinnamon 64

j03k3rr
Level 4
Level 4
Posts: 208
Joined: Fri Aug 28, 2015 7:03 am

Re: how to -truly- disable mouse acceleration?

Post by j03k3rr »

I came here to say same scenerario happened again with Mint 17.3 cinnamon with 4.2.18 kernel.

I used this code it worked great

Code: Select all

xinput --set-prop 11 "Device Accel Velocity Scaling" 1
Added it as start up application. Restarted my laptop, it's not working.

Same result with Mint 17.2

Is desktop manager the one responsible for such mouse settings? If so I'm done with Cinnamon.
● Windows 10 Pro 64
VMware Workstation 12 ○ Mint 18 ○ Elementary OS 0.3
● Ubuntu Server 14.04.03 Headless
Virtualbox 5.0.26 ○ Windows 7 64
● Linux Mint 18 Cinnamon 64

User avatar
roblm
Level 11
Level 11
Posts: 3812
Joined: Sun Feb 24, 2013 2:41 pm

Re: how to -truly- disable mouse acceleration?

Post by roblm »

Sometimes delaying the execution of a command in Startup Applications will allow it to work. Make the script as described in my third post, with these lines added, to delay the execution by 3 seconds:

Code: Select all

#!/bin/sh
sleep 3
xinput --set-prop 11 "Device Accel Velocity Scaling" 1
You can also test changing the sleep value to 2 and then 1. However, you previously said that command worked for the touchpad and not the mouse. Try using this command for the mouse:

Code: Select all

xinput --set-prop 11 "Device Accel Constant Deceleration" 4
You can also try using just the xinput command in the /home/your-user-name/.profile file, added to the bottom.

Post Reply

Return to “Hardware Support”