Nvidia driver with cuda installation in FELICIA

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
thiosk
Level 1
Level 1
Posts: 3
Joined: Tue Jan 13, 2009 11:41 pm

Nvidia driver with cuda installation in FELICIA

Postby thiosk » Fri Jan 16, 2009 12:37 pm

I was wondering if folks could give me tips on getting the CUDA enabled drivers in, im not using the beta (apparently the version is a bit crashy) but the installer is loading libraries in the emul directory... and then telling me they are not found.

I need these specific drivers to run GPU folding@home under WINE in linux on my 9800 gtx+.

Everythign in the install works fine until i reach the point where i install the 32-bit comatibility drivers.
And heres some screenies of my error messages:

[img=http://img19.picoodle.com/img/img19/3/1/12/f_Screenshot1m_e0d39b7.png]com/view.php?img=/3/1/12/f_Screenshot1m_e0d39b7.png&srv=img19]Image[/URL]

Image

Image

So the issue is something or other with my 32 bit libraries (obviously). If i look in the directory they are naming, i can SEE THOSE FILES IN THERE (but 2/3 of them are only 2.4 kb...)


This is my steps to get these installed:
http://www.nvidia.com/object/cuda_get.html
Download NVIDIA Driver for Linux 64-bit with CUDA Support (177.73).
CUDA toolkit: CUDA Toolkit for Ubuntu 8.04.

opened sudo gedit /lib/modules/`uname -r`/build/include/linux/autoconf.h
edit in //#define CONFIG_XEN 1 and save, temporarily, to allow the driver package to install correctly
sudo sh ~/Desktop/NVIDIA*.run --no-x-check

and thats where it fails.

Everything else works perfectly...

hotweiss
Level 4
Level 4
Posts: 204
Joined: Mon Jan 21, 2008 3:12 am
Location: Warsaw, Poland
Contact:

Re: Nvidia driver with cuda installation in FELICIA

Postby hotweiss » Fri Jan 16, 2009 3:50 pm

I reported this bug a few days ago:

https://bugs.launchpad.net/ubuntu/+sour ... bug/316902

To fix this I installed the 177.82 driver and then the 180.22 (if you want to) driver over top of it.

PS-If that doesn't work, I'd post any further questions in that launchpad thread...


Return to “Hardware Support”

Who is online

Users browsing this forum: glenn-o-matic and 8 guests