Power on fails after Linux Mint shutdown - OK on cold boot

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
paulshore
Level 1
Level 1
Posts: 13
Joined: Sat Sep 20, 2014 1:05 pm

Power on fails after Linux Mint shutdown - OK on cold boot

Post by paulshore » Sat Dec 19, 2015 1:53 pm

Hi,

I now have two machines which when you shutdown Linux mint it leaves the PC in a state that doesn't power up (from the shutdown state). It just hangs and doesn't get to the BIOS screen. I.e a warm reboot by pressing the power button after it has been shutdown doesn't work. If I cold power the machines they both boot fine.

Machine 1 - Sun Ultra 40M2 with 2 x Dual core AMD Opteron 2218, Mint Mate 64bit 17
Machine 2 - Intel Desktop board DG35EC with a Intel Core 2 Duo E8500, Mint Mate 64bit 17.3

Any hints as to what is going wrong?

Is there something that I need to change in the BIOS or Mint installation to fix this?

Its annoying, but not something that I can't work around.

Thanks

Paul

Maik
Level 2
Level 2
Posts: 69
Joined: Fri Jul 29, 2011 12:26 pm

Re: Power on fails after Linux Mint shutdown - OK on cold bo

Post by Maik » Mon Dec 21, 2015 3:37 am

If anyone can come up with an answer - or suggestions - for Paul I'd be interested as I have the same problem. Two desktops (self build), both Asrock H81M, one running an Intel G3250, other an Intel G1840. If we have a power cut, or if I re-boot (G1840) PC, it won't boot for hours. I can hear the power kick in but that's as far as it gets. I assumed this wasn't a Linux Mint issue but now I'm wondering. (Cinnamon 32-bit).

User avatar
Pierre
Level 18
Level 18
Posts: 8897
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Power on fails after Linux Mint shutdown - OK on cold bo

Post by Pierre » Mon Dec 21, 2015 3:40 am

what happens, if you type

Code: Select all

sudo shutdown now
into a terminal ?.

does it still freeze?.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

paulshore
Level 1
Level 1
Posts: 13
Joined: Sat Sep 20, 2014 1:05 pm

Re: Power on fails after Linux Mint shutdown - OK on cold bo

Post by paulshore » Mon Dec 21, 2015 2:57 pm

"sudo shutdown now" doesn't help - this shuts down Linux and leaves the power on, worse than Menu->Quit->Shutdown

"sudo shutdown -P now" powers off the machine and works in the exact same way that Menu->Quit-Shutdown does - it powers off, but when you press the power button to start up again it doesn't start.

The problem isn't getting the machine to power off - it does that fine, but its leaving the HW in a state that it doesn't power on correctly.

If you power on the machine from cold (i.e. switched on at the plug socket) you get the HW tests - fans run full for a few seconds, then they calm down and you see BIOS screen and then the machine boots. If you shut down it powers off. Powering on a 2nd time is the issue - it doesn't do HW tests (expected), but doesn't see the BIOS screen and doesn't boot - you have to switch it off/on at the power socket to reset things and get it to boot.

What should happen (and does if you have Windows installed) is on powering on a 2nd time does a sort of warm start - i.e. skips the HW tests, shows the BIOS screen and it boots up normally. This doesn't happen under Linux as it is not putting the machine into the right warm state on power off.

Paul

Post Reply

Return to “Hardware Support”