(Solved) Annoying touchpad enables after sleep mode

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
QuasarDeep
Level 1
Level 1
Posts: 3
Joined: Sun Feb 28, 2016 12:29 pm

(Solved) Annoying touchpad enables after sleep mode

Post by QuasarDeep » Sun Feb 28, 2016 12:50 pm

I am running an Asus laptop in my bios the touch-pad has been turned off it also stays like that when I boot into linux. I am using a normal mouse and have no need for a touch-pad I have tried touch-pad indicator the most recent version does not work with mint 17.3 cinnamon. Its only when it wakes up from sleep mode that the touch-pad stars up.

Is it possible some how to make a script out of this command: xinput set-prop 14 "Device Enabled" 0 , to make it start every time laptop wakes up from sleep mode.
Last edited by QuasarDeep on Tue Mar 01, 2016 5:15 am, edited 1 time in total.

User avatar
oldal
Level 1
Level 1
Posts: 33
Joined: Sat Jul 03, 2010 1:35 am
Location: Canberra, Australia
Contact:

Re: Annoying touchpad enables after sleep mode

Post by oldal » Mon Feb 29, 2016 7:23 am

Have you tried to enter the command

Code: Select all

synclient touchpadoff=1
On my HP2000 laptop that switches the touch pad off. It should work for your laptop too. If it does, please mark your mail <solved>.

Good luck and cheers,

OldAl.
---
OldAl - in Canberra, the capital of Australia

QuasarDeep
Level 1
Level 1
Posts: 3
Joined: Sun Feb 28, 2016 12:29 pm

Re: Annoying touchpad enables after sleep mode

Post by QuasarDeep » Mon Feb 29, 2016 11:08 am

Nope dident work thanks for the suggestion. The odd thing is that even when the touch-pad is disabled through the bios after I logg inn it is disabled as it should be, Only when I put the laptop in sleep mode does the touch-pad initialise again if I could only some how run a script after I boot up from sleep mode.

I have been through many threads about this issue, this is the best thread I have found so far.
http://askubuntu.com/questions/65951/ho ... e-touchpad

QuasarDeep
Level 1
Level 1
Posts: 3
Joined: Sun Feb 28, 2016 12:29 pm

Re: Annoying touchpad enables after sleep mode

Post by QuasarDeep » Tue Mar 01, 2016 5:14 am

Found this command works perfectly after suspend no need for script:
sudo gconftool-2 --set --type boolean /desktop/gnome/peripherals/touchpad/touchpad_enabled false

Answer from here;
http://askubuntu.com/questions/181616/i ... e-touchpad

Post Reply

Return to “Hardware Support”