Cannot get Realtek RTS525A card-reader to work

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
mhelvens
Level 1
Level 1
Posts: 1
Joined: Sun Apr 10, 2016 2:11 pm

Cannot get Realtek RTS525A card-reader to work

Post by mhelvens » Fri May 06, 2016 2:01 pm

Hi all,

I'm running Mint on a Dell XPS 13-9350. I cannot get its SD-card reader to work. When I insert an sd-card, nothing happens, including in `dmesg`. Here's the relevant `lspci -v` output:

Code: Select all

3b:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS525A PCI Express Card Reader (rev 01)
	Subsystem: Dell Device 0704
	Flags: bus master, fast devsel, latency 0, IRQ 255
	Memory at dc100000 (32-bit, non-prefetchable) [size=4K]
	Capabilities: [80] Power Management version 3
	Capabilities: [90] MSI: Enable- Count=1/1 Maskable- 64bit+
	Capabilities: [b0] Express Endpoint, MSI 00
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [148] Device Serial Number 00-00-00-01-00-4c-e0-00
	Capabilities: [158] Latency Tolerance Reporting
	Capabilities: [160] L1 PM Substates
From this link I learned that I need to load the `rtsx_pci` module. But `modprobe rtsx_pci` does nothing. This is where my know-how ends.

Some help would be much appreciated!

User avatar
leadwtZ
Level 3
Level 3
Posts: 130
Joined: Fri Aug 29, 2014 1:42 pm
Location: Universe

Re: Cannot get Realtek RTS525A card-reader to work

Post by leadwtZ » Sat May 14, 2016 4:29 am

Hi,

I am having the same issue but with a Genesys Logic which started with the last upgrade (I think) I know that some drivers for SD cards have changed but somewhat concerned about what to do. Have tried various links but they are a little 'out-of-date'.

Like mhelvens would appreciate some help.

Thanks.

Code: Select all

:
Bus 001 Device 003: ID 05e3:070e Genesys Logic, Inc. USB 2.0 Card Reader
Couldn't open device, some information will be missing
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0        64
  idVendor           0x05e3 Genesys Logic, Inc.
  idProduct          0x070e USB 2.0 Card Reader
  bcdDevice           93.17
  iManufacturer           3 
  iProduct                4 
  iSerial                 5 
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           32
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0x80
      (Bus Powered)
    MaxPower              500mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           2
      bInterfaceClass         8 Mass Storage
      bInterfaceSubClass      6 SCSI
      bInterfaceProtocol     80 Bulk-Only
      iInterface              6 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x02  EP 2 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
AND dmesg

Code: Select all

[code:select all] usb 1-1.1: Product: USB Reader
[    1.735414] usb 1-1.1: Manufacturer: Genesys
[    1.735416] usb 1-1.1: SerialNumber: 000000100516
[    1.882713] usb 2-1.3: New USB device found, idVendor=046d, idProduct=0802
[    1.882718] usb 2-1.3: New USB device strings: Mfr=0, Product=0, SerialNumber=2
[    1.882720] usb 2-1.3: SerialNumber: 47154760
[    1.954809] usb 2-1.4: new low-speed USB device number 4 using ehci-pci
[    2.053879] usb 2-1.4: New USB device found, idVendor=045e, idProduct=0083
[    2.053884] usb 2-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
]
Celeron CPU G1610@2.60GHz x 2
GeForce 8400 GS/PCle/SSE2
Linux MInt 18.3 'Sylvia' Mate 1.18
Reg. Linux user: 467766 Claws-Mail & Pale Moon user.

User avatar
leadwtZ
Level 3
Level 3
Posts: 130
Joined: Fri Aug 29, 2014 1:42 pm
Location: Universe

Re: Cannot get Realtek RTS525A card-reader to work

Post by leadwtZ » Mon May 23, 2016 4:51 am

Found this link which seems a little easier than some to follow:

https://thelastmaimou.wordpress.com/201 ... f-call-it/

I am assuming that inserting the appropriate model number would work! :)
Celeron CPU G1610@2.60GHz x 2
GeForce 8400 GS/PCle/SSE2
Linux MInt 18.3 'Sylvia' Mate 1.18
Reg. Linux user: 467766 Claws-Mail & Pale Moon user.

thierry-k
Level 1
Level 1
Posts: 10
Joined: Wed Jul 03, 2013 1:33 am

Re: Cannot get Realtek RTS525A card-reader to work

Post by thierry-k » Sun Jan 06, 2019 3:20 pm

Hi community,
I have HP ZBook G3, and the SD-Card reader is not detecting my SD-Card when I insert it.
Here is the result of

Code: Select all

lspci -v
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS525A PCI Express Card Reader (rev 01)
Subsystem: Hewlett-Packard Company RTS525A PCI Express Card Reader
Flags: bus master, fast devsel, latency 0, IRQ 125
Memory at e5200000 (32-bit, non-prefetchable) size=4K
Capabilities: <access denied>
Kernel driver in use: rtsx_pci
Kernel modules: rtsx_pci
note: I overwrote "size=4K" to "size=fourK" and removed the square brackets in the fourth line of the result for the purpose of being able to publish this post.

Anyone has had this issue and can help me solve it please?

thierry-k
Level 1
Level 1
Posts: 10
Joined: Wed Jul 03, 2013 1:33 am

Re: Cannot get Realtek RTS525A card-reader to work

Post by thierry-k » Fri Jan 18, 2019 6:42 pm

If anyone could help, that would be appreciated. I just noticed that when plugging my phone in that has an SD card inside, again nothing happens.

Post Reply

Return to “Hardware Support”