[solved] ASRock skylake flooding syslog with gpe6F

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
User avatar
DarrenG
Level 1
Level 1
Posts: 36
Joined: Mon Jun 23, 2014 9:12 pm
Location: New Zealand

[solved] ASRock skylake flooding syslog with gpe6F

Postby DarrenG » Wed Jun 08, 2016 4:03 am

I finally updated my ancient system with a Pentium G4400 and 8g ram on an ASRock H110M-DGS. I pondered waiting until mint 18 came out but I booted it barebones with a 17.3 usb thumbdrive and everything looked great so I decided to go ahead and transfer all the accessories over to the new system. All sweet for a couple of days until I got a message that my root partition was full.

I noticed that /var/log/syslog and var/log/kern.log were enormous and they were filled with the same error hundreds of times a second:
ACPI Exception: AE_NOT_FOUND, while evaluating GPE method [_L6F]

I looked around and found this is a known problem with ASRock Z170M boards and obviously applies to my H110M as well.

There is a good description of the fault at https://bugzilla.kernel.org/show_bug.cgi?id=117481 but to be honest the solution was a bit over my head.

I kept looking and found suggestions that upgrading my kernel to 4.4 would solve the problem. I used mint update to install 4.4.0-22 but that made no difference at all to the problem. This makes me wonder if this will be fixed in Mint18, or if it will require an update from ASRock.

The easiest to follow posting on the topic I found was in an amazon review:
Linux users be warned, there is a constant ACPI interrupt that continuously spams your syslog. For me, the log was growing approximately 1 mB/s and pegged a core at 100% usage. Search gpe6f acpi error for more information. It seems to be a problem with skylake motherboards, but other manufacturers have fixed the issue with a BIOS update, ASROCK has not.
A band-aide fix is to disable gpe6F interrupts. For ubuntu, open up a terminal and run

Code: Select all

sudo -s
echo "disable" > /sys/firmware/acpi/interrupts/gpe6F

This has to be done at every boot, or you can add it to /etc/rc.local to execute automatically at startup.


I entered the terminal commands then deleted the offending log files and sure enough they stopped regrowing. :D

Now to make it permanent:

Code: Select all

sudo -s gedit /etc/rc.local


then copy and paste

Code: Select all

echo "disable" > /sys/firmware/acpi/interrupts/gpe6F

before the exit 0 line.
Last edited by DarrenG on Sun Jun 19, 2016 10:21 pm, edited 1 time in total.
Linux Mint 17.3 Rosa 64 Cinnamon, on a homebuilt with ASRock N68PV-GS, AMD LE-1200, 1791MB Ram & NVIDIA C68.
“People shouldn't be afraid of their government. Governments should be afraid of their people.”

User avatar
DarrenG
Level 1
Level 1
Posts: 36
Joined: Mon Jun 23, 2014 9:12 pm
Location: New Zealand

Re: ASRock skylake flooding syslog with gpe6F

Postby DarrenG » Thu Jun 09, 2016 8:35 pm

As I suspected, the ASRock skylake gpe6F bug is also present in Linux Mint 18 beta Cinnamon. I just booted my system with a thumb drive and /var/log/syslog and var/log/kern.log grew until they filled my thumbdrive.
Linux Mint 17.3 Rosa 64 Cinnamon, on a homebuilt with ASRock N68PV-GS, AMD LE-1200, 1791MB Ram & NVIDIA C68.
“People shouldn't be afraid of their government. Governments should be afraid of their people.”

User avatar
DarrenG
Level 1
Level 1
Posts: 36
Joined: Mon Jun 23, 2014 9:12 pm
Location: New Zealand

Re: [solved] ASRock skylake flooding syslog with gpe6F

Postby DarrenG » Sun Jun 19, 2016 10:25 pm

ASRock_TSD emailed me bios L1.71 which solves this problem.
at the moment it is not listed at http://www.asrock.com/mb/Intel/H110M-DGS/?cat=Download&os=BIOS
Hopefully it will be up there soon, or you could probably ask for it from Asrock_TSD@asrock.com.tw
Linux Mint 17.3 Rosa 64 Cinnamon, on a homebuilt with ASRock N68PV-GS, AMD LE-1200, 1791MB Ram & NVIDIA C68.
“People shouldn't be afraid of their government. Governments should be afraid of their people.”

User avatar
DarrenG
Level 1
Level 1
Posts: 36
Joined: Mon Jun 23, 2014 9:12 pm
Location: New Zealand

Re: [solved] ASRock skylake flooding syslog with gpe6F

Postby DarrenG » Fri Jun 24, 2016 9:44 pm

I thanked ASRock and mentioned that the BIOS wasn't listed on their support page. They replied that they only provide official support for windows 7-8-10. The L prefix indicates that it is an Linux version for inhouse use and will not be put on their website. So if you want it you'll have to contact them directly. I'm grateful they emailed me the fix but I'm disappointed at their public attitude towards linux. I guess ASRock don't really want linux users' money, and I'll be taking that into account next time I'm shopping for motherboards. :x

Dear Darren,
Thank you for contacting ASRock!
Because the ASRock H110M-DGS official support Microsoft® Windows® 10 64-bit / 8.1 64-bit / 7 32-bit / 7 64-bit.
This BIOS is for our internal test to fix the issue about Linux OS, therefore, we haven't update this BIOS to our website and mark it as "L"1.71 version.
Despite of this, we still suggest user following the product SPEC to install the supported OS.

Thank you,
Sincerely,
ASRock TSD
Linux Mint 17.3 Rosa 64 Cinnamon, on a homebuilt with ASRock N68PV-GS, AMD LE-1200, 1791MB Ram & NVIDIA C68.
“People shouldn't be afraid of their government. Governments should be afraid of their people.”

numbetto
Level 1
Level 1
Posts: 1
Joined: Fri Sep 16, 2016 2:31 pm

Re: [solved] ASRock skylake flooding syslog with gpe6F

Postby numbetto » Fri Sep 16, 2016 2:33 pm

HI Darren,
I am having exactly the same problem with the same configuration (MB and CPU). I am using UBUNTU. Would it be possible for you to share the bios update? It would be very helpful to me.
Carlo.

fabrixx
Level 1
Level 1
Posts: 6
Joined: Mon Jun 06, 2011 3:27 pm

Re: [solved] ASRock skylake flooding syslog with gpe6F

Postby fabrixx » Sun Dec 18, 2016 2:39 pm

Same problem with my ASrock H170 Pro4 core i7 6700 fixed:
http://askubuntu.com/questions/176565/w ... et-so-high

I have to update bios?

dustystrings3001
Level 1
Level 1
Posts: 3
Joined: Tue May 01, 2012 11:36 pm

Re: [solved] ASRock skylake flooding syslog with gpe6F

Postby dustystrings3001 » Sun Jan 08, 2017 12:04 am

I have an ASROCK Z170 Extreme6 motherboard with an I7-6700 Skylake processor, and was taking care of the gpe6F flooding issue by manually disabling the interrupt as follows:
# echo "disable" > /sys/firmware/acpi/interrupts/gpe6F
as other people have indicated in earlier posts. This had to be done manually each time I rebooted, until I found another post by DarrenG on June 08, 2016 that recommended modifying /etc/rc.local to include the fix (see red font new line below). Darren's recommendation worked well for me:
#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.
echo "disable" > /sys/firmware/acpi/interrupts/gpe6F
exit 0

But at the end of December 2016, I downloaded- and applied ASROCK BIOS version 2.60 (file name Z17EX62.60) after email communication with ASROCK. This zipped file is 8Mb in size - too large to attach to this posting (I tried). This new version of the BIOS cleared up the interrupt issue; proof is that the following terminal command now shows zero interrupts for gpe6F:
$ grep enabled /sys/firmware/acpi/interrupts/*
/sys/firmware/acpi/interrupts/ff_gbl_lock: 0 enabled
/sys/firmware/acpi/interrupts/ff_pwr_btn: 0 enabled
/sys/firmware/acpi/interrupts/gpe61: 0 enabled
/sys/firmware/acpi/interrupts/gpe62: 0 enabled
/sys/firmware/acpi/interrupts/gpe66: 0 enabled
/sys/firmware/acpi/interrupts/gpe67: 0 enabled
/sys/firmware/acpi/interrupts/gpe6F: 0 enabled

The only problem is that the BIOS upgrade may have also cleared out my Skylake overclocking, but I was aware of this possibility before I applied the upgrade and decided to go for it anyway.

hminster
Level 1
Level 1
Posts: 2
Joined: Fri Feb 10, 2017 5:35 pm

Re: [solved] ASRock skylake flooding syslog with gpe6F

Postby hminster » Fri Feb 10, 2017 5:42 pm

I have an Asrock H110M-HDS motherboard.
The flood of gpe6F errors was fixed by a BIOS update 7.30 (H110M-HDS(7.30)ROM.zip) available from Asrock.

Winklejon
Level 1
Level 1
Posts: 1
Joined: Mon Feb 13, 2017 4:00 am

Re: [solved] ASRock skylake flooding syslog with gpe6F

Postby Winklejon » Tue Feb 14, 2017 3:23 am

hminster wrote:I have an Asrock H110M-HDS motherboard.
The flood of gpe6F errors was fixed by a BIOS update 7.30 (H110M-HDS(7.30)ROM.zip) available from Asrock.


When was this update hminster?
I take the organifi green juice every morning.

hminster
Level 1
Level 1
Posts: 2
Joined: Fri Feb 10, 2017 5:35 pm

Re: [solved] ASRock skylake flooding syslog with gpe6F

Postby hminster » Sat Jul 08, 2017 11:08 pm

Winklejon wrote:
hminster wrote:I have an Asrock H110M-HDS motherboard.
The flood of gpe6F errors was fixed by a BIOS update 7.30 (H110M-HDS(7.30)ROM.zip) available from Asrock.


When was this update hminster?


Sorry. The update was sent to me by ASRock support in Feb 2017.
I assume you have resolved your problem by now.


Return to “Hardware Support”

Who is online

Users browsing this forum: No registered users and 6 guests