Page 1 of 1

[SOLVED] bluetooth headset pairing ConnectionAttemptFailed

Posted: Tue Aug 30, 2016 7:49 pm
by vimsical
Linux Mint 18 Cinnamon. I tried to use "Bluetooth" from "System Settings", it will occasionally detect the device but with a "Not Set Up" tag. Clicking it turn the "Not Set Up" into a spinning wheel for a while, returning to "Not Set Up". Going to CLI instead, and I got this:

Code: Select all

$ bluetoothctl 
[NEW] Controller AC:D1:B8:C0:68:9E XPS-13 [default]
[CHG] Controller AC:D1:B8:C0:68:9E Discovering: no
[bluetooth]# scan on
Discovery started
[CHG] Controller AC:D1:B8:C0:68:9E Discovering: yes
[NEW] Device 00:23:01:11:B8:B3 Runaway
[bluetooth]# pair 00:23:01:11:B8:B3 
Attempting to pair with 00:23:01:11:B8:B3
Failed to pair: org.bluez.Error.ConnectionAttemptFailed
[CHG] Controller AC:D1:B8:C0:68:9E DiscoverableTimeout: 0x000000
[CHG] Controller AC:D1:B8:C0:68:9E DiscoverableTimeout: 0x000000
Can anyone help with the "ConnectionAttemptFailed" error?


Turns out that this is a symptom of another issue with the computer (Dell XPS13, 2015) which has a Broadcom bluetooth chip.

Code: Select all

$ lsusb  | grep -i bluetooth
Bus 002 Device 003: ID 0a5c:216f Broadcom Corp. BCM20702A0 Bluetooth
It is not legal to ship with the firmware for the device. So there is an error message in the kernel log as followings

Code: Select all

Aug 30 16:40:09 XPS-13 kernel: [    8.560291] bluetooth hci0: Direct firmware load for brcm/BCM20702A1-0a5c-216f.hcd failed with error -2
You have to follow the guide below and convert a firmware file from the Windows driver. ... -on-ubuntu

This solves the Bluetooth woe for this computer.