'Disable touchpad while typing not working' in LM18

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
melpomene
Level 1
Level 1
Posts: 1
Joined: Tue Sep 06, 2016 12:09 pm

'Disable touchpad while typing not working' in LM18

Postby melpomene » Tue Sep 06, 2016 12:20 pm

Hi all,

I am new to Linux Mint and it's great. I have only one small issue with my touchpad. It seems the control for the touchpad is not working as it should. In particular the ‘Disable touchpad while typing’ control does not work which is quite inconvenient. I tried to find out more on this issue and I guess it could be related to the fact that my system seems to not recognize my touchpad correctly (the output of xinput shows two touchpads ELAN1010:00 04F3:3012 Touchpad and ETPS/2 Elantech Touchpad which seems to be odd). Does anyone know a fix for this issue or point me to a solution?
Thanks for your help!

Details (let me know if any further information would be useful)

moestmar@mmoest ~ $ xinput
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ Atmel Atmel maXTouch Digitizer id=13 [slave pointer (2)]
⎜ ↳ ELAN1010:00 04F3:3012 Touchpad id=14 [slave pointer (2)]
⎜ ↳ ETPS/2 Elantech Touchpad id=16 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Power Button id=6 [slave keyboard (3)]
↳ Video Bus id=7 [slave keyboard (3)]
↳ Video Bus id=8 [slave keyboard (3)]
↳ Power Button id=9 [slave keyboard (3)]
↳ Sleep Button id=10 [slave keyboard (3)]
↳ Integrated_Webcam_HD id=12 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=15 [slave keyboard (3)]
↳ DELL Wireless hotkeys id=17 [slave keyboard (3)]
↳ Dell WMI hotkeys id=18 [slave keyboard (3)]


System info:
OS: Linux Mint 18 Cinnamon 64-bit
Cinnamon Version: 3.0.7
Linux Kernel: 4.4.0-36-generic
Machine: Dell Inspiron15 7000 Series

deepakdeshp
Level 8
Level 8
Posts: 2330
Joined: Sun Aug 09, 2015 10:00 am

Re: 'Disable touchpad while typing not working' in LM18

Postby deepakdeshp » Tue Sep 20, 2016 5:12 pm

If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 18 Cinnamon 64 bit with AMD processor .

User avatar
Pjotr
Level 18
Level 18
Posts: 8631
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: 'Disable touchpad while typing not working' in LM18

Postby Pjotr » Tue Sep 20, 2016 5:15 pm

Tip: 10 things to do after installing Linux Mint 18.2 Sonya
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

deepakdeshp
Level 8
Level 8
Posts: 2330
Joined: Sun Aug 09, 2015 10:00 am

Re: 'Disable touchpad while typing not working' in LM18

Postby deepakdeshp » Wed Sep 21, 2016 4:57 pm

Pjotr wrote:Try this:
https://sites.google.com/site/easylinux ... one-second
(item 16, right column)


Thank you. These are invaluable tips . :D
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 18 Cinnamon 64 bit with AMD processor .

asimsalam
Level 1
Level 1
Posts: 14
Joined: Sun Aug 10, 2014 5:14 pm

Re: 'Disable touchpad while typing not working' in LM18

Postby asimsalam » Fri Dec 09, 2016 3:17 am

melpomene, did you find a solution to this besides installing the utility deepakdeshp suggested?
I have the same machine and see the same problem. Like melpomene, I thought it could be due to the two toucpads present in the output of xinput. But if you see the output from my system below, you will see the external Microsoft mouse that I currently have plugged in also seems to show up twice.
~ $ xinput list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ Lite-On Technology Corp. Lenovo silver silk (wireless) 2.4G K&M kit id=12 [slave pointer (2)]
⎜ ↳ Lite-On Technology Corp. Lenovo silver silk (wireless) 2.4G K&M kit id=13 [slave pointer (2)]
⎜ ↳ Microsoft Microsoft® Nano Transceiver v2.0 id=15 [slave pointer (2)]
⎜ ↳ Microsoft Microsoft® Nano Transceiver v2.0 id=16 [slave pointer (2)]
⎜ ↳ ELAN1010:00 04F3:3012 Touchpad id=18 [slave pointer (2)]
⎜ ↳ ETPS/2 Elantech Touchpad id=20 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Power Button id=6 [slave keyboard (3)]
↳ Video Bus id=7 [slave keyboard (3)]
↳ Video Bus id=8 [slave keyboard (3)]
↳ Power Button id=9 [slave keyboard (3)]
↳ Sleep Button id=10 [slave keyboard (3)]
↳ Lite-On Technology Corp. Lenovo silver silk (wireless) 2.4G K&M kit id=11 [slave keyboard (3)]
↳ Microsoft Microsoft® Nano Transceiver v2.0 id=14 [slave keyboard (3)]
↳ Integrated_Webcam_HD id=17 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=19 [slave keyboard (3)]
↳ DELL Wireless hotkeys id=21 [slave keyboard (3)]
↳ Dell WMI hotkeys id=22 [slave keyboard (3)]

Any resolution to this?

paradroid
Level 1
Level 1
Posts: 37
Joined: Sat Jul 04, 2015 1:56 am

Re: 'Disable touchpad while typing not working' in LM18

Postby paradroid » Thu Dec 22, 2016 2:50 pm

is this bug likely to be fixed anytime soon?

Cosmo.
Level 22
Level 22
Posts: 15431
Joined: Sat Dec 06, 2014 7:34 am

Re: 'Disable touchpad while typing not working' in LM18

Postby Cosmo. » Thu Dec 22, 2016 3:40 pm

It is a stone-aged bug. So I would not hold my breath.

paradroid
Level 1
Level 1
Posts: 37
Joined: Sat Jul 04, 2015 1:56 am

Re: 'Disable touchpad while typing not working' in LM18

Postby paradroid » Thu Dec 22, 2016 5:35 pm

So what do other users do to not interrupt typing with the touchpad? Laptops are getting bigger touchpads every year. Am I really the only one bothered by touchpad clicks while typing? By the way it works very well with Linux Mint MATE so they would have the code to fix it already.

I found that "syndaemon -i 1.0 -K -R -t" command as solution but it does nothing.

Cosmo.
Level 22
Level 22
Posts: 15431
Joined: Sat Dec 06, 2014 7:34 am

Re: 'Disable touchpad while typing not working' in LM18

Postby Cosmo. » Thu Dec 22, 2016 5:39 pm

I do prefer a real mouse to the touchpad. So I disable it (Fn-key combination), when I do not need it.

paradroid
Level 1
Level 1
Posts: 37
Joined: Sat Jul 04, 2015 1:56 am

Re: 'Disable touchpad while typing not working' in LM18

Postby paradroid » Mon Mar 27, 2017 3:46 am

For everyone interested in disabeling touchpad while typing I solved this issue by installing the latest libinput from github.

https://wayland.freedesktop.org/libinpu ... pendencies

I compiled it without libwacom because I could not find that lib in the required version, because I do not use a wacom device I do not care bout them.
The autogensript will bring up some errors and you have to google this error and install the thing that is missing and run autogen so long till it runs without errors.
Maybe I make a more detailed instruction when I have more spare time.

Libinput 1,7 works great, touchpad is way more responsive and precise, just everything works better.

User avatar
Pjotr
Level 18
Level 18
Posts: 8631
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: 'Disable touchpad while typing not working' in LM18

Postby Pjotr » Mon Mar 27, 2017 4:16 am

@paradroid: have you also tried libinput 1.6.3-1, which is available in the official Ubuntu repo's? Installation of that, is much easier, and even Wacom support remains intact....

To other people who read this: don't try this at home. Negative side effects are quite possible.

How-to:

For 64-bit, download this:
http://archive.ubuntu.com/ubuntu/pool/m ... _amd64.deb

Then this:
http://archive.ubuntu.com/ubuntu/pool/m ... _amd64.deb

Then this:
http://archive.ubuntu.com/ubuntu/pool/m ... _amd64.deb

Finally this:
http://archive.ubuntu.com/ubuntu/pool/m ... -1_all.deb

Installation:

Code: Select all

cd Downloads


Code: Select all

sudo dpkg --force-depends-version -i libinput-bin*


Code: Select all

sudo dpkg --force-depends-version -i libwacom2*


Code: Select all

sudo dpkg --force-depends-version -i libwacom-common*


Code: Select all

sudo dpkg -i libinput10*


Reboot.

-- Edit: applied small correction
Tip: 10 things to do after installing Linux Mint 18.2 Sonya
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

paradroid
Level 1
Level 1
Posts: 37
Joined: Sat Jul 04, 2015 1:56 am

Re: 'Disable touchpad while typing not working' in LM18

Postby paradroid » Mon Mar 27, 2017 10:44 am

Because libinput 1.7 is such a big step forward, and everything works so much smoother, for me there is no point in testing an older version anymore.

Maybee someone else wants to test this ppa, or just wait a few days untill the ppa has version 1.7.

Man I love the new smooth scrolling with libinput 1.7.

theaterghost
Level 1
Level 1
Posts: 13
Joined: Thu Mar 30, 2017 3:03 pm

Re: 'Disable touchpad while typing not working' in LM18

Postby theaterghost » Sat May 06, 2017 4:11 pm

I found this script useful when added to startup applications.

Code: Select all

killall syndaemon 2>/dev/null
sleep 1
syndaemon -i 1.0 -d

This kills the running syndaemon that cinnamon starts, and uses my options instead.

mikkime23
Level 1
Level 1
Posts: 1
Joined: Sat Jul 22, 2017 3:18 am

Re: 'Disable touchpad while typing not working' in LM18

Postby mikkime23 » Sat Jul 22, 2017 3:20 am

Hi all,

I found an amazing little app called Touccpad Indicator. Does the trick perfectly.

http://www.linuxandubuntu.com/home/how-to-disable-touchpad-while-writing-article-or-documentation-in-ubuntulinux-mint-or-derivatives-linux

Hope this helps!!


Return to “Hardware Support”

Who is online

Users browsing this forum: No registered users and 7 guests