Mint 18 Mate Brightness trouble

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
Friedrich79
Level 1
Level 1
Posts: 7
Joined: Wed Feb 05, 2014 9:35 am

Mint 18 Mate Brightness trouble

Post by Friedrich79 » Wed Dec 28, 2016 5:07 pm

Hey guys,

I'm trying to get the backlight fn-buttons working with my Clevo P651 RE6-G (actually Tuxedo XC1506) and Linux Mint 18, Mate.
Kernel version 4.4.0-47-generic, Nvidia driver 375.26-0ubuntu0~gpu16.04.1

I tried changing in /etc/default/grub

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
to the following with the following effects:


Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_os_name=Linux acpi_osi= acpi_backlight=vendor"
  • no fn-key onscreen display
  • no brightness bar in "Power Management Preferences"
  • /sys/class/backlight/ empty

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"
  • no fn-key onscreen display
  • no brightness bar in "Power Management Preferences"
  • /sys/class/backlight/ empty

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor
  • no fn-key onscreen display
  • no brightness bar in "Power Management Preferences"
  • /sys/class/backlight/ empty

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi="
  • no fn-key onscreen display
  • Backlight is somewhat darker.
  • /sys/class/backlight/ includes acpi_video0
  • max_brightness = 10 (! not 100)
  • Values can be changed with the "Power Management Preferences" slider but not with fn-keys, but no effect on display.
  • An identical directory is also found at
    /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0/backlight/acpi_video0

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"
  • There is a functional fn-key onscreen display
  • /sys/class/backlight/ includes acpi_video0
  • max_brightness = 100 (! not 10)
  • Values can be changed with the "Power Management Preferences" slider and with fn-keys, but no effect on display.
  • An identical directory is also found at
    /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0/backlight/acpi_video0
  • This is same as the default "quite splash".
I also tried adding to /etc/X11/xorg.conf:

Code: Select all

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option         "RegistryDwords" "EnableBrightnessControl=1"
EndSection

But this made no difference.


Anything else I could try?

Post Reply

Return to “Hardware Support”