Installation on Lenovo Miix 310-101CR, then the black screen

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
Peterburd
Level 1
Level 1
Posts: 27
Joined: Sun Jan 13, 2008 2:03 am

Installation on Lenovo Miix 310-101CR, then the black screen

Post by Peterburd »

I managed to install a couple of different distros on my Lenovo Miix (a clean install, wiping out windows 10 entirely), but after it boots up nothing happens. Black screen, not even a cursor.

Except, TWICE, it gave me my login screen, and let me log in, whereupon I did the usual things, update the system, etc. But those were two exceptions and I have no idea why they happened. Plus, the first few times, I was encrypting my hard disk, and when rebooting it would ask me for the password ... So I know the OS was installed.

In other words, this is not an installation problem. I suspect it has to do with the drivers. This uses Intel HD graphics, BTW.

I've tried Cinnamon and Mate 18.1, and for kicks, the latest Ubuntu flavors, Manjaro, and Fedora, even Arch, each of which presented me with new, different horizons of failure.

Thanks for any pointers or links you can provide!

deepakdeshp
Level 16
Level 16
Posts: 6581
Joined: Sun Aug 09, 2015 10:00 am

Re: Installation on Lenovo Miix 310-101CR, then the black screen

Post by deepakdeshp »

Please see
https://community.linuxmint.com/tutorial/view/842

Post back result of command

Code: Select all

inxi -Fxz
in terminal booting from live usb/dvd
If you have. nvidia, which will be displayed by inxi command , you can see following https://sites.google.com/site/easylinuxtipsproject/12
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.3 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

Peterburd
Level 1
Level 1
Posts: 27
Joined: Sun Jan 13, 2008 2:03 am

Re: Installation on Lenovo Miix 310-101CR, then the black screen

Post by Peterburd »

Thanks for the quick reply. I have already looked at that link. The trouble is that I don't have a grub menu to go to, I assume since I'm only booting one OS.

As for the results of inxi -Fxz ...

System: Host: mint Kernel: 4.4.0-53-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: MATE 1.16.1 (Gtk 3.18.9-1ubuntu3.1)
Distro: Linux Mint 18.1 Serena
Machine: System: LENOVO product: 80SG v: MIIX 310-10ICR
Mobo: LENOVO model: Cavalli v: SDK0J91196 WIN
Bios: LENOVO v: 3YCN30WW date: 09/02/2016
CPU: Quad core Intel Atom x7-Z8750 (-MCP-) cache: 1024 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 12799
clock speeds: max: 2560 MHz 1: 540 MHz 2: 746 MHz 3: 895 MHz
4: 1268 MHz
Graphics: Card: Intel Device 22b0 bus-ID: 00:02.0
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
Resolution: 1200x1920@60.00hz
GLX Renderer: Mesa DRI Intel HD Graphics (Cherryview)
GLX Version: 3.0 Mesa 11.2.0 Direct Rendering: Yes
Audio: Card Failed to Detect Sound Card! Sound: ALSA v: k4.4.0-53-generic
Network: Card: Intel Wireless 3165 driver: iwlwifi bus-ID: 01:00.0
IF: wlp1s0 state: down mac: <filter>
Drives: HDD Total Size: 7.8GB (0.8% used)
ID-1: /dev/mmcblk0 model: N/A size: 62.5GB
ID-2: USB /dev/sda model: TransMemory size: 7.8GB temp: 0C
Partition: ID-1: / size: 1.9G used: 66M (4%) fs: overlay dev: N/A
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 40.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 208 Uptime: 2 min Memory: 338.1/3866.1MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.461) inxi: 2.2.35


... As for that "failed to detect sound card" message, I'll save that issue for another day!

deepakdeshp
Level 16
Level 16
Posts: 6581
Joined: Sun Aug 09, 2015 10:00 am

Re: Installation on Lenovo Miix 310-101CR, then the black screen

Post by deepakdeshp »

Menu will appear if you press and hold Shift during loading Grub.

For permanent change you'll need to edit your /etc/default/grub file -- place a "#" symbol at the start of line GRUB_HIDDEN_TIMEOUT=0.

Save changes and run sudo update-grub to apply changes.

Documentation: https://help.ubuntu.com/community/Grub2
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.3 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

Peterburd
Level 1
Level 1
Posts: 27
Joined: Sun Jan 13, 2008 2:03 am

Re: Installation on Lenovo Miix 310-101CR, then the black screen

Post by Peterburd »

Not much progress, I'm afraid.

I did manage to get to the grub menu (I thought if there was only one OS installed, there would be no grub), jumping a few hurdles along the way, including the "canonical use of /cow" message when trying to update grub. Chrooting in to make the change was made more difficult because I found the partitions had odd names I didn't recognize, like mmcblk0p1, and the like.

The upshot is that I can easily get to grub now, but none of the suggestions on that page work, not even the i915.modeset=0 one. The only variations I notice is sometimes the booting up screen is distorted and sometimes it isn't.

deepakdeshp
Level 16
Level 16
Posts: 6581
Joined: Sun Aug 09, 2015 10:00 am

Re: Installation on Lenovo Miix 310-101CR, then the black screen

Post by deepakdeshp »

Set the nomodeset option while booting in grub and boot
https://community.linuxmint.com/tutorial/view/842
Once you boot into the desktop, apply the video drivers
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.3 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

Peterburd
Level 1
Level 1
Posts: 27
Joined: Sun Jan 13, 2008 2:03 am

Re: Installation on Lenovo Miix 310-101CR, then the black screen

Post by Peterburd »

Thanks again, but adding nomodeset was the very first thing I tried. I went through that last year when installing an nvidia card.

I've tried all of the pertinent words from that first link, nomodeset, i915=0, adding the gfxmode options, etc. Maybe I should wait until the kernel catches up to the new drivers.

deepakdeshp
Level 16
Level 16
Posts: 6581
Joined: Sun Aug 09, 2015 10:00 am

Re: Installation on Lenovo Miix 310-101CR, then the black screen

Post by deepakdeshp »

Somebody else may help here. Good luck
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.3 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

Peterburd
Level 1
Level 1
Posts: 27
Joined: Sun Jan 13, 2008 2:03 am

Re: Installation on Lenovo Miix 310-101CR, then the black screen

Post by Peterburd »

Thanks again for your help!

yquux
Level 1
Level 1
Posts: 40
Joined: Mon Nov 17, 2014 4:28 pm
Location: France

Re: Installation on Lenovo Miix 310-101CR, then the black screen

Post by yquux »

@ Peterburd:
Hello - any news on the Miix 310 ? May be interesting to get Mint working on it... did you try antiX ? When trying to install Linux on some strange devices, it was usually successful for me... even on bay-trails with 32bit UEFI...
Does Miix 310 have a 32bit UEFI ?

Yquux
ASUS MAXIMUS IX APEX - i7-6700T - 16Go (ssd) - Mint 19.3 Cinnamon
Acer SF113-31 - N4200 - M.2 SSD 250 Go - Mint 19.3 XFCE

User avatar
bbaker6212
Level 5
Level 5
Posts: 522
Joined: Wed Aug 12, 2015 6:35 pm

Re: Installation on Lenovo Miix 310-101CR, then the black screen

Post by bbaker6212 »

I would try one of Linuxium's distros, tweaked Ubuntu, specifically for cherry-trail Atom devices...
http://linuxiumcomau.blogspot.com.br/20 ... buntu.html
Linux Mint Mate 19.1 k/4.15, Windows 10, Manjaro 18.03 Xfce k/4.19.24-1 MX-Linux 18.1 Lenovo Ideapad G50-45 8GB
Lenovo Ideapad 330S-15IKB, Core i5-8250U, 8GB RAM, Samsung EVO 850 SATA SSD, 14GB Optane M.2 PCIe NVMe, QCA9377 WiFi

Peterburd
Level 1
Level 1
Posts: 27
Joined: Sun Jan 13, 2008 2:03 am

Re: Installation on Lenovo Miix 310-101CR, then the black screen

Post by Peterburd »

Wow, didn't realize people had replied. Sorry I haven't responded until now.

Yquux: I tried Antix, at least the live version of it. The live version boots fine, which is a good start, but like almost all of the distros I've tried, it puts everything sideways on the Lenovo, which is a laptop/tablet hybrid, after all. I couldn't find a way to rotate the screen, at least in the live version. But I'll get back to it before long and figure something out maybe.

(EDIT) figured out the rotating. But I botched the first two attempts to install. Will try again in a couple days!

bbaker6212: Thanks for the links. Didn't know that this project was going on. Alas, I have the same problems with the live screen displaying gibberish that I have with the "official" versions I tried before. But I'll keep an eye on the Linuxium spins ...

Dupo
Level 5
Level 5
Posts: 511
Joined: Thu Jan 31, 2008 9:42 pm

Re: Installation on Lenovo Miix 310-101CR, then the black screen

Post by Dupo »

Hi,

@ Peterburd: If you installed linux mint 18.1 on your hardware and you have a black screen after the installation. I have the solution.

There is a problem (blackscreen) with 4.4.0-53 kernel available by default with Baytrail hardware. The 4.8.0-xx solve the problem.

The solution:

1. Boot into your efi boot menu (with one of the function button).
2. Choose Ubuntu option from boot efi menu.
3. In the grub menu, press "c" to enter command line and press "ls" command. You must see : (hd0,gpt5), (hd0,gpt4,) ....
You must know where you have created the root partition. Mine is /dev/mmcblk0p5. Check yours.
4. In the grub prompt, you must type: linux (hd0,gpt5)/boot/vmlinuz-4.4.0-53-generic root=/dev/mmcblk0p5 intel_idle.max_cstate=0 intel_pstates=disabled
Note: gpt5 means it is the five partition (for root). Check yours.
5. In the grub prompt, type : initrd (hd0,gpt5)/boot/initrd.img-4.4.0-53-generic
6. In the grub prompt, type : boot
7. If it works you must see the mdm screen.
8. Install the 4.8.0-xx kernel after through MintUpdate.
9. reboot.

Peterburd
Level 1
Level 1
Posts: 27
Joined: Sun Jan 13, 2008 2:03 am

Re: Installation on Lenovo Miix 310-101CR, then the black screen

Post by Peterburd »

Dupo, I'd love to try your solution out, but while fooling around with an AntiX installation, I must have overwritten the efi partition that the hard disk needs to boot. Now the Lenovo doesn't see the hard disk at all. I try to install Mint, all it can find is the USB boot drive itself.

Sometimes I wonder if I should stand at least a meter away from any computer doing an installation ... Anyway, any ideas on how to fix this NEW problem? Most quick searches for the problem assume I have a windows disk laying around ...

maxarsys
Level 1
Level 1
Posts: 24
Joined: Mon Nov 05, 2012 3:00 am

Re: Installation on Lenovo Miix 310-101CR, then the black screen

Post by maxarsys »

Hello ! I have exactly the same product and I am exactly doing the same thing. However my story is a bit different and I want your help to try out what you said to do with the kernel issue.

However I can get to the grub options,
I choosed to do an encrypted install of Linux mint. When I start the computer, I try to hold shift but it get to the pass phrase to decrypt the harddrive. Then immediately
After I tried holding shift but it went right away to black screen.


Can you please help me to get to grub since I have installed only Linux mint 18.1 XFce Edition

Then I would be able to get a feedback if the last suggested solution is working or not.


Édit : i managed to get to grub but i cant figure out where is my root partition since i cant see anything once the computer has started ...

How can i figure that out only using grub ?

maxarsys
Level 1
Level 1
Posts: 24
Joined: Mon Nov 05, 2012 3:00 am

Re: Installation on Lenovo Miix 310-101CR, then the black screen

Post by maxarsys »

Sorry for the double post. Well i managed to get graphics using hdmi cable to the TV but graphics on the screen are horrible full of layers like if steped on the screen, but not on the TV.

Well i decided to go right away to the last step since graphics works (not well at all on the laptop screen).
Edit: now it s black again, and I can only see a quater of the screen on the tv.

And after I warned to get the last kernel hoping i d get better screen but wifi is not working!

It s says my wifi card is not detected. It s weird because the output of the commande you typed above shows the same except the network line : card: failed to detect network card ...
Is there is a kernel module that I can load to get wifi working ? I can't even get to internet using Ethernet since there is not Ethernet on the laptop.... aie aie aie... stupid me

User avatar
bbaker6212
Level 5
Level 5
Posts: 522
Joined: Wed Aug 12, 2015 6:35 pm

Re: Installation on Lenovo Miix 310-101CR, then the black screen

Post by bbaker6212 »

Try installing Manjaro Xfce onto a USB drive and boot from that. This might allow you to run Gparted and config your eMMC if it can be seen.
Linux Mint Mate 19.1 k/4.15, Windows 10, Manjaro 18.03 Xfce k/4.19.24-1 MX-Linux 18.1 Lenovo Ideapad G50-45 8GB
Lenovo Ideapad 330S-15IKB, Core i5-8250U, 8GB RAM, Samsung EVO 850 SATA SSD, 14GB Optane M.2 PCIe NVMe, QCA9377 WiFi

Post Reply

Return to “Hardware Support”