[Solved] USB Drive Read-Only File System

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
User avatar
White Phoenix
Level 4
Level 4
Posts: 256
Joined: Sun Dec 22, 2013 9:01 am
Location: Ypsilanti
Contact:

[Solved] USB Drive Read-Only File System

Postby White Phoenix » Sat Mar 04, 2017 1:52 pm

Linux Mint 17.3 MATE, Toshiba laptop with 64 bit dual processor and 4 GB RAM.

DOSDrycraft, Runa, Grimoire Windows, are all on the Hitachi 320 GB hard drive. DOSDrycraft and Runa are FAT16, Grimoire Windows is NTFS. IRIS is a 125 MB FAT16 SD card, Penseive is a 1 GB NTFS Lexar Jumpdrive Secure USB thumbdrive. Xanadu and Shangri-La are NTFS Western Digital My Passport 500 GB USB drives, Karnak (NTFS) and Stonehenge (ext4) are on a Western Digital My Passport Ultra 1 TB USB drive. Mouseio (1 TB) and Limbo (2 TB) are ext4 Western Digital Elements USB drives. All are MBR partition types.

Code: Select all

whitephoenix@BookOfShadows /media/whitephoenix $ ls --la
ls: unrecognized option '--la'
Try 'ls --help' for more information.
whitephoenix@BookOfShadows /media/whitephoenix $ ls -la
total 172
drwxr-x---+ 13 root         root          4096 Mar  4 15:24 .
drwxr-xr-x   3 root         root          4096 Mar  1 13:47 ..
drwx------   3 whitephoenix whitephoenix 16384 Dec 31  1969 DOSDrycraft
drwx------   1 whitephoenix whitephoenix  8192 Mar  2 17:54 Grimoire Windows
drwx------   3 whitephoenix whitephoenix 16384 Mar  4 15:10 IRIS
drwx------   1 whitephoenix whitephoenix  4096 Mar  4 06:33 Karnak
drwx------  16 whitephoenix whitephoenix  4096 Mar  3 21:12 Limbo
drwx------   6 whitephoenix whitephoenix  4096 Mar  2 15:38 Mouseio
drwx------   1 whitephoenix whitephoenix 86016 Mar  3 21:14 Penseive
drwx------   4 whitephoenix whitephoenix 16384 Dec 31  1969 Runa
drwx------   1 whitephoenix whitephoenix  4096 Mar  4 10:53 Shangri-La
drwx------  10 whitephoenix whitephoenix  4096 Feb 24 06:51 Stonehenge
drwx------   1 whitephoenix whitephoenix  4096 Mar  3 21:14 Xanadu
whitephoenix@BookOfShadows /media/whitephoenix $ chmod 660 DOSDrycraft
whitephoenix@BookOfShadows /media/whitephoenix $ chmod 660 Grimoire\ Windows
whitephoenix@BookOfShadows /media/whitephoenix $ chmod 660 Runa
whitephoenix@BookOfShadows /media/whitephoenix $ chmod 770 IRIS
whitephoenix@BookOfShadows /media/whitephoenix $ chmod 770 Karnak
whitephoenix@BookOfShadows /media/whitephoenix $ chmod 770 Limbo
chmod: changing permissions of ‘Limbo’: Read-only file system
whitephoenix@BookOfShadows /media/whitephoenix $ chmod 770 Mouseio
whitephoenix@BookOfShadows /media/whitephoenix $ chmod 770 Penseive
whitephoenix@BookOfShadows /media/whitephoenix $ chmod 770 Shangri-La
whitephoenix@BookOfShadows /media/whitephoenix $ chmod 770 Xanadu
whitephoenix@BookOfShadows /media/whitephoenix $ ls -la
total 172
drwxr-x---+ 13 root         root          4096 Mar  4 15:24 .
drwxr-xr-x   3 root         root          4096 Mar  1 13:47 ..
drwx------   3 whitephoenix whitephoenix 16384 Dec 31  1969 DOSDrycraft
drwx------   1 whitephoenix whitephoenix  8192 Mar  2 17:54 Grimoire Windows
drwx------   3 whitephoenix whitephoenix 16384 Mar  4 15:10 IRIS
drwx------   1 whitephoenix whitephoenix  4096 Mar  4 06:33 Karnak
drwx------  16 whitephoenix whitephoenix  4096 Mar  3 21:12 Limbo
drwxrwx---   6 whitephoenix whitephoenix  4096 Mar  2 15:38 Mouseio
drwx------   1 whitephoenix whitephoenix 86016 Mar  3 21:14 Penseive
drwx------   4 whitephoenix whitephoenix 16384 Dec 31  1969 Runa
drwx------   1 whitephoenix whitephoenix  4096 Mar  4 10:53 Shangri-La
drwx------  10 whitephoenix whitephoenix  4096 Feb 24 06:51 Stonehenge
drwx------   1 whitephoenix whitephoenix  4096 Mar  3 21:14 Xanadu
whitephoenix@BookOfShadows /media/whitephoenix $ sudo chmod 660 DOSDrycraft
[sudo] password for whitephoenix:
whitephoenix@BookOfShadows /media/whitephoenix $ sudo chmod 660 Grimoire\ Windows
whitephoenix@BookOfShadows /media/whitephoenix $ sudo chmod 660 Runa
whitephoenix@BookOfShadows /media/whitephoenix $ sudo chmod 770 IRIS
whitephoenix@BookOfShadows /media/whitephoenix $ sudo chmod 770 Karnak
whitephoenix@BookOfShadows /media/whitephoenix $ sudo chmod 770 Limbo
chmod: changing permissions of ‘Limbo’: Read-only file system
whitephoenix@BookOfShadows /media/whitephoenix $ sudo chmod 770 Penseive
whitephoenix@BookOfShadows /media/whitephoenix $ sudo chmod 770 Shangri-La
whitephoenix@BookOfShadows /media/whitephoenix $ sudo chmod 770 Xanadu
whitephoenix@BookOfShadows /media/whitephoenix $ ls -la
total 172
drwxr-x---+ 13 root         root          4096 Mar  4 15:24 .
drwxr-xr-x   3 root         root          4096 Mar  1 13:47 ..
drwx------   3 whitephoenix whitephoenix 16384 Dec 31  1969 DOSDrycraft
drwx------   1 whitephoenix whitephoenix  8192 Mar  2 17:54 Grimoire Windows
drwx------   3 whitephoenix whitephoenix 16384 Mar  4 15:10 IRIS
drwx------   1 whitephoenix whitephoenix  4096 Mar  4 06:33 Karnak
drwx------  16 whitephoenix whitephoenix  4096 Mar  3 21:12 Limbo
drwxrwx---   6 whitephoenix whitephoenix  4096 Mar  2 15:38 Mouseio
drwx------   1 whitephoenix whitephoenix 86016 Mar  3 21:14 Penseive
drwx------   4 whitephoenix whitephoenix 16384 Dec 31  1969 Runa
drwx------   1 whitephoenix whitephoenix  4096 Mar  4 10:53 Shangri-La
drwx------  10 whitephoenix whitephoenix  4096 Feb 24 06:51 Stonehenge
drwx------   1 whitephoenix whitephoenix  4096 Mar  3 21:14 Xanadu

Why did Mouseio change and not the others? More importantly, what does it mean that Limbo has a read-only file system? I used the same settings when formatting all the drives in Gnome Disks. I even changed Mouseio and Limbo to MBR because they were set to GPT when I bought them.

I used Limbo to back up Penseive, Karnak, Shangri-La and Xanadu without any problems. It took the better part of a day to do it, but now it’s taking forever to put everything back. Except for the thumbdrive. That only took a few minutes each way and Limbo didn’t complain about moving the files.
Last edited by White Phoenix on Thu Mar 16, 2017 9:33 pm, edited 1 time in total.
Linux Mint 17.3 / MATE
Toshiba Satellite L655d-S5151 (Intel dual processor, 64bit, 4G RAM)

fabien85
Level 6
Level 6
Posts: 1096
Joined: Tue Mar 11, 2014 4:30 pm

Re: USB Drive Read-Only File System

Postby fabien85 » Sat Mar 04, 2017 5:14 pm

NTFS filesystem does not support permissions in the linux sense, if you want files inside to have some set permissions, you need to specify options when mounting them. The standard is to set these options once and for all in /etc/fstab
You can find the currently mounted filesystems and their mounting options with

Code: Select all

mount

You can find the uuid of the partitions with

Code: Select all

blkid

(I think this requires that the partitions were present during boot time, so it doesnt update when you plug a drive. In that case you can use gparted > Partition > Information)

User avatar
White Phoenix
Level 4
Level 4
Posts: 256
Joined: Sun Dec 22, 2013 9:01 am
Location: Ypsilanti
Contact:

Re: USB Drive Read-Only File System

Postby White Phoenix » Sat Mar 04, 2017 7:08 pm

fabien85 wrote:NTFS filesystem does not support permissions in the linux sense, if you want files inside to have some set permissions, you need to specify options when mounting them.

But the drive I am having difficulties with being Read-Only is ext4 not NTFS. All the other drives are behaving just fine.

Also, I had set all of the drives, including the NTFS ones, to have all the same permissions. I did this before moving the files of Xanadu, Shangri-La, Karnak and Penseive to Limbo. Some of the NTFS drives had no permissions, some were read-only.

mount:

Code: Select all

/dev/sda7 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/cgroup type tmpfs (rw)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
none on /sys/fs/pstore type pstore (rw)
/dev/sda5 on /boot type ext4 (rw)
/dev/sda8 on /home type ext4 (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
systemd on /sys/fs/cgroup/systemd type cgroup (rw,noexec,nosuid,nodev,none,name=systemd)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=whitephoenix)
/dev/sdc1 on /media/whitephoenix/IRIS type vfat (rw,nosuid,nodev,uid=1000,gid=1000,shortname=mixed,dmask=0077,utf8=1,showexec,flush,uhelper=udisks2)
/dev/sdg2 on /media/whitephoenix/Stonehenge type ext4 (rw,nosuid,nodev,uhelper=udisks2)
/dev/sdf1 on /media/whitephoenix/Penseive type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)
/dev/sdb1 on /media/whitephoenix/Mouseio type ext4 (rw,nosuid,nodev,uhelper=udisks2)
/dev/sde1 on /media/whitephoenix/Limbo type ext4 (rw,nosuid,nodev,uhelper=udisks2)
/dev/sdh1 on /media/whitephoenix/Shangri-La type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)
/dev/sdg1 on /media/whitephoenix/Karnak type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)
/dev/sdd1 on /media/whitephoenix/Xanadu type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)

parted

Code: Select all

Model: ATA Hitachi HTS54503 (scsi)
Disk /dev/sda: 320GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type      File system     Flags
 1      1049kB  11.5MB  10.5MB  primary   fat16           lba
 2      11.5MB  158MB   147MB   primary   fat16           lba
 3      158MB   108GB   107GB   primary   ntfs            boot
 4      108GB   320GB   213GB   extended
 5      108GB   108GB   210MB   logical   ext4
 6      108GB   112GB   4295MB  logical   linux-swap(v1)
 7      112GB   134GB   21.5GB  logical   ext4
 8      134GB   320GB   187GB   logical   ext4


Model: Generic- Multi-Card (scsi)
Disk /dev/sdc: 125MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End    Size   Type     File system  Flags
 1      50.7kB  125MB  125MB  primary  fat16


Model: WD My Passport 0748 (scsi)
Disk /dev/sdd: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End    Size   Type     File system  Flags
 1      1049kB  500GB  500GB  primary  ntfs


Model: WD Elements 25A2 (scsi)
Disk /dev/sde: 2000GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  2000GB  2000GB  primary  ext4


Model: LEXAR JUMPDRIVE SECURE (scsi)
Disk /dev/sdf: 1038MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  1037MB  1036MB  primary  ntfs         boot


Model: WD My Passport 259F (scsi)
Disk /dev/sdg: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size   Type     File system  Flags
 1      1049kB  500GB   500GB  primary  ntfs
 2      500GB   1000GB  500GB  primary  ext4


Model: WD My Passport 0827 (scsi)
Disk /dev/sdh: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End    Size   Type     File system  Flags
 1      32.3kB  500GB  500GB  primary  ntfs         boot

Shangri-La (sdh) is showing as bootable, but I never set it. Although, Boot Repair or Windows may have.
Linux Mint 17.3 / MATE
Toshiba Satellite L655d-S5151 (Intel dual processor, 64bit, 4G RAM)

fabien85
Level 6
Level 6
Posts: 1096
Joined: Tue Mar 11, 2014 4:30 pm

Re: USB Drive Read-Only File System

Postby fabien85 » Sun Mar 05, 2017 3:26 pm

Hum, may be above my pay grade.
Did you try chmoding /media/whitephoenix/Limbo while the disk was unplugged ? And then plug it. Also try "defaults" as mounting options in the fstab.
One thing is that this drive is 2TB which is the limit that MBR can handle (see e.g. https://en.wikipedia.org/wiki/Master_boot_record), maybe that makes a difficulty (though I wouldnt understand why it would be a permission problem), would have been better to leave the drive as GPT (which is by the way a bit more robust to corruption than MBR).
You can remove boot flags with gparted if you need.

User avatar
White Phoenix
Level 4
Level 4
Posts: 256
Joined: Sun Dec 22, 2013 9:01 am
Location: Ypsilanti
Contact:

Re: USB Drive Read-Only File System

Postby White Phoenix » Mon Mar 06, 2017 11:10 am

Yes, I know about the 2 TB limitations. Gnome Disks was the first one to alert me to the partition table not being MBR.

I had start up and other problems with the drives as GPT. Not sure if it was the laptop or Linux. I have a feeling that the laptop doesn’t understand GPT. Even after changing the two Elements drives to MBR, the laptop still has a tendency to hang when they are plugged in when it starts up. Also, gParted doesn’t do GPT. Seems to me that needs to be updated soon, before a lot of people start complaining.

I just had a thought. The idea of having a 2 TB drive was to back the other drives up while they underwent maintenance (especially in Windows). What if I split the drive into three partitions or so? There is only one 1TB drive that is one partition. All the others are 500 GB partitions. None of them are (or will be when the data is restored to them) over half full. i decided on a limit of three 500 GB drives or the 1 TB and one of the 500 GB at one time when doing this. The thumb drives are only 16 MB at the most, so I really only need one 1 TB partition and maybe two 500 GB partitions, or two 1 TB partitions.

Yes, I remove the boot flags all the time, but it’s rather annoying to have a program keep putting them back on when there is no need. I am not sure I want to put entries for the drives in fstab any more. It started becoming a hassle keeping them from getting screwed up. After I gave up and just let Mint boot them as is, everything started up and ran just fine. Although, the CD/DVD player no longer shows up in media/<user> like it used to. It also doesn’t mount in the default location which causes a problem sometimes when burning/blanking a disk. So I do need to add that to fstab since it’s not mounting at the default point by itself. I am not sure which ID is best to use for that. The CD/DVD drive doesn’t have a UUID.

I will try the chmod technique and see what happens with that.

Code: Select all

whitephoenix@BookOfShadows ~/Desktop $ sudo chmod 770 Limbo
[sudo] password for whitephoenix:
chmod: cannot access ‘Limbo’: No such file or directory

Right.
Linux Mint 17.3 / MATE
Toshiba Satellite L655d-S5151 (Intel dual processor, 64bit, 4G RAM)

User avatar
Flemur
Level 13
Level 13
Posts: 4817
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: USB Drive Read-Only File System

Postby Flemur » Mon Mar 06, 2017 12:36 pm

White Phoenix wrote:I will try the chmod technique and see what happens with that.

Code: Select all

whitephoenix@BookOfShadows ~/Desktop $ sudo chmod 770 Limbo
[sudo] password for whitephoenix:
chmod: cannot access ‘Limbo’: No such file or directory

Right.


Shouldn't you be at:
/media/whitephoenix
and not at "~/Desktop" ??? (Unless you changed the mount-point from 1st post)

Try

Code: Select all

cd /media/whitephoenix
sudo chmod -R +w Limbo

(Or use the 770 rather than "+w"...I don't like using the numbers...)
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?

User avatar
White Phoenix
Level 4
Level 4
Posts: 256
Joined: Sun Dec 22, 2013 9:01 am
Location: Ypsilanti
Contact:

Re: USB Drive Read-Only File System

Postby White Phoenix » Mon Mar 06, 2017 2:55 pm

Shouldn't you be at:
/media/whitephoenix
and not at "~/Desktop" ??? (Unless you changed the mount-point from 1st post)

Nuts. Forgot to use the path. Best laid plans....

Code: Select all

whitephoenix@BookOfShadows /media/whitephoenix $ sudo chmod 770 Limbo
[sudo] password for whitephoenix:
chmod: cannot access ‘Limbo’: No such file or directory
whitephoenix@BookOfShadows /media/whitephoenix $ ls -la
total 132
drwxr-x---+ 10 root         root          4096 Mar  6 13:51 .
drwxr-xr-x   3 root         root          4096 Mar  1 13:47 ..
drwx------   3 whitephoenix whitephoenix 16384 Dec 31  1969 IRIS
drwx------   1 whitephoenix whitephoenix  4096 Mar  4 06:33 Karnak
drwxrwx---  16 whitephoenix whitephoenix  4096 Mar  3 21:12 Limbo
drwx------   6 whitephoenix whitephoenix  4096 Mar  2 15:38 Mouseio
drwx------   1 whitephoenix whitephoenix 86016 Mar  3 21:14 Penseive
drwx------   1 whitephoenix whitephoenix  4096 Mar  4 10:53 Shangri-La
drwxrwx---  10 whitephoenix whitephoenix  4096 Feb 24 06:51 Stonehenge
drwx------   1 whitephoenix whitephoenix  4096 Mar  3 21:14 Xanadu
whitephoenix@BookOfShadows /media/whitephoenix $

Still won’t work while the drive is unmounted and disconnected. BTW, I did all of them that hadn’t been changed again when I experimented earlier. One more drive was set. But even after re-booting, no more drives could be set. Guess I am only allowed to set one a day? Oh, wait a minute Limbo took, but I lost Mouseio.
Linux Mint 17.3 / MATE
Toshiba Satellite L655d-S5151 (Intel dual processor, 64bit, 4G RAM)

fabien85
Level 6
Level 6
Posts: 1096
Joined: Tue Mar 11, 2014 4:30 pm

Re: USB Drive Read-Only File System

Postby fabien85 » Wed Mar 08, 2017 10:16 am

Sorry for the late reply, I had a laptop breakdown.
gparted does work with GPT. Maybe you are confused with fdisk which indeed only works with MBR as far as I know (you can use gdisk instead for GPT).
To boot on a GPT drive is indeed different than on a MBR drive. But for storage, it should be transparent in principle.

For the rest, I thought you had defined the mount points manually and put the drives in your fstab. If you let them mount automatically, indeed you cant chmod the mount point when the drive is disconnected, as the mount point isnt there anymore. I dont know what goes wrong with the auto-mounting, this looks above my experience ; personally I would give up and force the thing by defining manually a fstab entry.

User avatar
White Phoenix
Level 4
Level 4
Posts: 256
Joined: Sun Dec 22, 2013 9:01 am
Location: Ypsilanti
Contact:

Re: USB Drive Read-Only File System

Postby White Phoenix » Wed Mar 08, 2017 1:05 pm

That’s right, gParted complained about the FAT12 partitions I had to use for the MS-DOS 5.0 partition. When I used fdisk, it complained about not being able to handle the UFT partitions. Then when I made the entries in my notes, I put down gParted complained about UFT. If I remember correctly gPart is able to handle the FAT12 and there is another fdisk, (gnu-fdisk?) that handles UFT partitions.

Well, much as I hate to go through it all just to have complaints from the system again, I will create entries on fstab. Maybe if I just use “defaults” for the options, the drives will behave. I remember now what the problem wound up being. At boot it would take a long time for the system to find all the drives. It especially freaked if one drive was not connected (I don’t always need Limbo and Mouseio connected). It would either take a very long time before giving up, or just hang.

Thanks for trying to help anyway.
Linux Mint 17.3 / MATE
Toshiba Satellite L655d-S5151 (Intel dual processor, 64bit, 4G RAM)

fabien85
Level 6
Level 6
Posts: 1096
Joined: Tue Mar 11, 2014 4:30 pm

Re: USB Drive Read-Only File System

Postby fabien85 » Thu Mar 09, 2017 6:55 am

If you make a fstab entry (for lack of an alternative indeed), put the "noauto" option. That way the system will not try to mount the drive during boot and will not freak out if it's not there. It will just mount when you connect the drive and click on it in the file manager.
For example I have an entry like this in my fstab :

Code: Select all

# ext4 partition on Storeva external HD
UUID=blabla  /media/fabien/Linux-Storeva  ext4  noauto  0  0

where I created manually the mount point and chowned it :

Code: Select all

$ ll /media/fabien/
snip.. snip
drwxr-xr-x   2 fabien fabien  4096 janv. 11 17:26 Linux-Storeva/


(I'm not saying this is the best way to do it, it's just the way I found. Maybe someone will correct it. e.g. I'm not sure I really needed to chown the mount point. And maybe it would be better to add the option uid=fabien so that files inside the partition are owned by me ; I'm not clear about that.)

User avatar
austin.texas
Level 20
Level 20
Posts: 11777
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: USB Drive Read-Only File System

Postby austin.texas » Thu Mar 09, 2017 8:16 am

fabien85 wrote:Maybe someone will correct it. e.g. I'm not sure I really needed to chown the mount point. And maybe it would be better to add the option uid=fabien so that files inside the partition are owned by me ; I'm not clear about that.)
When you are mounting a ext filesystem, you do not need to worry about the ownership of the mount point. The critical factor is the ownership of the filesystem you are mounting.
EXAMPLE: I can mount my (ext2) flash drive at /media/user/8GBflash. If I chown the filesystem on the flash drive with the command: sudo chown -R $USER:$USER /media/user/8GBflash - from that point on I can mount the flash drive to any other mount point (such as /mnt) and I don't have to worry about the owner of the mount point. It is the ownership of the mounted filesystem which matters.
When you mount a filesystem, it takes the place of everything on that mount point, including (temporarily) overriding the previous ownership and permissions of the mount point.
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2017

fabien85
Level 6
Level 6
Posts: 1096
Joined: Tue Mar 11, 2014 4:30 pm

Re: USB Drive Read-Only File System

Postby fabien85 » Thu Mar 09, 2017 10:03 am

Thanks for the explanation austin.texas.

User avatar
White Phoenix
Level 4
Level 4
Posts: 256
Joined: Sun Dec 22, 2013 9:01 am
Location: Ypsilanti
Contact:

Re: USB Drive Read-Only File System

Postby White Phoenix » Thu Mar 09, 2017 2:51 pm

So everything is done. I started transferring files at 9pm last night and finished around 1 pm a little while ago. I started with transferring the files from Limbo to Shangri-La doing a simple cut and paste. It took off and the File Operation reported it would take over 7 hours, so I went to bed. I figured it would be done around 4am. I woke up around 2 and decided to check the progress.

Hardly anything had been done File Operations was then reporting 130 hours (less than 5.5 days) at a speed of a little over 100 kb/sec. I tried finding the process in the System Manager, but all the process names are pretty much meaningless. Everything was sleeping except one that was running, mate-system-monitor. In Windows the Task Manager has a window that shows only the windows that are open. As far as I know there is nothing that does that in Linux. So I gave up. I unmounted all drives except Limbo and Shangri-La, then unplugged them, disabled networking, turned off the modem-router, ejected the SD card and blank CD, took out the card and didn’t close the CD drive tray. Then the speed started taking off! Within a half hour the ETA was 48 hours.

By the time I went back for a nap there was only a few hours left and the speed was a little under 5 MB/sec. It must have finished around 8am. I woke up at 9, unmounted and unplugged Shangri-La and plugged in Xanadu. Then I did a cut and paste for Xanadu’s files. File Operations reported an ETA of two and a half hours at a speed of 21 MB/sec.

After Xanadu finished I set up the last drive. When everything was finished, I shut down the system, plugged everything back in and started up the laptop. Everything is back to where it should be, so now I can finish setting up after the last time I installed Linux.

It took 6 to 7 hours for each of the three drives to move their files to Limbo using a shell script with sudo commands with no problems.

There were already some files transferred to each of those drives before I started this last session. I was using the same sudo commands in reverse and it took several hours before I gave up just to do that.

Counting the time before I unplugged everything, it took 13 hours to move the rest of the files back. I still have no idea why I needed to disconnect everything just to do that.
Linux Mint 17.3 / MATE
Toshiba Satellite L655d-S5151 (Intel dual processor, 64bit, 4G RAM)

User avatar
White Phoenix
Level 4
Level 4
Posts: 256
Joined: Sun Dec 22, 2013 9:01 am
Location: Ypsilanti
Contact:

Re: USB Drive Read-Only File System

Postby White Phoenix » Thu Mar 09, 2017 11:01 pm

I am the owner of Stonehenge shouldn’t I be the one to decide whether or not this file system is read only? Or is the status of the file system separate from the ownership of the partition?

Code: Select all

total 150
drwxr-x---+ 12 root         root          4096 Mar  9 21:14 .
drwxr-xr-x   3 root         root          4096 Mar  8 19:23 ..
drwx------   1 whitephoenix whitephoenix  8192 Mar  8 10:09 Grimoire Windows
drwx------   3 whitephoenix whitephoenix 16384 Mar  9 18:30 IRIS
drwx------   1 whitephoenix whitephoenix  4096 Mar  9 14:36 Karnak
drwxrwx---  16 whitephoenix whitephoenix  4096 Mar  3 21:12 Limbo
dr-xr-xr-x   1 whitephoenix whitephoenix  2048 Nov 28  2015 Linux Mint 17.3 MATE 64-bit
drwxrwx---   6 whitephoenix whitephoenix  4096 Mar  2 15:38 Mouseio
drwx------   1 whitephoenix whitephoenix 86016 Mar  7 00:25 Penseive
drwx------   1 whitephoenix whitephoenix  4096 Mar  9 20:23 Shangri-La
drwxrwx---  10 whitephoenix whitephoenix  4096 Feb 24 06:51 Stonehenge
drwx------   1 whitephoenix whitephoenix 12288 Mar  9 11:32 Xanadu

Screenshot Properties.png

I can’t get the file access to stick on the owner or the group. Clicking on the Apply Permissions to Enclosed Files button does no good. Neither does the chmod command from the terminal.

Code: Select all

whitephoenix@BookOfShadows /media/whitephoenix/Stonehenge $ sudo chmod 770 Back*[sudo] password for whitephoenix:
chmod: changing permissions of ‘BackBoot’: Read-only file system
chmod: changing permissions of ‘BackHome’: Read-only file system
chmod: changing permissions of ‘BackRoot’: Read-only file system
chmod: changing permissions of ‘Backup Instructions.TXT’: Read-only file system
chmod: changing permissions of ‘Backup Plan.TXT’: Read-only file system

Screenshot Properties 2.png

Stonehenge is formatted ext4. Karnak which is ntfs has no problem. Limbo which is formatted ext4 has no problem. Only Stonehenge does this and it has only started doing it recently.
Linux Mint 17.3 / MATE
Toshiba Satellite L655d-S5151 (Intel dual processor, 64bit, 4G RAM)

User avatar
White Phoenix
Level 4
Level 4
Posts: 256
Joined: Sun Dec 22, 2013 9:01 am
Location: Ypsilanti
Contact:

Re: USB Drive Read-Only File System

Postby White Phoenix » Mon Mar 13, 2017 7:24 pm

Well, I finally figured out how to get everything working again. While the permissions wound up still the same, at least there are no drives that give the “read only” message. I also learned how to fix when the system cannot find my home by putting an entry in fstab properly formatted. Although, I didn’t have an entry in fstab before and there was no problem.

Also while you can change the ownership and permissions while the drives are unmounted and they are retained after rebooting, once you remove them from fstab, the settings are replaced. But the replacements are consistent and all the drives behave.

However, my CD/DVD drive still doesn’t show up anywhere so programs like Brasero can’t find the disk. I did have it show up once in the user folder under media, but then when everything finally showed up right, it disappeared again. The line in fstab that I am using is “/dev/cdrom /cd iso9660 ro,user,noauto,unhide 0 0”. Why this shows up in the default mount point without being in fstab in the live session and not in the real Linux, doesn’t make any sense.

Would it help to post the mtab file? Oops. I have another thread for that. (I fixed it.)
Linux Mint 17.3 / MATE
Toshiba Satellite L655d-S5151 (Intel dual processor, 64bit, 4G RAM)

tolga
Level 1
Level 1
Posts: 7
Joined: Fri Mar 10, 2017 5:02 pm

Re: [Solved] USB Drive Read-Only File System

Postby tolga » Fri Dec 15, 2017 10:26 am

I went through all with no luck.

I plugged my Sandisk USB stick to a Windows computer and downloaded Rufus 2.18. I ran the application with the option "Check device for bad blocks" with 1 Pass. Once the run is complete, I had my stick running.

I copied some splitted gz files and transferred them to my Linux laptop and ran without any issues.

I know that this is not a solution we wanted, but at least I got my USB stick working :wink:


Return to “Hardware Support”