Software Rendering - Apollo Lake iGPU

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
gpshumway
Level 1
Level 1
Posts: 8
Joined: Wed Apr 05, 2017 5:38 pm

Software Rendering - Apollo Lake iGPU

Post by gpshumway » Wed Apr 05, 2017 6:22 pm

Hello. New(ish) Linux user here with a bit of a graphics problem.

Due to some flaky behavior, I recently upgraded my J1900 Bay Trail embedded motherboard to a Celeron J3455 Apollo Lake version. The HDD remained unchanged and contained Mint 18 Cinnamon. When I booted up I got the "Running in software rendering mode" notification. Here's what I've tried:

- Using the driver manager, uninstalling and reinstalling the Intel microcode driver in Mint 18. No effect.

- Using the update manager to update to the most recent stable Linux kernel.

- Booting from a USB stick with Mint 18.1 - presto, no software rendering mode notification. When booting from my old Mint 18.0 USB stick I do get the software rendering mode notification.

- Upgrading the existing Mint 18 installation to 18.1. The notification is still present. :?:

- Using the driver manager to uninstall and reinstall the Intel microcode driver in Mint 18.1. Notification still present.

The motherboard is an Asrock J3455M http://asrock.com/mb/Intel/J3455M/
The iGPU is an Intel HD Graphics 500 http://www.intel.com/content/www/us/en/ ... j3455.html

My questions:
-Is a clean install of Mint 18.1 Cinnamon likely to solve the problem as booting from the live Mint 18.1 USB stick does not show the error?

-Is there any way to preserve my customizations and software (printer drivers, browser add-ons, UI tweaks, etc) while doing an otherwise clean install of Mint 18.1 Cinnamon?

I'll do a clean install if I have to, but I'd rather avoid all the work. Thanks for any help.

gpshumway
Level 1
Level 1
Posts: 8
Joined: Wed Apr 05, 2017 5:38 pm

Re: Software Rendering - Apollo Lake iGPU

Post by gpshumway » Thu Apr 06, 2017 6:02 pm

Just thought I'd update this thread.

I ended up doing a clean install from the current (as of yesterday) ISO image of Mint 18.1 Cinnamon, which solved the software rendering issue. Prior to the clean-sheet install I did a bunch of troubleshooting and am still perplexed as to why the clean install successfully uses hardware rendering, but the upgraded original configuration would not. Some findings:

- The working kernel installed by the ISO USB key is 4.4.0-53, and the computer is not using the Intel micro-code driver. I'm going to leave it that way until new info or some other reason compels me to change it. Prior to the clean-sheet install, I upgraded my 18.0 Cinnamon installation to 18.1 and then tried various kernels up to 4.10.8-041008, including 4.8.x, and 4.4.0-53 with and without the micro-code driver to no avail, all used software rendering. Any ideas as to why a clean install of Mint 18.1 Cinnamon with kernel 4.4.0-53 and without the micro-code driver works and the same configuration achieved through upgrades and the driver manager doesn't?

- The installation media doesn't like to install over an existing Mint installation on my system. It crashed at the "installing 'grub2'" step every time no matter the settings I chose for the installation options. I suspect i now know how to make it work by choosing custom options for the drive partitions, but there's clearly a bug in the installer at least as it relates to my hardware. The method which finally worked was using a Windows 8 (cringe) install media to change the partitions, then installing Mint. Each time the Mint installer failed it said I would have the opportunity to submit a bug report, but no additional dialog presented itself. How do I do so?

Any insights into the strange behavior of my system are appreciated.

Now I'm off to the fun task of re-creating all my customizations, add-ons and settings.

scjet45
Level 3
Level 3
Posts: 109
Joined: Sat May 07, 2016 12:50 am

Re: Software Rendering - Apollo Lake iGPU

Post by scjet45 » Mon Dec 25, 2017 7:28 am

Hi @gpshumway and others:

I hate to necro bump this, but, how has your luck been with Minty and the J3544?.
I sure hope Mint 18.3 (Mate) will boot/install OOTB with the J3544-ITX (Apollo Lake) series' systems, and although it should, I've also read horror-stories where Ubuntu +17.10 has actually caused regressions. !?
But I guess, as with every other, ehm, (Swamp)-Lake CPU/iGPU by Intel, these days, that this is sadly gonna be a continual problem :(

So, do I wish AMD would hurry up and come out with a working/cost-effective (mini-ITX) Ryzen-based mobile CPU/iGPU that will work beautifully ootb with opensource Linux/Xorg/... ?
heck YA ! :)
But until then, I'll try-n-install LM 18.3 on my ASRock J3544B-ITX, as soon as it arrives, but plz, let me know of you still have any issues, and/or how you may have circumvented them, if at all.

cheers, and Merry Xmas.
:)

ggerla
Level 1
Level 1
Posts: 3
Joined: Tue Jun 19, 2018 7:23 am

Re: Software Rendering - Apollo Lake iGPU

Post by ggerla » Tue Jun 19, 2018 7:27 am

Hi all
I'm experiencing a lot of issues with my ASRock J3544B-ITX...
I'm not able to have pc reliable more than 12 hourse. It freezes often and usually when no user are using the pc.
No error in kern.log or syslog files...
What is your experience with LM 18.3 and ASRock J3544B-ITX?


Thanks

Hoser Rob
Level 12
Level 12
Posts: 4213
Joined: Sat Dec 15, 2012 8:57 am

Re: Software Rendering - Apollo Lake iGPU

Post by Hoser Rob » Tue Jun 19, 2018 8:46 am

Unfortunately there's not enough usefuk system info there, copy/paste this to the terminal and copy/paste the text output here:

Code: Select all

inxi -Fxz
That intel-microcode you see in Driver Manager isn't really a driver, it's a CPU firmware update. Intel doesn't do closed binary video drivers anyway so you aren't going to see any there.

It's second nature for WIndows users to just go to a mfr's page and download drivers. This is usually NOT a good idea for Linux users. Don't do that unless you are damn sure it'll work because the wrong driver will usually completely break the video.

ggerla
Level 1
Level 1
Posts: 3
Joined: Tue Jun 19, 2018 7:23 am

Re: Software Rendering - Apollo Lake iGPU

Post by ggerla » Tue Jun 19, 2018 1:29 pm

Hi
thanks for your answer and sorry for short description.
First of all, let me explain better my situation. I bought a lot of hw: j3455b-itx, 16GB ddr, SSD 240GB, AWUS1900 wifi dongle, AWUS036AC wifi dongle, 4 Rankie usb ethernet adapter. My scope is to create a PC that is able also to work like a wifi router.
My first installation was Ubuntu 18.04 and I experienced immediately freeze problem. So after a lot of experiment I tryed to install Linux Mint 18.3, but the result was the same. Using Mint I done a lot of tests. Also removing all usb peripheral... Always the same result. Searching on internet I found a lot of suggestion about i915 graphic card and Apollo Lake problems... so I added a lot of parameter in the grub file: i915.enable_rc6=0 i915.semaphores=1 processor.max_cstate=1 intel_idle.max_cstate=0 (I try also intel_idle.max_cstate=1). Always with same result.
I verified RAM (with memtester) and HDD and I didn'f find HW problem.
So I come back to Ubuntu (actual installation). I read that during this month it will be delivered a new board based on j3455 motherboard and Linux Mint 19. So I wanted to understand how the problems I've been experiencing had been solved.

Following the output of "inxi -Fxz" command:


System: Host: ggserver Kernel: 4.15.0-23-generic x86_64
bits: 64 gcc: 7.3.0
Desktop: Gnome 3.28.1 (Gtk 3.22.30-1ubuntu1)
Distro: Ubuntu 18.04 LTS
Machine: Device: desktop Mobo: ASRock model: J3455B-ITX serial: N/A
UEFI: American Megatrends v: P1.30 date: 07/14/2017
CPU: Quad core Intel Celeron J3455 (-MCP-) arch: N/A cache: 1024 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 11980
clock speeds: max: 1500 MHz 1: 1497 MHz 2: 1497 MHz 3: 1497 MHz
4: 1497 MHz
Graphics: Card: Intel Device 5a85 bus-ID: 00:02.0
Display Server: x11 (X.Org 1.19.6 ) driver: intel
Resolution: 1680x1050@59.88hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 500 (Broxton 2x6)
version: 4.5 Mesa 18.0.0-rc5 Direct Render: Yes
Audio: Card Intel Celeron N3350/Pentium N4200/Atom E3900 Series Audio Cluster
driver: snd_hda_intel bus-ID: 00:0e.0
Sound: Advanced Linux Sound Architecture v: k4.15.0-23-generic
Network: Card-1: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 02:00.0
IF: wan state: up speed: 1000 Mbps duplex: full mac: <filter>
Card-2: Realtek RTL8812AU 802.11a/b/g/n/ac WLAN Adapter
usb-ID: 002-009
IF: null-if-id state: N/A mac: N/A
Drives: HDD Total Size: 2240.5GB (1.6% used)
ID-1: /dev/sda model: SanDisk_SSD_PLUS size: 240.1GB temp: 39C
ID-2: USB /dev/sdb model: M3_Portable size: 2000.4GB temp: 0C
Partition: ID-1: / size: 219G used: 13G (6%) fs: ext4 dev: /dev/sda2
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 55.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 261 Uptime: 3 min Memory: 1404.1/15447.1MB
Init: systemd runlevel: 5 Gcc sys: 7.3.0
Client: Shell (bash 4.4.191) inxi: 2.3.56

User avatar
ClixTrix
Level 5
Level 5
Posts: 747
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: Software Rendering - Apollo Lake iGPU

Post by ClixTrix » Tue Jun 19, 2018 1:51 pm

Go into BIOS setup and see if you can disable C-States for a test. That's a more direct-reliable way to disable C-States. I see you tried from kernel parm, but let's see if the BIOS setting helps. The fact that it freezes when idle is why....i.e. dropping to very low power load.

What is the make and model of power supply you are using?
Linux Mint 18.3 x64 Cinnamon Kernel 4.15.0-36-generic
Gigabyte GA-AB350M-D3H (F20) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 2x8GB / XFX HD5450-1GB
NVMe-SSD Samsung 960 EVO 250GB / SATA-HDD WD1600BEKT 160GB / SATA-SSD Toshiba OCZ VX500 512GB

ggerla
Level 1
Level 1
Posts: 3
Joined: Tue Jun 19, 2018 7:23 am

Re: Software Rendering - Apollo Lake iGPU

Post by ggerla » Tue Jun 19, 2018 2:33 pm

Unfortunately, I already disabled CSTATE in BIOS.

Intel SpedStep Tecnology -> Disabled
CPU C States Support -> Disabled

About power supply I have an old case: ITEK case atomic nz 65W.
Take into account that wifi dongles and external HDD are connected to an hub with power supply


Thanks

Post Reply

Return to “Hardware Support”