Laptop freezes when unplugging a lan cable while on battery.

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
naven
Level 1
Level 1
Posts: 24
Joined: Fri Sep 30, 2016 6:24 am

Laptop freezes when unplugging a lan cable while on battery.

Post by naven » Sat Jun 10, 2017 5:32 pm

Hi,

So, when I have my laptop AC plugged in, there is no issue, but when it is using battery power then every single time the whole laptop freezes, can't switch ttys, basically can't do anything. Could it be that the battery itself is causing issues? I bought the laptop like 2 years back and it was already used before that, probably it was never replaced.
Do you think that replacing the battery would help?

HP probook 6454b.

User avatar
simonsaysthis
Level 2
Level 2
Posts: 50
Joined: Sun Jun 11, 2017 1:39 pm
Location: Johannesburg

Re: Laptop freezes when unplugging a lan cable while on battery.

Post by simonsaysthis » Wed Jun 14, 2017 1:08 am

Hi there. Very hard to say whether it is a software or hardware issue. You havent even told us what version of Mint you are using.

You could run a different distro as live and see whether the same problem persists. If so it might be hardware related.

naven
Level 1
Level 1
Posts: 24
Joined: Fri Sep 30, 2016 6:24 am

Re: Laptop freezes when unplugging a lan cable while on battery.

Post by naven » Wed Jun 14, 2017 2:23 am

Hi!

Right now I am using 18.1. However this laptop is a test laptop, so it gets reinstalled like very other month, I've had 17.x, different ubuntu, Kali and there was the same issue using those.

User avatar
Lanser
Level 4
Level 4
Posts: 289
Joined: Mon Mar 08, 2010 5:12 am
Location: Salzburg Austria

Re: Laptop freezes when unplugging a lan cable while on battery.

Post by Lanser » Wed Jun 14, 2017 3:30 am

Just a thought. Do you have the same issue if you connect to a different switch port ? Or a different switch ?
I have seen a similar issue, where ports had become faulty and were leaking low voltage into the LAN cables.
Didn't affect the connectivity, but strange things happened when plugging in and out.
Lanser
Thinkpads:- LM19.1 Mate, LMDE3, Debian 10

User avatar
simonsaysthis
Level 2
Level 2
Posts: 50
Joined: Sun Jun 11, 2017 1:39 pm
Location: Johannesburg

Re: Laptop freezes when unplugging a lan cable while on battery.

Post by simonsaysthis » Wed Jun 14, 2017 7:27 am

naven wrote:Hi!

Right now I am using 18.1. However this laptop is a test laptop, so it gets reinstalled like very other month, I've had 17.x, different ubuntu, Kali and there was the same issue using those.
Sorry to hear. That really might be a hardware issue/

naven
Level 1
Level 1
Posts: 24
Joined: Fri Sep 30, 2016 6:24 am

Re: Laptop freezes when unplugging a lan cable while on battery.

Post by naven » Thu Jun 15, 2017 4:00 am

Lanser wrote:Just a thought. Do you have the same issue if you connect to a different switch port ? Or a different switch ?
I have seen a similar issue, where ports had become faulty and were leaking low voltage into the LAN cables.
Didn't affect the connectivity, but strange things happened when plugging in and out.
Lanser
Yea, I'm a network guy so ethernet card is my main interest in the laptop. I've been plugging it to multiple switches/routers and it always acts the same.

@simonsaythis- it would point me to believe this also. But what could be the issue? Is it battery or is it something else?

User avatar
Lanser
Level 4
Level 4
Posts: 289
Joined: Mon Mar 08, 2010 5:12 am
Location: Salzburg Austria

Re: Laptop freezes when unplugging a lan cable while on battery.

Post by Lanser » Thu Jun 15, 2017 8:13 pm

If you see the same problem across multiple OSs, then it could be related to the power management.
Some BIOS settings for maximum battery life could be affecting the integrated PCI ethernet device.
Have you tried changing the BIOS settings to performance, when on battery ?
Also might be worth checking the change notes for your BIOS versions, to see if there was a reported issue and fix.
Lanser
Thinkpads:- LM19.1 Mate, LMDE3, Debian 10

Mute Ant
Level 14
Level 14
Posts: 5135
Joined: Tue Sep 03, 2013 7:45 pm
Location: Norfolk UK

Re: Laptop freezes when unplugging a lan cable while on battery.

Post by Mute Ant » Thu Jun 15, 2017 8:38 pm

Certainly it sounds like hardware when different OS show the same symptoms. Try running on battery with the AC adaptor plugged in but switched off...does that behave? I am thinking earth-loop and electro-magnetic screening here...grounding EM interference or leakage through the AC adaptor even though it's switched off.
While you're waiting, read the free novel we sent you. It's a Spanish story about a guy named "manual".

naven
Level 1
Level 1
Posts: 24
Joined: Fri Sep 30, 2016 6:24 am

Re: Laptop freezes when unplugging a lan cable while on battery.

Post by naven » Fri Jun 16, 2017 4:03 am

Unfortunately at the moment I do not have access to the BIOS. I just spoke with HP support and hope to resolve it soon.
Lanser, I'll get back to those when/if I have access to BIOS.


Mute Ant, I guess you mean disabling the battery also in BIOS?

naven
Level 1
Level 1
Posts: 24
Joined: Fri Sep 30, 2016 6:24 am

Re: Laptop freezes when unplugging a lan cable while on battery.

Post by naven » Mon Jul 03, 2017 10:03 am

Well. That didn't work. Still no access to BIOS.

User avatar
Lanser
Level 4
Level 4
Posts: 289
Joined: Mon Mar 08, 2010 5:12 am
Location: Salzburg Austria

Re: Laptop freezes when unplugging a lan cable while on battery.

Post by Lanser » Sun Jul 09, 2017 11:46 pm

naven. What happens if you disconnect the ethernet connection in network-manager, before you unplug the cable?
Lanser
Thinkpads:- LM19.1 Mate, LMDE3, Debian 10

naven
Level 1
Level 1
Posts: 24
Joined: Fri Sep 30, 2016 6:24 am

Re: Laptop freezes when unplugging a lan cable while on battery.

Post by naven » Mon Jul 10, 2017 8:34 am

I actually tried shutting the interface down using the command (ifconfig eth0 down) and it didn't freeze. So at least I have a workaround.

Still no access to BIOS though. I guess I'll never have it.

User avatar
Lanser
Level 4
Level 4
Posts: 289
Joined: Mon Mar 08, 2010 5:12 am
Location: Salzburg Austria

Re: Laptop freezes when unplugging a lan cable while on battery.

Post by Lanser » Mon Jul 10, 2017 9:59 pm

Sounds like a background app / process demands network connnectivity. You running any file sharing apps or mapped drives?
I would be looking at what is running at "startup" and what is running in the background. Maybe also take a look at the traffic with wireshark.
Lanser
Thinkpads:- LM19.1 Mate, LMDE3, Debian 10

naven
Level 1
Level 1
Posts: 24
Joined: Fri Sep 30, 2016 6:24 am

Re: Laptop freezes when unplugging a lan cable while on battery.

Post by naven » Sun Oct 22, 2017 7:37 pm

Hi,
Sorry I was away for so long. In the end I was able to somewhat resolve my issue.

I bought a new battery- that didn't help though.
However I installed Ubuntu and now it works fine.

Lanser, answering your question- yes I do, but not at all times. Those are disabled by default, usually I boot up without access to network.

Thank you for all the help.

Post Reply

Return to “Hardware Support”