Problems installing AMDGPU-PRO on Mint 18.1

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
rchille
Level 1
Level 1
Posts: 10
Joined: Thu Mar 19, 2015 4:19 pm
Location: North Carolina

Problems installing AMDGPU-PRO on Mint 18.1

Postby rchille » Sat Jun 24, 2017 1:57 pm

Good day everyone!
I recently upgraded my motherboard/cpu/memory and am having a heck of a time getting my graphics drivers loaded.
Before the upgrade, I had Mint 18.1 and the same video card (a Radeon RX480 from MSI) running with the AMDGPU-PRO drivers without any problems.

When I initially reinstalled Mint 18.1 (before I attempted to load the drivers), Cinnamon came up with the warning that it was running in software rendering mode and complaining about my drivers. I wasn't too worried since I was planning to load AMD's proprietary ones.

I mainly followed the directions here: viewtopic.php?t=229229 but tried a few other things when
    First I updated to the 4.10 Kernel and restarted. (I kept seeing folks have trouble with the 4.4 kernel)
    I downloaded the drivers from AMD for the Ubuntu 16.04.2 release: https://www2.ati.com/drivers/linux/ubun ... 170.tar.xz
    I unpacked them and modified the amdgpu-pro-install script to replace 'Ubuntu' with 'linuxmint'
    Ran the script, if failed because of unsupported OS (WHAT?)
    I checked my /etc/os-releases file and it IDs itself as a Ubuntu.
    Change the install script back and run in, it installs this time
    I add myself to the 'video' group and restart

Note that every other time I have installed these drivers (twice successfully, and once when I first tried to install this machine with Mint 17.3) I had to change the "amdgpu-pro-install" file to look for the "linuxmint" label, not sure why my current release is identifying as Ubuntu. I double checked the USB installer to be sure and it says it is "Linux Mint 18 Cinnamon 64bit" and I like to think I would have noticed the Ubuntu installer running instead of the Mint one. :)

Now when I start up, Cinnamon instantly crashes and ask if I want to restart. If I say 'yes', it instantly crashes again and continues to until I select 'fallback mode'.
When I check, the amdgpu-pro drivers do not seem to be loaded.

My /etc/os-releases file:

Code: Select all

NAME="Ubuntu"
VERSION="16.04 LTS (Xenial Xerus)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 16.04 LTS"
VERSION_ID="16.04"
HOME_URL="http://www.ubuntu.com/"
SUPPORT_URL="http://help.ubuntu.com/"
BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"
UBUNTU_CODENAME=xenial


Results of inxi -Fxz

Code: Select all

System:    Host: kitt Kernel: 4.10.0-24-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.0.7 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18 Sarah
Machine:   Mobo: ASRock model: H270M-ITX/ac Bios: American Megatrends v: P1.40 date: 02/17/2017
CPU:       Quad core Intel Core i5-7600 (-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 28032
           clock speeds: max: 4100 MHz 1: 899 MHz 2: 899 MHz 3: 899 MHz 4: 899 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Device 67df bus-ID: 01:00.0
           Display Server: X.Org 1.18.3 drivers: ati,vesa (unloaded: fbdev,radeon,amdgpu)
           Resolution: 1920x1080@0.00hz
           GLX Renderer: N/A GLX Version: N/A Direct Rendering: N/A
Audio:     Card-1 Intel Device a2f0 driver: snd_hda_intel bus-ID: 00:1f.3 Sound: ALSA v: k4.10.0-24-generic
           Card-2 Advanced Micro Devices [AMD/ATI] Device aaf0 driver: snd_hda_intel bus-ID: 01:00.1
Network:   Card-1: Intel Ethernet Connection (2) I219-V driver: e1000e v: 3.2.6-k bus-ID: 00:1f.6
           IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Card-2: Intel I211 Gigabit Network Connection driver: igb v: 5.4.0-k port: d000 bus-ID: 03:00.0
           IF: enp3s0 state: down mac: <filter>
           Card-3: Intel Wireless 3160 bus-ID: 04:00.0
           IF: N/A state: N/A mac: N/A
Drives:    HDD Total Size: 736.2GB (3.3% used) ID-1: /dev/sda model: INTEL_SSDSA2M080 size: 80.0GB
           ID-2: /dev/sdb model: WDC_WD3200BEKT size: 320.1GB ID-3: /dev/sdc model: WDC_WD3200BEKT size: 320.1GB
           ID-4: USB /dev/sdd model: STORAGE_DEVICE size: 16.0GB
Partition: ID-1: / size: 58G used: 7.2G (14%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 17.14GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 40.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 191 Uptime: 27 min Memory: 1187.7/16010.6MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35


My groups

Code: Select all

adm cdrom sudo dip video plugdev lpadmin sambashare


I've tried installing from a 17.3 image, updating to 18.1 then adding the drivers and I get the same effect: drivers not loaded and Cinnamon crashing.

The only other thing I can think of is something in the BIOS. It has a setting to pick on-board video VS using the PCIE card and currently it is set to use the card. No other settings jumped out at me that seemed to effect video cards, but may be there a more general setting that is causing the issue?

Thanks for any help, and please let me know if any other information is useful!

anud33p
Level 1
Level 1
Posts: 3
Joined: Mon Jun 29, 2015 3:29 am

Re: Problems installing AMDGPU-PRO on Mint 18.1

Postby anud33p » Wed Nov 08, 2017 3:00 pm

Hi, having the same issue here.. were you able to solve it?


Return to “Hardware Support”