Auto-Connect Bluetooth Device

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
mystik
Level 1
Level 1
Posts: 3
Joined: Fri Jul 21, 2017 8:18 pm

Auto-Connect Bluetooth Device

Postby mystik » Fri Jul 21, 2017 8:26 pm

I hate to ask this because I am sure it is very basic. This is my first day using a Linux OS. So, be easy. :D

I have a Rii i8+ Bluetooth keyboard/mouse combo. When I connected via TeamViewer, I was able to pair it, and I seem to remember it working at that moment, but when I rebooted, it won't work. I imagine there's just a setting somewhere to connect to it automatically on boot. Someone care to give me a pointer to it? Thanks much in advance.

User avatar
jungle_boy
Level 7
Level 7
Posts: 1716
Joined: Thu Aug 19, 2010 2:51 pm
Location: Amazon Rain Forest Land

Re: Auto-Connect Bluetooth Device

Postby jungle_boy » Sun Jul 23, 2017 8:29 pm

Try in:
Menu>System Settings>Preferences> Startup Applications

mystik
Level 1
Level 1
Posts: 3
Joined: Fri Jul 21, 2017 8:18 pm

Re: Auto-Connect Bluetooth Device

Postby mystik » Sun Jul 23, 2017 8:31 pm

Thanks much for the reply. Which application do I need to add there? Or is there some setting to check? (I'm not in front of it right now, but want to check so I'm ready to go when I get there if not). Appreciate the assist.

amicalmant
Level 1
Level 1
Posts: 1
Joined: Thu Sep 28, 2017 10:35 am

Re: Auto-Connect Bluetooth Device

Postby amicalmant » Thu Sep 28, 2017 10:49 am

Hi Mystic! Seems like nobody cares to reply so let me try it at my best.

I use a Bluetooth mouse and each time I start a Linux Mint session it is not automatically connected either. I found an easy workaround though and, although things could certainly be more straightforward, it works well for me.

  1. Boot your machine and log in your session.
  2. Click on the Bluetooth icon in the taskbar to launch the Bluetooth manager window.
  3. De-activate the Bluetooth service (push toggle from right to left).
  4. Activate the Bluetooth service (push toggle from left to right).
  5. Your device should appears in the list.
  6. Wait for ±5-10 seconds and check if it has started.
  7. If not, click on it and push the connection toggle from left to right.
  8. If the toggle does not stick you must probably re-pair the device (especially if you paired it with another device or OS as well).
  9. To do so, click on "Delete the device", and restart the pairing procedure on your device.

I hope this works for you too,

mystik
Level 1
Level 1
Posts: 3
Joined: Fri Jul 21, 2017 8:18 pm

Re: Auto-Connect Bluetooth Device

Postby mystik » Thu Sep 28, 2017 5:46 pm

Thanks much for the reply. I really appreciate it. I ended up scraping Mint completely because of this. I was going to put it on my HTPC as a starting point, and then see about moving the workstation to it as I became more familiar. But, I ended up just putting LibreELEC on there, which is working great. With that being said, I have since bought a USB version of my wireless keyboard/mouse. So, I might give it another try.

Franpoule
Level 1
Level 1
Posts: 10
Joined: Tue Apr 18, 2017 7:01 am

Re: Auto-Connect Bluetooth Device

Postby Franpoule » Thu Nov 30, 2017 10:45 am

Hello,

I start again this conversation because I have a similar problem. I have 2 bluetooth devices (Bose Soundlink Mini 2 speaker and Plantronics Backbeat Pro headphone).

These two devices connect automatically but it never automatically switch to them in the setting sounds. I always have to go to the settings and select the bluetooth device in order to control the sound from the computer.

Is there any way to resolve this ?

Thank you guys !

Franpoule
Level 1
Level 1
Posts: 10
Joined: Tue Apr 18, 2017 7:01 am

Re: Auto-Connect Bluetooth Device

Postby Franpoule » Sun Dec 03, 2017 6:49 am

Well for the others who want to have this problem, I solved it by following this tutorial https://wiki.archlinux.org/index.php/Pu ... SB_headset


Return to “Hardware Support”