Bluetooth not working??

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
JeremyB
Level 17
Level 17
Posts: 7912
Joined: Fri Feb 21, 2014 8:17 am

Re: Bluetooth not working??

Post by JeremyB » Tue Aug 22, 2017 5:36 pm

Disconnect from the headphones, do

Code: Select all

pactl load-module module-bluetooth-discover
Then connect again and see if it seen in Sound Settings and be selected

Ronnybaby
Level 1
Level 1
Posts: 21
Joined: Tue Oct 13, 2015 4:38 pm

Re: Bluetooth not working??

Post by Ronnybaby » Wed Aug 23, 2017 6:28 pm

I have tried this several times along with several other things.
The headset is acknowledged and it says so... but it always
says Failed To Connect.

$ pactl load-module module-bluetooth-discover
Failure: Module initialization failed

It also says Resource Temporarily Unavailable when attempting
to connect the normal way through the icon in the panel.

I tried your code again after removing the headset and got this:
$ Failure: Module initialization failed
Failure:: command not found

JeremyB
Level 17
Level 17
Posts: 7912
Joined: Fri Feb 21, 2014 8:17 am

Re: Bluetooth not working??

Post by JeremyB » Thu Aug 24, 2017 5:16 pm

Try using bluetoothctl to connect

Code: Select all

bluetoothctl
This should show your controller and paired devices

Code: Select all

connect
Followed by the headsets MAC address
For my headset, I use connect 00:1E:7C:28:8F:7F[/code]
See if there are errors, and check [code]pactl list short | grep blue[/code]
As the module-bluetooth-discover may already be loaded

Ronnybaby
Level 1
Level 1
Posts: 21
Joined: Tue Oct 13, 2015 4:38 pm

Re: Bluetooth not working??

Post by Ronnybaby » Thu Aug 24, 2017 8:43 pm

Didn't you already give me this in an earlier post?

JeremyB
Level 17
Level 17
Posts: 7912
Joined: Fri Feb 21, 2014 8:17 am

Re: Bluetooth not working??

Post by JeremyB » Tue Aug 29, 2017 5:16 pm

I don't think I gave you those exact commands before

K32237h
Level 1
Level 1
Posts: 4
Joined: Wed Aug 30, 2017 12:09 pm

Re: Bluetooth not working??

Post by K32237h » Wed Aug 30, 2017 4:24 pm

:( No audio with bluetooth headphones or speaker for me. I tried what was suggested below but it didn't work. Also was poking around in the config couldn't get it to work.


Update:
I got the audio to work by changing the output in per application section but not on a global scale.

charlyaurelia
Level 1
Level 1
Posts: 17
Joined: Sat Jun 03, 2017 1:33 am

Re: Bluetooth not working??

Post by charlyaurelia » Thu Jan 18, 2018 1:56 pm

hey my Bluetooth is not working on either of my Lenovo laptops, both Mint 18.3. Tried uninstalling Blueberry and installing Blueman on oen and this is my output to the aforementioned query : any help would be appreciated. thanks

02:00.0 Network controller [0280]: Intel Corporation Wireless 8260 [8086:24f3] (rev 3a)
Subsystem: Intel Corporation Wireless 8260 [8086:1130]
Kernel driver in use: iwlwifi
Kernel modules: iwlwifi
03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
Subsystem: Lenovo RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [17aa:3835]
Kernel driver in use: r8169
Kernel modules: r8169
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 8087:0a2b Intel Corp.
Bus 001 Device 028: ID 06cb:7b0e Synaptics, Inc.
Bus 001 Device 004: ID 5986:0670 Acer, Inc
Bus 001 Device 029: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
[ 0.297486] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored
[ 16.633277] Bluetooth: Core ver 2.21
[ 16.633287] Bluetooth: HCI device and connection manager initialized
[ 16.633289] Bluetooth: HCI socket layer initialized
[ 16.633290] Bluetooth: L2CAP socket layer initialized
[ 16.633293] Bluetooth: SCO socket layer initialized
[ 16.963161] Bluetooth: HCI UART driver ver 2.3
[ 16.963164] Bluetooth: HCI UART protocol H4 registered
[ 16.963165] Bluetooth: HCI UART protocol BCSP registered
[ 16.963165] Bluetooth: HCI UART protocol LL registered
[ 16.963166] Bluetooth: HCI UART protocol ATH3K registered
[ 16.963167] Bluetooth: HCI UART protocol Three-wire (H5) registered
[ 16.963186] Bluetooth: HCI UART protocol Intel registered
[ 16.963194] Bluetooth: HCI UART protocol BCM registered
[ 16.963195] Bluetooth: HCI UART protocol QCA registered
[ 17.378214] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-8000C-19.ucode failed with error -2
[ 17.378227] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-8000C-18.ucode failed with error -2
[ 17.378234] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-8000C-17.ucode failed with error -2
[ 18.620238] iwlwifi 0000:02:00.0: loaded firmware version 16.242414.0 op_mode iwlmvm
[ 18.703921] Bluetooth: hci0: Bootloader revision 0.0 build 2 week 52 2014
[ 18.708928] Bluetooth: hci0: Device revision is 5
[ 18.708930] Bluetooth: hci0: Secure boot is enabled
[ 18.708931] Bluetooth: hci0: OTP lock is enabled
[ 18.708931] Bluetooth: hci0: API lock is enabled
[ 18.708932] Bluetooth: hci0: Debug lock is disabled
[ 18.708933] Bluetooth: hci0: Minimum firmware build 1 week 10 2014
[ 19.324350] Bluetooth: hci0: Found device firmware: intel/ibt-11-5.sfi
[ 20.655083] Bluetooth: hci0: Waiting for firmware download to complete
[ 20.655970] Bluetooth: hci0: Firmware loaded in 1907168 usecs
[ 20.656001] Bluetooth: hci0: Waiting for device to boot
[ 20.666974] Bluetooth: hci0: Device booted in 10725 usecs
[ 20.780031] Bluetooth: hci0: Found Intel DDC parameters: intel/ibt-11-5.ddc
[ 20.783972] Bluetooth: hci0: Applying Intel DDC parameters completed
[ 29.889631] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 29.889632] Bluetooth: BNEP filters: protocol multicast
[ 29.889636] Bluetooth: BNEP socket layer initialized
[ 85.792421] Bluetooth: RFCOMM TTY layer initialized
[ 85.792427] Bluetooth: RFCOMM socket layer initialized
[ 85.792437] Bluetooth: RFCOMM ver 1.11
[585293.519212] Bluetooth: hci0 command 0x200c tx timeout
[585300.230262] Bluetooth: hci0 ACL packet for unknown connection handle 256
[585300.967052] Bluetooth: hci0 command 0x0405 tx timeout
[585340.974317] Bluetooth: hci0 command 0x0408 tx timeout
[585400.109236] Bluetooth: hci0 command 0x0408 tx timeout
[586035.649686] Bluetooth: hci0 command 0x200c tx timeout
[586222.622254] Bluetooth: hci0 command 0x0408 tx timeout
[586293.764941] Bluetooth: hci0 command 0x0408 tx timeout
[586434.330378] Bluetooth: hci0 command 0x0408 tx timeout

Post Reply

Return to “Hardware Support”