my fan is always on

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
hhead
Level 3
Level 3
Posts: 133
Joined: Thu Jan 12, 2012 7:01 am

my fan is always on

Post by hhead » Thu Sep 28, 2017 11:52 am

my fan is always on. The only exception to this is when I boot it goes off at the login screen then comes on as I get to the desktop. Its speed seems to vary but that's it. I set the bios to fan off. I cannot find a way of determining its speed but don't think my laptop is that hot or needs to be on that much.

inxi -Fxz

Code: Select all


System:    Host: nrh1-HP-Notebook Kernel: 4.8.0-53-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: MATE 1.18.0 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.2 Sonya
Machine:   System: HP product: HP Notebook v: Type1ProductConfigId
           Mobo: HP model: 80C1 v: 96.44 Bios: Insyde v: F.1E date: 12/25/2015
CPU:       Dual core Intel Core i3-5005U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 7981
           clock speeds: max: 1900 MHz 1: 1900 MHz 2: 1900 MHz 3: 1886 MHz
           4: 1894 MHz
Graphics:  Card: Intel Broadwell-U Integrated Graphics bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2)
           GLX Version: 3.0 Mesa 12.0.6 Direct Rendering: Yes
Audio:     Card-1 Intel Wildcat Point-LP High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Broadwell-U Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.8.0-53-generic
Network:   Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: 4000 bus-ID: 07:00.0
           IF: enp7s0 state: down mac: <filter>
           Card-2: Realtek RTL8723BE PCIe Wireless Network Adapter
           driver: rtl8723be port: 3000 bus-ID: 0d:00.0
           IF: wlp13s0 state: up mac: <filter>
Drives:    HDD Total Size: 1000.2GB (5.3% used)
           ID-1: /dev/sda model: HGST_HTS541010A9 size: 1000.2GB
Partition: ID-1: / size: 230G used: 6.7G (4%) fs: ext4 dev: /dev/sda2
           ID-2: /home size: 686G used: 41G (7%) fs: ext4 dev: /dev/sda3
           ID-3: swap-1 size: 2.15GB used: 0.00GB (0%) fs: swap dev: /dev/sda4
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 36.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 202 Uptime: 1:16 Memory: 865.5/7898.3MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 

Any ideas its not loud but does presumably degrade battery life?

User avatar
mrmajik45
Level 5
Level 5
Posts: 597
Joined: Tue Aug 29, 2017 9:51 pm
Location: USA, indiana
Contact:

Re: my fan is always on

Post by mrmajik45 » Sat Sep 30, 2017 7:10 pm

ReactOS Donator ~ $5.00 | Linux Mint Donator ~ $1.00 in BTC

User avatar
richyrich
Level 19
Level 19
Posts: 9075
Joined: Mon May 04, 2009 8:31 pm

Re: my fan is always on

Post by richyrich » Sat Sep 30, 2017 8:43 pm

Sure . . I'm positive that you can disable those fans in your BIOS.
Be also sure to let the accumulated heat fry your system !
Just for the sake of the sound of your fans . . :shock:

User avatar
trytip
Level 11
Level 11
Posts: 3705
Joined: Tue Jul 05, 2016 1:20 pm

Re: my fan is always on

Post by trytip » Sat Sep 30, 2017 9:35 pm

install lm_sensors you must run sudo sensors detect and choose yes to all then once installed you can run sensors in terminal to see if your fan is detected and at what speeds

BUT i would not advise to turn off fan that's what keeps your CPU alive. cpu fan runs faster if you utilize more processing power like converting a video or recording your desktop

you may want to test out different fan setting if you have them in bios but i would NEVER turn off a cpu/gpu fan even 5 minutes with fan off would overheat the chip to 100C or above
Image

zaqcroyd
Level 2
Level 2
Posts: 93
Joined: Sun Aug 20, 2017 5:11 pm

Re: my fan is always on

Post by zaqcroyd » Sat Sep 30, 2017 11:57 pm

You need to make sure the inward bound air ports on your laptop are not blocked, even partially. I had a laptop that I would literally use in my lap and it would get very hot & loud within 15 min because the air was (trying to be) pulled in through the bottom of the laptop right where it sat on my legs. I put a piece of cardboard on my legs and sat the laptop on top of that and everything was fine.

Short suggestion: check your air ports are clean and not blocked by your machine's placement.

hhead
Level 3
Level 3
Posts: 133
Joined: Thu Jan 12, 2012 7:01 am

Re: my fan is always on

Post by hhead » Wed Oct 04, 2017 5:04 am

will try mrmajik45's link as I understand it disabling fan always on in the bios does not permanently switch the fan off but puts it under the control of the OS where it should cycle on an off as required. That's certainly true of my machine where the fan is certainly working. The exit point is clean and clear.

hhead
Level 3
Level 3
Posts: 133
Joined: Thu Jan 12, 2012 7:01 am

Re: my fan is always on

Post by hhead » Thu Dec 28, 2017 5:53 am

machine just not sophisticated enough to monitor or control fan. Since an update of something its a bit more variable. Not solved though.

Post Reply

Return to “Hardware Support”