Page 1 of 1

Sound card suddenly stopped working in LM 18.2 - SOLVED

Posted: Fri Oct 27, 2017 3:58 pm
by grungy_me
As of today my internal PCI sound card stopped working and I no longer have sound output on my computer. It worked last night and for the last six years flawlessly in LinuxMint with no problems at all. I'm using LinuxMint 18.2 Cinnamon 64-bit.

Here's my inxi -Fxz from today:

Code: Select all

System:    Host: TWO Kernel: 4.8.0-53-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.4.3 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.2 Sonya
Machine:   Mobo: Gigabyte model: GA-890FXA-UD5
           Bios: Award v: F6 date: 11/24/2010
CPU:       Hexa core AMD Phenom II X6 1055T (-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4a svm) bmips: 33751
           clock speeds: max: 2800 MHz 1: 1500 MHz 2: 1500 MHz 3: 800 MHz
           4: 800 MHz 5: 1500 MHz 6: 1500 MHz
Graphics:  Card: NVIDIA GM107 [GeForce GTX 750] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1200@59.95hz
           GLX Renderer: GeForce GTX 750/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 384.90 Direct Rendering: Yes
Audio:     Card NVIDIA Device 0fbc driver: snd_hda_intel bus-ID: 01:00.1
           Sound: Advanced Linux Sound Architecture v: k4.8.0-53-generic
Network:   Card: Intel 82574L Gigabit Network Connection
           driver: e1000e v: 3.2.6-k port: cf00 bus-ID: 04:00.0
           IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 2000.4GB (5.2% used)
           ID-1: /dev/sda model: WDC_WD2002FAEX size: 2000.4GB
Partition: ID-1: / size: 806G used: 83G (11%) fs: ext4 dev: /dev/sda8
           ID-2: swap-1 size: 16.50GB used: 0.00GB (0%) fs: swap dev: /dev/sda7
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 21.0C mobo: N/A gpu: 0.0:30C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 244 Uptime: 1 min Memory: 585.1/3948.9MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35
You'll notice it only shows the HDMI sound output from my Nvidia GPU. Which is the same thing that only shows in the sound settings from the panel.
Below is snippet of the relevant audio portion of inxi -Fxz output from a few days ago at this link: viewtopic.php?f=49&t=256033

Code: Select all

Audio:     Card-1 NVIDIA Device 0fbc driver: snd_hda_intel bus-ID: 01:00.1
           Card-2 C-Media CMI8738/CMI8768 PCI Audio
           driver: snd_cmipci port: 9e00 bus-ID: 06:06.0
           Sound: Advanced Linux Sound Architecture v: k4.8.0-53-generic
The C-Media card no longer shows. I've tried re-booting to make sure it wasn't a freak occurrence, and it still does not show.

Any ideas? How do I diagnose and repair this?

Thank you for your time and help in advance.

Re: Sound card suddenly stopped working in LM 18.2

Posted: Fri Oct 27, 2017 4:53 pm
by grungy_me
I've since reflashed the motherboard BIOS, as once in a great while it gets corrupted and falls back to it's stock version. And then re-booted several times. A few times I booted into Windows which also shows no sound card. This doesn't bode well. Although one time when booting into LinuxMint inxi showed the C-media card, but the "sound" button on the panel wasn't loading. And you could see the system attempting to load it as the panel would flash every ten seconds or so and you'd see the items on the right move a little as if the sound program was starting to load and then crash, and the system would pause as it was trying to do this. Rather weird. Ran memtest86 for a few minutes just in case and found no errors. I haven't been able to since get it to do that.

Has my sound card died?

Re: Sound card suddenly stopped working in LM 18.2 - SOLVED

Posted: Sat Oct 28, 2017 1:04 pm
by grungy_me
I opened my computer and pulled the sound card to see if there was bulging and/or leaking capacitors or anything else obviously wrong with it. It all looked good. Put it back in and re-booted and had sound again. The only thing I can figure is perhaps the card needed to be re-seated in its PCI slot for some of the contacts to be good again. Hopefully it continues to work.