Trouble mounting external HD [SOLVED]

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
locowrench
Level 1
Level 1
Posts: 4
Joined: Mon Oct 30, 2017 5:10 pm

Trouble mounting external HD [SOLVED]

Postby locowrench » Mon Oct 30, 2017 5:31 pm

Hi all,

Please forgive my inexperience. I am relatively new to Linux Mint, and am not very computer literate in general.

I have two personal computers, one desktop and one laptop, both running Linux Mint 18.2 Cinnamon. I have been using a Samsung 1 TB external USB HD with my desktop machine without any problem for some time. Recently, I tried to copy some files from my laptop onto the external drive. Since then, I can't get the external drive to mount on either computer. When I power up the drive and connect to a USB port on either machine I get this error message:

External drive screenshot.png


The drive shows up in the disc utility, but I can not seen to get it to mount.

I'd like to recover some of the other data on this drive. Any ideas as to what I might try?

Thank you for any advice you can offer.
Last edited by locowrench on Thu Nov 02, 2017 5:46 pm, edited 1 time in total.

Mute Ant
Level 12
Level 12
Posts: 4089
Joined: Tue Sep 03, 2013 7:45 pm

Re: Trouble mounting external HD

Postby Mute Ant » Mon Oct 30, 2017 6:04 pm

Linux-the-kernel supports reading NTFS. You might try manually mounting your partition read-only on the /mnt folder...
sudo mount /dev/sdb1 -t ntfs -o ro /mnt
...to look at the contents and make copies.

If you intend to keep the drive formatted as NTFS, you need a Windows-Competent machine to repair the file system, not Linux.
Armageddon only happens once, you know. They don’t let you go around again until you get it right.

locowrench
Level 1
Level 1
Posts: 4
Joined: Mon Oct 30, 2017 5:10 pm

Re: Trouble mounting external HD

Postby locowrench » Mon Oct 30, 2017 7:30 pm

Mute Ant wrote:Linux-the-kernel supports reading NTFS. You might try manually mounting your partition read-only on the /mnt folder...
sudo mount /dev/sdb1 -t ntfs -o ro /mnt
...to look at the contents and make copies.

If you intend to keep the drive formatted as NTFS, you need a Windows-Competent machine to repair the file system, not Linux.



Thank you for taking the time to reply to my questions. I did as you suggested and received essentially the same error message:

$MFTMirr does not match $MFT (record 0).
Failed to mount '/dev/sdb1': Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
for more details.


I am also curious as to what caused the drive to malfunction in the first place. As a test, I tried loading some flies from my laptop onto a flash drive. Afterwards the flash drive would no longer mount even after reformatting.

Mute Ant
Level 12
Level 12
Posts: 4089
Joined: Tue Sep 03, 2013 7:45 pm

Re: Trouble mounting external HD

Postby Mute Ant » Mon Oct 30, 2017 8:54 pm

A simple unmounted readability test perhaps. Will it fetch the first GiB off the drive...
sudo head -c 1G /dev/sdb1 > /dev/zero && echo "Okay"
Armageddon only happens once, you know. They don’t let you go around again until you get it right.

locowrench
Level 1
Level 1
Posts: 4
Joined: Mon Oct 30, 2017 5:10 pm

Re: Trouble mounting external HD

Postby locowrench » Tue Oct 31, 2017 5:49 pm

Mute Ant wrote:A simple unmounted readability test perhaps. Will it fetch the first GiB off the drive...
sudo head -c 1G /dev/sdb1 > /dev/zero && echo "Okay"


Thank you once more for your insight.

I did as you suggested, and interestingly, I received "Okay" as the ouput. So the first GB of data seems to be readable. I ran the same command again with 5 G and "Okay" again. Promising

budgiebandolier
Level 1
Level 1
Posts: 9
Joined: Sun Jun 26, 2016 11:56 am
Location: Gogledd Cymru

Re: Trouble mounting external HD

Postby budgiebandolier » Wed Nov 01, 2017 1:44 pm

Try here https://wmarkito.wordpress.com/2010/12/ ... -record-0/ worked very quickly and repaired my problem with the same message.

locowrench
Level 1
Level 1
Posts: 4
Joined: Mon Oct 30, 2017 5:10 pm

Re: Trouble mounting external HD

Postby locowrench » Wed Nov 01, 2017 6:39 pm

budgiebandolier wrote:Try here https://wmarkito.wordpress.com/2010/12/ ... -record-0/ worked very quickly and repaired my problem with the same message.


Thank you very much for posting this. I have been able to recover my data and my external drive is working correctly again.

I wonder if I should reformat the drive to something other than NTFS.

budgiebandolier
Level 1
Level 1
Posts: 9
Joined: Sun Jun 26, 2016 11:56 am
Location: Gogledd Cymru

Re: Trouble mounting external HD

Postby budgiebandolier » Thu Nov 02, 2017 6:16 am

Always happy to pass on useful links that worked. I have left the disc as NTFS and no further problems but I was transferring a large volume of data when it went wrong and have since done no more than 1GB at a tme.

User avatar
minitux
Level 5
Level 5
Posts: 580
Joined: Tue Sep 12, 2017 10:05 am

Re: Trouble mounting external HD

Postby minitux » Thu Nov 02, 2017 6:38 am

the message was clear, make a check disk from windows
locowrench wrote:SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows

If you do not have windows you can try with

Code: Select all

sudo ntfsfix /dev/sdb1
Sorry for my English, is not my language

When you ask for support, put the output of inxi -Fxz


Return to “Hardware Support”

Who is online

Users browsing this forum: No registered users and 12 guests