[SOLVED] Laptop brightness not working in Mint 18.2 Cinnamon

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
JLemur
Level 1
Level 1
Posts: 3
Joined: Fri Nov 03, 2017 11:02 am

[SOLVED] Laptop brightness not working in Mint 18.2 Cinnamon

Postby JLemur » Fri Nov 03, 2017 11:15 am

I've got an issue with my laptop's brightness having just installed Linux Mint 18.2 with Cinnamon 3.4.6. I'm coming to Linux Mint from Ubuntu and OpenSUSE, where I've had the same issue, but I've been able to resolve it in those distros. When I press the brightness keys, I see the brightness indicator open and the bar moves up and down, but the brightness does not change. Also, when I open the brightness settings through the menu, I cannot change the brightness there either.

My solution in OpenSUSE was to install xf86-video-intel and to create the following file:

Code: Select all

# cat /etc/X11/xorg.conf.d/20-intel.conf
Section "Device"
        Identifier      "card0"
        Driver          "intel"
        Option          "Backlight"     "intel_backlight"
        BusID           "PCI:0:2:0"
EndSection


However, /etc/X11/xorg.conf.d does not exist in my current installation. I had to install xf86-video-intel after discovering that the intel module was not installed with OpenSUSE by default, but I do not see the same package in Mint.

Having checked a few Linux Mint solutions for a similar problem, I tried editing grub as follows:

Code: Select all

jon@jon-Inspiron-N4010 ~ $ grep "GRUB_CMDLINE_LINUX" /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX="acpi_backlight=vendor"


But after rebooting, the brightness is still unable to be adjusted.

I saw someone suggested checking this, but they did not mention what to do with the information. I'm posting it here in case anyone can help direct me to how this is useful:

Code: Select all

$ systemctl list-units | grep backlight
sys-devices-pci0000:00-0000:00:02.0-drm-card0-card0\x2dLVDS\x2d1-intel_backlight.device                               loaded active plugged   /sys/devices/pci0000:00/0000:00:02.0/drm/card0/card0-LVDS-1/intel_backlight
sys-devices-platform-dell\x2dlaptop-backlight-dell_backlight.device                                                   loaded active plugged   /sys/devices/platform/dell-laptop/backlight/dell_backlight
sys-devices-platform-dell\x2dlaptop-leds-dell::kbd_backlight.device                                                   loaded active plugged   /sys/devices/platform/dell-laptop/leds/dell::kbd_backlight
systemd-backlight@backlight:dell_backlight.service                                                                    loaded active exited    Load/Save Screen Backlight Brightness of backlight:dell_backlight
systemd-backlight@backlight:intel_backlight.service                                                                   loaded active exited    Load/Save Screen Backlight Brightness of backlight:intel_backlight
systemd-backlight@leds:dell::kbd_backlight.service                                                                    loaded active exited    Load/Save Screen Backlight Brightness of leds:dell::kbd_backlight
system-systemd\x2dbacklight.slice                                                                                     loaded active active    system-systemd\x2dbacklight.slice


My laptop is a Dell Inspiron 14R.
Last edited by JLemur on Fri Nov 03, 2017 11:39 am, edited 1 time in total.

JLemur
Level 1
Level 1
Posts: 3
Joined: Fri Nov 03, 2017 11:02 am

Re: Laptop brightness not working in Mint 18.2 Cinnamon

Postby JLemur » Fri Nov 03, 2017 11:39 am

I got it to work by doing the following:

(I don't know if this first part was necessary, but I did it)

Entered command line interface (TTY1) by pressing Ctrl-Alt-F1, stopped the display manager, and reconfigured xserver-xorg

Code: Select all

service lightdm stop
sudo dpkg-reconfigure xserver-xorg
sudo dpkg-reconfigure xserver-xorg-video-intel


That still didn't create an xorg.conf file, so I created one manually in /etc/X11/ with only this information:

Code: Select all

$ cat /etc/X11/xorg.conf
Section "Device"
   Identifier   "card0"
   Driver      "intel"
   Option      "Backlight"   "intel_backlight"
   BusID      "PCI:0:2:0"
EndSection


Then I rebooted, and the laptop brightness started working when I press the brightness keys (Fn-F4 and Fn-F5).

User avatar
Moem
Level 11
Level 11
Posts: 3715
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: [SOLVED] Laptop brightness not working in Mint 18.2 Cinnamon

Postby Moem » Fri Nov 03, 2017 11:46 am

Thank you for stating your solution, you're helping us make this forum a better resource! 8)
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!


Return to “Hardware Support”