OS HD keeps parking every few seconds

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
User avatar
Minterator
Level 5
Level 5
Posts: 596
Joined: Thu Jan 10, 2013 8:29 am

OS HD keeps parking every few seconds

Post by Minterator » Wed Nov 29, 2017 10:52 am

OS HD keeps parking & restarting every few seconds, click-click-click.

It works fine in LM 17.3 and only does this in 18.3, the disk is a 500 GB Hitachi HTS547550A9E384 (JE3OA50A)
Mint 17.3 MATE, kernel 4.11.12

User avatar
Pjotr
Level 20
Level 20
Posts: 10058
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: OS HD keeps parking every few seconds

Post by Pjotr » Wed Nov 29, 2017 11:28 am

Tip: 10 things to do after installing Linux Mint 18.3 Sylvia
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

User avatar
Minterator
Level 5
Level 5
Posts: 596
Joined: Thu Jan 10, 2013 8:29 am

Re: OS HD keeps parking every few seconds

Post by Minterator » Wed Nov 29, 2017 2:41 pm

Pjotr wrote:Try this:
https://sites.google.com/site/easylinux ... p-and-down
(item 12, right column)

Thank you. That worked and the setting persists after resume/reboot without editing /etc/hdparm.conf. And in LM17.3 spindown-timeout still works properly.
Mint 17.3 MATE, kernel 4.11.12

User avatar
Pjotr
Level 20
Level 20
Posts: 10058
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: OS HD keeps parking every few seconds

Post by Pjotr » Wed Nov 29, 2017 3:35 pm

Minterator wrote:
Pjotr wrote:Try this:
https://sites.google.com/site/easylinux ... p-and-down
(item 12, right column)

Thank you. That worked and the setting persists after resume/reboot without editing /etc/hdparm.conf. And in LM17.3 spindown-timeout still works properly.
Good to hear that it worked. :)

However, I do think that /etc/hdparm.conf will need to be edited as well, in order to make this fix persistent....
Tip: 10 things to do after installing Linux Mint 18.3 Sylvia
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

User avatar
Minterator
Level 5
Level 5
Posts: 596
Joined: Thu Jan 10, 2013 8:29 am

Re: OS HD keeps parking every few seconds

Post by Minterator » Wed Nov 29, 2017 3:50 pm

Pjotr wrote:
Minterator wrote:
Pjotr wrote:Try this:
https://sites.google.com/site/easylinux ... p-and-down
(item 12, right column)

Thank you. That worked and the setting persists after resume/reboot without editing /etc/hdparm.conf. And in LM17.3 spindown-timeout still works properly.
Good to hear that it worked. :)

However, I do think that /etc/hdparm.conf will need to be edited as well, in order to make this fix persistent....
I agree, /etc/hdparm.conf should be edited or at least some thaw|resume in /etc/pm/sleep.d/ but it's working properly in both LM17.3 & 18.3
Mint 17.3 MATE, kernel 4.11.12

Post Reply

Return to “Hardware Support”