TP Link TL-WN722N V2

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 2
Joined: Tue Dec 05, 2017 1:59 pm

TP Link TL-WN722N V2

Post by ieronymous » Tue Dec 05, 2017 2:18 pm


i ve purchased a wireless usb stick with an external antena for a laptop which monitor broken and had to de -attach it from the laptop's body. Problem was that the wireless card had cables directly soldered inside the monitor so i removed the card and searched for a
wifi usb stick and came across to TP Link TL-WN722N V2 It uses realtek rtl8188eus chip and I m using Mint 18.3 version. My problem is that i cant seem to make OS see the wifi stick
Tried many things like

Code: Select all

sudo add-apt-repository ppa:hanipouspilot/rtlwifi
sudo apt update
sudo apt install rtl8192eu-dkms

Now i see that my stick uses diffrent chip so it failed for this reason


Code: Select all

sudo aptitude install firmware-atheros
sudo service network-manager restart
Well that didnt worked either because V1 only used Atheros chip

-for version 2 the driver provided on official website don't work it has chip-set of RTL8188 so install "lwfinger" drivers

Code: Select all

mkdir tmp
cd tmp
git clone
cd rtl8188eu
make all
sudo make install
sudo reboot
step:5 make the driver for your system (Note: you should have kernal headers to make, google it !) I didnt do anything for it but it didnt gave me any errors either
This step got me to see teh usb stick powered on at last but just that Seen also my ssid but as many times i tried i didnt manage to connect Like i couldn't type the password
Also the wifi bars were zero

-Lastly i found the below link and i dont want how to <<install it>> It's for the correct chip of mine

Anyone succeeded to make this damn usb stick work?

Thank you in advance

PS In case of any suggestions please also refer to the lines i have to run in the terminal

Post Reply

Return to “Hardware Support”