Any Thinkpad X230 users here that can help me with brightness?

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
orschiro
Level 4
Level 4
Posts: 218
Joined: Mon Dec 04, 2017 2:56 am
Contact:

Any Thinkpad X230 users here that can help me with brightness?

Postby orschiro » Thu Dec 07, 2017 10:34 am

Dear all,

I am running the latest 18.3 Cinnamon on my Thinkpad X230.

It's a really great and pleasant experience.

The only problem I have is that sometimes my laptop resumes from suspend and doesn't use the same brightness level I had used before suspending.

Does anyone using a X230 or related device experience the same or similar issue?

Thank you!

Hoser Rob
Level 10
Level 10
Posts: 3007
Joined: Sat Dec 15, 2012 8:57 am

Re: Any Thinkpad X230 users here that can help me with brightness?

Postby Hoser Rob » Thu Dec 07, 2017 11:04 am

Since I wouldn't assume that all Thinkpad X230s are going to have the same video card, you should provide more info. Copy/paste this to the terminal and copy/paste the text output here:

Code: Select all

inxi -Fxz

orschiro
Level 4
Level 4
Posts: 218
Joined: Mon Dec 04, 2017 2:56 am
Contact:

Re: Any Thinkpad X230 users here that can help me with brightness?

Postby orschiro » Thu Dec 07, 2017 11:47 am

Thank you for your help!

Here is the output:

Code: Select all

orschiro@x230 ~ $ inxi -Fxz
System:    Host: x230 Kernel: 4.10.0-40-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.6 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: LENOVO (portable) product: 23352CG v: ThinkPad X230
           Mobo: LENOVO model: 23352CG v: NO DPK
           Bios: LENOVO v: G2ETA8WW (2.68 ) date: 04/19/2017
CPU:       Dual core Intel Core i5-3320M (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10376
           clock speeds: max: 3300 MHz 1: 3099 MHz 2: 3098 MHz 3: 3210 MHz
           4: 3167 MHz
Graphics:  Card: Intel 3rd Gen Core processor Graphics Controller
           bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.10hz
           GLX Renderer: Mesa DRI Intel Ivybridge Mobile
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card Intel 7 Series/C210 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.10.0-40-generic
Network:   Card-1: Intel 82579LM Gigabit Network Connection
           driver: e1000e v: 3.2.6-k port: 5080 bus-ID: 00:19.0
           IF: enp0s25 state: down mac: <filter>
           Card-2: Intel Centrino Advanced-N 6205 [Taylor Peak]
           driver: iwlwifi bus-ID: 03:00.0
           IF: wlp3s0 state: up mac: <filter>
Drives:    HDD Total Size: 128.0GB (56.4% used)
           ID-1: /dev/sda model: Samsung_SSD_840 size: 128.0GB
Partition: ID-1: / size: 50G used: 6.7G (15%) fs: ext4 dev: /dev/dm-0
           ID-2: /boot size: 976M used: 121M (14%) fs: ext4 dev: /dev/sda1
           ID-3: /home size: 62G used: 56G (95%) fs: ext4 dev: /dev/dm-2
           ID-4: swap-1 size: 6.21GB used: 0.00GB (0%) fs: swap dev: /dev/dm-1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 55.0C mobo: N/A
           Fan Speeds (in rpm): cpu: 3264
Info:      Processes: 372 Uptime: 9:22 Memory: 3688.4/11713.3MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35


Return to “Hardware Support”