Wifi: Broadcom BCM4306 rev3 (Laptop Dell Inspiron 9100)

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
Level 2
Level 2
Posts: 73
Joined: Sun Jan 08, 2012 12:08 pm

Wifi: Broadcom BCM4306 rev3 (Laptop Dell Inspiron 9100)

Post by kaefert » Mon Dec 11, 2017 6:36 am

Hey there!

I wanted to revive an old laptop of mine, a Dell Inspiron 9100.
I tried both Linux Mint XFCE 17.1 and 18.2, and they both work okey in general, but the wifi makes problems.

I still got an Windows XP installation on that machine which works fine but it's quite scary to connect that to the internet..
The WinXP got working wifi (completely stable)
On Linux Mint XFCE 18.2 I got the wifi recognized as such after installing the package `firmware-b43-installer` and running `modprobe b43` (when running a kernel 4.4.*, with 4.8.* and 4.10.* it doesn't seem to work at all). But although I can connect to a network sometimes it looses the connection a few seconds afterwards (also the network interface vanishes so if I run `ifconfig` only the loopback and the wired network eth0 is shown) and after a few more seconds it comes back and connects again. This is not usable sadly.

With Linux Mint XFCE 17.1 the same procedure works, but it also offers to install drivers through the drivermanger gui, but doing that never finishes, cannot be killed and leaves apt-get in an unrepairable state.

Anybody got hint's on how to get this wifi-card working with an not too ancient operating system?

I had it working stable with some ancient ubuntu version before, but sadly I did not take note which it was.. And I'm also unsure if those ancient linux systems are safe to operate with an unrestricted internet connection? Do they still have the repositories online for those and publish security updates?

These are the details of the problematic wifi card:

Code: Select all

user@Inspiron-9100 ~ $ lspci -s 2:3 -vv
02:03.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)
    Subsystem: Dell Wireless 1350 WLAN Mini-PCI Card
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
    Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 32
    Interrupt: pin A routed to IRQ 17
    Region 0: Memory at faff6000 (32-bit, non-prefetchable) [size=8K]
    Kernel driver in use: b43-pci-bridge
For reference the information on how to get it halfway working was found here:

Post Reply

Return to “Hardware Support”