AMD R9-290x acceleration in Kernel 4.08 or 4.10?

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
rkelleyrtp
Level 1
Level 1
Posts: 3
Joined: Mon Nov 13, 2017 12:35 pm

AMD R9-290x acceleration in Kernel 4.08 or 4.10?

Postby rkelleyrtp » Mon Dec 11, 2017 3:46 pm

Greetings all,

I am trying to move from Mac OSX to Ubuntu but am having a heck of a time getting everything working. I have an Intel 5690X CPU, 32G RAM, and an AMD R9-290x on an Gigabyte X99UD4 board. I installed mint 18.2 XFCE - all went well.

I ran some video benchmarks after the install, and it seems the hardware acceleration was awful. I was getting 14-FPS in the "Heaven Valley" test. After researching for a bit, I discovered the the stock kernel (4.08) does not have the video acceleration I needed. I upgraded to kernel 4.14 and Valley started giving me 60-80FPS! Seems like the new kernel did the trick. However, I can't run Virtualbox or VMWare workstation anymore due to module compiling errors.

For example, trying to install Virtualbox gives me this:

Code: Select all

Job for virtualbox.service failed because the control process exited with error code. See "systemctl status virtualbox.service" and "journalctl -xe" for details.
invoke-rc.d: initscript virtualbox, action "restart" failed.
● virtualbox.service - LSB: VirtualBox Linux kernel module
   Loaded: loaded (/etc/init.d/virtualbox; bad; vendor preset: enabled)
   Active: failed (Result: exit-code) since Mon 2017-12-11 14:18:31 EST; 5ms ago
     Docs: man:systemd-sysv-generator(8)
  Process: 6352 ExecStart=/etc/init.d/virtualbox start (code=exited, status=1/FAILURE)

Dec 11 14:18:31 rkelley-xfce systemd[1]: Starting LSB: VirtualBox Linux kernel module...
Dec 11 14:18:31 rkelley-xfce virtualbox[6352]:  * Loading VirtualBox kernel modules...
Dec 11 14:18:31 rkelley-xfce virtualbox[6352]:  * No suitable module for running kernel found
Dec 11 14:18:31 rkelley-xfce virtualbox[6352]:    ...fail!
Dec 11 14:18:31 rkelley-xfce systemd[1]: virtualbox.service: Control process exited, code=exited status=1
Dec 11 14:18:31 rkelley-xfce systemd[1]: Failed to start LSB: VirtualBox Linux kernel module.
Dec 11 14:18:31 rkelley-xfce systemd[1]: virtualbox.service: Unit entered failed state.
Dec 11 14:18:31 rkelley-xfce systemd[1]: virtualbox.service: Failed with result 'exit-code'.


This happens if I download the ".deb" file from VBox, use the "standard" ppa, or use the "custom" ppa (deb http://download.virtualbox.org/virtualbox/debian zesty non-free contrib)
I get similar issues with VMWare Workstation 14 (something about missing gcc-7 - which essentially means the vmnet driver fails to compile). When booting back to kernel 4.08 or 4.10, the apps work properly but the acceleration does not.

Just reaching out to see if anyone might have an idea how to get AMD acceleration in kernel 4.08 or 4.10. I really, really want to use Linux but need video hardware acceleration and the ability to run VMs.

Thanks.

rkelleyrtp
Level 1
Level 1
Posts: 3
Joined: Mon Nov 13, 2017 12:35 pm

[SOLVED] AMD R9-290x acceleration in Kernel 4.08 or 4.10?

Postby rkelleyrtp » Tue Dec 12, 2017 11:48 am

Quick follow-up. Turns out I was using the wrong PPA to download Virtualbox. I was using the "zesty" PPA instead of "xenial" (apparently, Mint 18.2 is based on Xenial). The correct entry in /etc/apt/sources.list.d/virtualbox.org.list should be

Code: Select all

deb http://download.virtualbox.org/virtualbox/debian xenial contrib


After purging all remnants of virtualbox then reinstalling, things got sorted out. I have HW acceleration on my R9-290x and can run VirtualBox VMs. All while running kernel 4.14 (Linux 4.14.0-041400-generic).


Return to “Hardware Support”