Mint 18.2 Never SLEEPS ! (suspend)

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
ac0ma
Level 1
Level 1
Posts: 6
Joined: Sun Dec 24, 2017 10:29 pm

Mint 18.2 Never SLEEPS ! (suspend)

Post by ac0ma » Sun Dec 24, 2017 10:54 pm

Hi everyone!

I'm a new Linux user so please forgive my tremendous ignorance.

Since I wiped out windows 10 and installed linux on both my laptop and my desktop computers, my life has changed in a very good way.

But because the subject of this post is not about all the good aspects of linux compared to windows, I'll go straight to the point: my biggest problem right now is that sleep functionality (or suspend on mint) doesn't work on my desktop computer. And hibernate neither. When I do that, screens go normally black for a sec, and then it's like waking up instantaneously, locked and asking for my pwd (but power never shuts down in that brief moment, just the screens).

I did some researches before posting this message of course, but very often the found issues were more about "killing aggressive sleep mode" or were related to computer not getting out of sleep mode.

Any idea of the cause of this ?

Any help is much appreciated.

Thank you!

(and Merry Christmas :-)

User avatar
Pierre
Level 17
Level 17
Posts: 7289
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Mint 18.2 Never SLEEPS ! (suspend)

Post by Pierre » Sun Dec 24, 2017 11:21 pm

So, in oder to help you - - we will need some hardware info . .

Code: Select all

inxi -Fxz
type that code into a Terminal session that is on your Desktop taskbar,
& copy / paste the result, back here, on your next reply.
8)
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

User avatar
caf4926
Level 7
Level 7
Posts: 1868
Joined: Mon Mar 22, 2010 3:21 pm
Location: UK Lake District

Re: Mint 18.2 Never SLEEPS ! (suspend)

Post by caf4926 » Sun Dec 24, 2017 11:24 pm

It can sometimes be an issue related to the GPU - For example nVidia and the driver
It's a longtime since I experienced any issues though so I don't recall the solution/s
Linux Mint 18.3 Cinnamon

ac0ma
Level 1
Level 1
Posts: 6
Joined: Sun Dec 24, 2017 10:29 pm

Re: Mint 18.2 Never SLEEPS ! (suspend)

Post by ac0ma » Mon Dec 25, 2017 1:11 pm

Hi again. Thanks for your reply. Here is the result of inxi -Fxz (I feel a bit naked now...)

Code: Select all

System:    Host
           Desktop: Cinnamon 3.4.6 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.2 Sonya
Machine:   Mobo:
CPU:       
Graphics: 
Audio:    
Network:   
Drives: 
Partition: t
Sensors:  
Info:
Last edited by ac0ma on Wed Jan 03, 2018 10:44 pm, edited 2 times in total.

carum carvi
Level 3
Level 3
Posts: 190
Joined: Sun Apr 16, 2017 11:44 pm

Re: Mint 18.2 Never SLEEPS ! (suspend)

Post by carum carvi » Tue Dec 26, 2017 11:24 am

I am a newbie myself so dont get your hopes up by my advice, but I have had numerous problems with sleep and suspend as well when I tried out different versions of LinuxMint.
As I know now hibernate and suspend(=sleep) is a very much reported problem. Mostly one or the other works. Rarely seem both to work fine.

In LinuxMint 18.1. my suspend(sleep) works fine. Hibernate NEVER works whatever mint edition I choose. But thats ok, because I only need suspend. But when I upgraded from LinuxMint 18.1. to 18.2 /18.3. I also got suspend(sleep) problems.

My advice to you is: try out a new install with LinuxMint 18.1. Cinnamon edition. I have got smooth sailing with suspend in LinuxMint18.1. Cinnamon edition.
The 18.1. edition of LinuxMint uses a different base of software than 18.2 / 18.3, according to user MuteAnt. That could be the cause of the problem for me that suspend(sleep) DOES NOT work in 18.2 and 18.3 for me but DOES work fine in 18.1.
Somebody else advised me to try LinuxMInt Mate edition too, because Mate has the reputation to have better support for hardware conflicts, although that didnt work for me.

Good luck with trying out different things. I have been a newbie for half a year now and I only like LinuxMint more and more, but it takes some searching in the beginning sometimes...

Sorry for the " suspend(sleep)" quotations, but in the past I got confused myself which is what, because english is not my native tongue.
Hibernate is a complete power down with information stored on the harddrive. After a new power up of the pc the information is REstored from the harddisk.
With suspend(sleep) the pc stays on standby in low power mode. No information is stored on the harddisk, but in RAM memory only.But you can quickly wake up the pc with one keypress which isnt possible with hibernate.
Too make things even more confusing there is hybrid sleep which is only available in linuxmint 18.3. but not in 18.1/.18.2.
It is a fast hibernate mode. It speeds up the time to get out of hibernate.
Last edited by carum carvi on Mon Jan 01, 2018 5:04 pm, edited 2 times in total.

User avatar
ClixTrix
Level 5
Level 5
Posts: 747
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: Mint 18.2 Never SLEEPS ! (suspend)

Post by ClixTrix » Tue Dec 26, 2017 11:51 am

Make sure "Wake on LAN" is disabled in Motherboard BIOS.
Linux Mint 18.3 x64 Cinnamon Kernel 4.15.0-33-generic
Gigabyte GA-AB350M-D3H (F20) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 2x8GB / XFX HD5450-1GB
NVMe-SSD Samsung 960 EVO 250GB / SATA-HDD WD1600BEKT 160GB / SATA-SSD Toshiba OCZ VX500 512GB

ac0ma
Level 1
Level 1
Posts: 6
Joined: Sun Dec 24, 2017 10:29 pm

Re: Mint 18.2 Never SLEEPS ! (suspend)

Post by ac0ma » Tue Dec 26, 2017 11:59 am

newbie serena wrote:I am a newbie myself so dont get your hopes up by my advice, but I have had numerous problems with sleep and suspend as well when I tried out different versions of LinuxMint.
As I know now hibernate(=sleep) and suspend is a very much reported problem. Mostly one or the other works. Rarely seem both to work fine.

In LinuxMint 18.1. my suspend works fine. Hibernate NEVER works whatever mint edition I choose. But thats ok, because I only need suspend. But when I upgraded from LinuxMint 18.1. to 18.2 /18.3. I also got suspend problems.

My advice to you is: try out a new install with LinuxMint 18.1. Cinnamon edition. I have got smooth sailing with suspend in LinuxMint18.1. Cinnamon edition.
The 18.1. edition of LinuxMint uses a different base of software than 18.2 / 18.3, according to user MuteAnt. That could be the cause of the problem for me that suspend DOES NOT work in 18.2 and 18.3 for me but DOES work fine in 18.1
Somebody else advised me to try LinuxMInt Mate edition too, because Mate has the reputation to have better support for hardware conflicts, although that didnt work for me.

Good luck with trying out different things. I have been a newbie for half a year now and I only like LinuxMint more and more, but it takes some searching in the beginning sometimes...
I feel you! It's a bit hard in the beginning because you don't really know exactly what you're doing and you constantly need tutorials for anything and what you can do on your own becomes rare.

Thanks for your replies, I will try what it gives with another version as you say.

ac0ma
Level 1
Level 1
Posts: 6
Joined: Sun Dec 24, 2017 10:29 pm

Re: Mint 18.2 Never SLEEPS ! (suspend)

Post by ac0ma » Tue Dec 26, 2017 12:00 pm

ClixTrix wrote:Make sure "Wake on LAN" is disabled in Motherboard BIOS.
Thanks I will try it

Post Reply

Return to “Hardware Support”