wifi cannot connect

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
whitede
Level 1
Level 1
Posts: 10
Joined: Mon Dec 24, 2012 12:08 am

wifi cannot connect

Post by whitede » Fri Jan 12, 2018 12:59 pm

I am using an old laptop trying to get wireless working again. The driver seems to be working: iwlist eth1 scan shows access points in the neighborhood including mine. Below is the output, "wireless-info.txt" from the script, "wireless-info" that I found from another post at a ubunto site. I hope this will help diagnose why the connection cannot be made. Thank you.

########## wireless info START ##########

Report from: 12 Jan 2018 08:00 PST -0800

Booted last: 12 Jan 2018 07:52 PST -0800

Script from: 05 Dec 2017 03:13 UTC +0000

##### release ###########################

Distributor ID: LinuxMint
Description: Linux Mint 17.3 Rosa
Release: 17.3
Codename: rosa

##### kernel ############################

Linux 3.13.0-24-generic #46-Ubuntu SMP Thu Apr 10 19:08:14 UTC 2014 i686 i686 i686 GNU/Linux

Parameters: ro, quiet, splash, vt.handoff=7

##### desktop ###########################

MATE

##### lspci #############################

01:03.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL-8100/8101L/8139 PCI Fast Ethernet Adapter [10ec:8139] (rev 10)
Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:0121]
Kernel driver in use: 8139too

01:09.0 Network controller [0280]: Intel Corporation PRO/Wireless 2915ABG [Calexico2] Network Connection [8086:4223] (rev 05)
Subsystem: Intel Corporation Device [8086:1000]
Kernel driver in use: ipw2200

##### lsusb #############################

Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 062a:2008 Creative Labs
Bus 001 Device 003: ID 05dc:a410 Lexar Media, Inc. JumpDrive 128MB/256MB
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

##### PCMCIA card info ##################

PRODID_1=""
PRODID_2=""
PRODID_3=""
PRODID_4=""
MANFID=0000,0000
FUNCID=255

##### rfkill ############################

1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

##### lsmod #############################

ipw2200 136401 0
libipw 33144 1 ipw2200
lib80211 14040 2 libipw,ipw2200
cfg80211 409394 2 libipw,ipw2200

##### interfaces ########################

auto lo
iface lo inet loopback

iface eth1 inet dhcp
wpa-psk <WPA key removed>
wpa-driver wext
wpa-key-mgmt WPA-PSK
wpa-proto WPA2
wpa-ssid summerfield

auto eth1

##### ifconfig ##########################

eth0 Link encap:Ethernet HWaddr <MAC 'eth0' [IF1]>
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

eth1 Link encap:Ethernet HWaddr <MAC 'eth1' [IF2]>
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:30 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:6137 (6.1 KB)

eth1:avahi Link encap:Ethernet HWaddr <MAC 'eth1' [IF2]>
inet addr:169.254.5.212 Bcast:169.254.255.255 Mask:255.255.0.0
UP BROADCAST MULTICAST MTU:1500 Metric:1

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:36 errors:0 dropped:0 overruns:0 frame:0
TX packets:36 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2608 (2.6 KB) TX bytes:2608 (2.6 KB)

##### iwconfig ##########################

lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11abg ESSID:off/any
Mode:Managed Channel:0 Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power=20 dBm Sensitivity=8/0
Retry limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

##### route #############################

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 0.0.0.0 0.0.0.0 U 1003 0 0 eth1
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth1

##### resolv.conf #######################

##### network managers ##################

Installed:

NetworkManager

Running:

root 2262 1 0 07:55 ? 00:00:00 NetworkManager

##### NetworkManager info ###############

NetworkManager Tool

State: connected (global)

- Device: eth1 -----------------------------------------------------------------
Type: 802.11 WiFi
Driver: ipw2200
State: unmanaged
Default: no
HW Address: <MAC 'eth1' [IF2]>

Capabilities:

Wireless Properties
WEP Encryption: yes
WPA Encryption: yes
WPA2 Encryption: yes

Wireless Access Points

- Device: eth0 -----------------------------------------------------------------
Type: Wired
Driver: 8139too
State: unavailable
Default: no
HW Address: <MAC 'eth0' [IF1]>

Capabilities:
Carrier Detect: yes

Wired Properties
Carrier: off

##### NetworkManager.state ##############

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
WimaxEnabled=true

##### NetworkManager.conf ###############

[main]
plugins=ifupdown,keyfile,ofono
dns=dnsmasq

[ifupdown]
managed=false

##### NetworkManager profiles ###########

[[/etc/NetworkManager/system-connections/summerfield]] (600 root)
[connection] id=summerfield | type=802-11-wireless
[802-11-wireless] ssid=summerfield | mac-address=<MAC 'eth1' [IF2]>
[ipv4] method=auto
[ipv6] method=auto

##### Netplan config ####################

##### iw reg get ########################

Region: America/Vancouver (based on set time zone)

country 00:
(2402 - 2472 @ 40), (3, 20)
(2457 - 2482 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS
(2474 - 2494 @ 20), (3, 20), NO-OFDM, PASSIVE-SCAN, NO-IBSS
(5170 - 5250 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS
(5735 - 5835 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS

##### iwlist channels ###################

lo no frequency information.

eth0 no frequency information.

eth1 24 channels in total; available frequencies :
Channel 01 : 2.412 GHz
Channel 02 : 2.417 GHz
Channel 03 : 2.422 GHz
Channel 04 : 2.427 GHz
Channel 05 : 2.432 GHz
Channel 06 : 2.437 GHz
Channel 07 : 2.442 GHz
Channel 08 : 2.447 GHz
Channel 09 : 2.452 GHz
Channel 10 : 2.457 GHz
Channel 11 : 2.462 GHz
Channel 36 : 5.18 GHz
Channel 40 : 5.2 GHz
Channel 44 : 5.22 GHz
Channel 48 : 5.24 GHz
Channel 52 : 5.26 GHz
Channel 56 : 5.28 GHz
Channel 60 : 5.3 GHz
Channel 64 : 5.32 GHz
Channel 149 : 5.745 GHz
Channel 153 : 5.765 GHz
Channel 157 : 5.785 GHz
Channel 161 : 5.805 GHz
Channel 165 : 5.825 GHz
Current Channel=0

##### iwlist scan #######################

lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

Channel occupancy:

1 APs on Frequency:2.412 GHz (Channel 1)
1 APs on Frequency:2.422 GHz (Channel 3)
2 APs on Frequency:2.442 GHz (Channel 7)
1 APs on Frequency:2.447 GHz (Channel 8)

eth1 Scan completed :
Cell 01 - Address: <MAC 'SMA1990025782 ' [AC1]>
ESSID:"SMA1990025782 "
Protocol:IEEE 802.11b
Mode:Master
Frequency:2.412 GHz (Channel 1)
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
Quality=37/100 Signal level=-78 dBm
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
Extra: Last beacon: 10316ms ago
Cell 02 - Address: <MAC 'Birkney' [AC2]>
ESSID:"Birkney"
Protocol:IEEE 802.11bg
Mode:Master
Frequency:2.422 GHz (Channel 3)
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=31/100 Signal level=-81 dBm
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
Extra: Last beacon: 10264ms ago
Cell 03 - Address: <MAC 'Extender' [AC3]>
ESSID:"Extender"
Protocol:IEEE 802.11bg
Mode:Master
Frequency:2.442 GHz (Channel 7)
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 11 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=89/100 Signal level=-40 dBm
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
Extra: Last beacon: 4140ms ago
Cell 04 - Address: <MAC 'Summerfield' [AC4]>
ESSID:"Summerfield"
Protocol:IEEE 802.11bg
Mode:Master
Frequency:2.442 GHz (Channel 7)
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=78/100 Signal level=-51 dBm
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
Extra: Last beacon: 4156ms ago
Cell 05 - Address: <MAC 'Sandworms-guest' [AC5]>
ESSID:"Sandworms-guest"
Protocol:IEEE 802.11bg
Mode:Master
Frequency:2.447 GHz (Channel 8)
Encryption key:off
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=27/100 Signal level=-83 dBm
Extra: Last beacon: 10124ms ago

##### module infos ######################

[ipw2200]
filename: /lib/modules/3.13.0-24-generic/kernel/drivers/net/wireless/ipw2x00/ipw2200.ko
firmware: ipw2200-bss.fw
firmware: ipw2200-sniffer.fw
firmware: ipw2200-ibss.fw
license: GPL
author: Copyright(c) 2003-2006 Intel Corporation
version: 1.2.2kmprq
description: Intel(R) PRO/Wireless 2200/2915 Network Driver
srcversion: 6432FDB1497A8B2EC025CB2
depends: cfg80211,libipw,lib80211
intree: Y
vermagic: 3.13.0-24-generic SMP mod_unload modversions 686
signer: Magrathea: Glacier signing key
sig_key: 77:D7:0E:1D:F4:29:96:DC:92:B0:1D:75:9D:3E:85:62:EA:32:A1:C7
sig_hashalgo: sha512
parm: disable:manually disable the radio (default 0 [radio on]) (int)
parm: associate:auto associate when scanning (default off) (int)
parm: auto_create:auto create adhoc network (default on) (int)
parm: led:enable led control on some systems (default 1 on) (int)
parm: debug:debug output mask (int)
parm: channel:channel to limit associate to (default 0 [ANY]) (int)
parm: rtap_iface:create the rtap interface (1 - create, default 0) (int)
parm: qos_enable:enable all QoS functionalitis (int)
parm: qos_burst_enable:enable QoS burst mode (int)
parm: qos_no_ack_mask:mask Tx_Queue to no ack (int)
parm: burst_duration_CCK:set CCK burst value (int)
parm: burst_duration_OFDM:set OFDM burst value (int)
parm: mode:network mode (0=BSS,1=IBSS,2=Monitor) (int)
parm: bt_coexist:enable bluetooth coexistence (default off) (int)
parm: hwcrypto:enable hardware crypto (default off) (int)
parm: cmdlog:allocate a ring buffer for logging firmware commands (int)
parm: roaming:enable roaming support (default on) (int)
parm: antenna:select antenna 1=Main, 3=Aux, default 0 [both], 2=slow_diversity (choose the one with lower background noise) (int)

[cfg80211]
filename: /lib/modules/3.13.0-24-generic/kernel/net/wireless/cfg80211.ko
description: wireless configuration support
license: GPL
author: Johannes Berg
srcversion: 8B3D642D1F2E6406EF33F74
depends:
intree: Y
vermagic: 3.13.0-24-generic SMP mod_unload modversions 686
signer: Magrathea: Glacier signing key
sig_key: 77:D7:0E:1D:F4:29:96:DC:92:B0:1D:75:9D:3E:85:62:EA:32:A1:C7
sig_hashalgo: sha512
parm: ieee80211_regdom:IEEE 802.11 regulatory domain code (charp)
parm: cfg80211_disable_40mhz_24ghz:Disable 40MHz support in the 2.4GHz band (bool)

##### module parameters #################

[ipw2200]
antenna: 0
associate: 0
auto_create: 1
bt_coexist: 0
burst_duration_CCK: 0
burst_duration_OFDM: 0
channel: 0
cmdlog: 0
debug: 0
disable: 0
hwcrypto: 0
led: 1
mode: 0
qos_burst_enable: 0
qos_enable: 0
qos_no_ack_mask: 0
roaming: 1
rtap_iface: 0

[cfg80211]
cfg80211_disable_40mhz_24ghz: N
ieee80211_regdom: 00

##### /etc/modules ######################

lp

##### modprobe options ##################

[/etc/modprobe.d/blacklist-ath_pci.conf]
blacklist ath_pci

[/etc/modprobe.d/blacklist.conf]
blacklist evbug
blacklist usbmouse
blacklist usbkbd
blacklist eepro100
blacklist de4x5
blacklist eth1394
blacklist snd_intel8x0m
blacklist snd_aw2
blacklist i2c_i801
blacklist prism54
blacklist bcm43xx
blacklist garmin_gps
blacklist asus_acpi
blacklist snd_pcsp
blacklist pcspkr
blacklist amd76x_edac

[/etc/modprobe.d/blacklist-rare-network.conf]
alias net-pf-3 off
alias net-pf-6 off
alias net-pf-9 off
alias net-pf-11 off
alias net-pf-12 off
alias net-pf-19 off
alias net-pf-21 off
alias net-pf-36 off

[/etc/modprobe.d/iwlwifi.conf]
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211

[/etc/modprobe.d/mlx4.conf]
softdep mlx4_core post: mlx4_en

##### rc.local ##########################

exit 0

##### pm-utils ##########################

##### udev rules ########################

[/etc/udev/rules.d/70-persistent-net.rules]
# PCI device 0x10ec:0x8139 (8139too)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC 'eth0' [IF1]>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
# PCI device 0x8086:0x4223 (ipw2200)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC 'eth1' [IF2]>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth1"

##### dmesg #############################

[ 19.093325] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kmprq
[ 19.093335] ipw2200: Copyright(c) 2003-2006 Intel Corporation
[ 19.093748] ipw2200: Detected Intel PRO/Wireless 2915ABG Network Connection
[ 19.943052] ipw2200: Detected geography ZZA (11 802.11bg channels, 13 802.11a channels)
[ 90.707183] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[ 91.704023] ipw2200: Failed to send CARD_DISABLE: Command timed out.
[ 338.852759] 8139too 0000:01:03.0 eth0: link down
[ 338.852976] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready (repeated 2 times)

########## wireless info END ############

earnestbunbury
Level 1
Level 1
Posts: 6
Joined: Fri Jan 12, 2018 1:09 pm

Re: wifi cannot connect

Post by earnestbunbury » Fri Jan 12, 2018 2:00 pm

Did you install the driver for it? Just because the system shows that you have wireless connections in your area doesn't mean that the driver for that wireless adapter is working.

Post Reply

Return to “Hardware Support”