Turning off bluetooth shuts down wireless as well

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
User avatar
djk2
Level 1
Level 1
Posts: 5
Joined: Mon Jan 15, 2018 3:32 pm
Location: New Jersey, United States

Turning off bluetooth shuts down wireless as well

Post by djk2 » Mon Jan 15, 2018 4:55 pm

When I turn off bluetooth it also turns off my wireless completely. My wireless card is a Broadcom BCM4313 802.11bgn.

My system dual boots with Windows 10 and this is not an issue when running Windows.

I have updated to the Linux drivers that are specific to this wireless card, i.e. not using the generic ones. Still having the same problem.

Thoughts?

Thank you.
Mint 18.3 x64 Cinnamon 3.6.7
HP Pavilion dm1z-4000
Dual core AMD E-450 APU with Radeon HD Graphics
SSD Crucial CT525MX3 525GB

orschiro
Level 4
Level 4
Posts: 230
Joined: Mon Dec 04, 2017 2:56 am
Contact:

Re: Turning off bluetooth shuts down wireless as well

Post by orschiro » Tue Jan 16, 2018 3:05 am

When I turn off bluetooth it also turns off my wireless completely.
How do you turn off bluetooth?

User avatar
WiltshireJon
Level 1
Level 1
Posts: 47
Joined: Wed Nov 15, 2017 1:14 pm

Re: Turning off bluetooth shuts down wireless as well

Post by WiltshireJon » Tue Jan 16, 2018 7:49 am

To turn off Bluetooth:

Menu -> Preferences -> Bluetooth

It might be a coincidence but I think I had the same problem with Bluetooth turning off Wifi. Certainly something did and it wasn't me. I had trouble reconnecting: a reboot didn't help but the viewtopic.php?f=53&t=261724&p=1415202&h ... i#p1415202 third post, by czeekaj, worked for me.

My system:

Code: Select all

System:    Host: jon-zenbook Kernel: 4.13.0-26-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: ASUSTeK (portable) product: UX360UA v: 1.0
           Mobo: ASUSTeK model: UX360UA v: 1.0
           Bios: American Megatrends v: UX360UA.300 date: 06/17/2016
CPU:       Dual core Intel Core i5-6200U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9600
           clock speeds: max: 2800 MHz 1: 2400 MHz 2: 2400 MHz 3: 2400 MHz
           4: 2400 MHz
Graphics:  Card: Intel Sky Lake Integrated Graphics bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: (unloaded: fbdev,vesa)
           Resolution: 3200x1800@59.70hz
           GLX Renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2)
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card Intel Sunrise Point-LP HD Audio
           driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.13.0-26-generic
Network:   Card: Intel Wireless 7265 driver: iwlwifi bus-ID: 01:00.0
           IF: wlp1s0 state: up mac: <filter>
Drives:    HDD Total Size: 512.1GB (21.7% used)
           ID-1: /dev/sda model: HFS512G39MND size: 512.1GB
Partition: ID-1: / size: 213G used: 26G (13%) fs: ext4 dev: /dev/sda5
           ID-2: swap-1 size: 8.48GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 34.0C mobo: N/A
           Fan Speeds (in rpm): cpu: 3100
Info:      Processes: 193 Uptime: 19:53 Memory: 2034.9/7873.6MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 

User avatar
djk2
Level 1
Level 1
Posts: 5
Joined: Mon Jan 15, 2018 3:32 pm
Location: New Jersey, United States

Re: Turning off bluetooth shuts down wireless as well

Post by djk2 » Tue Jan 16, 2018 10:47 am

orschiro wrote:
When I turn off bluetooth it also turns off my wireless completely.
How do you turn off bluetooth?
I use the bluetooth icon in the panel. When I switch it to the off position, it disables both the bluetooth and wireless connections.
Mint 18.3 x64 Cinnamon 3.6.7
HP Pavilion dm1z-4000
Dual core AMD E-450 APU with Radeon HD Graphics
SSD Crucial CT525MX3 525GB

orschiro
Level 4
Level 4
Posts: 230
Joined: Mon Dec 04, 2017 2:56 am
Contact:

Re: Turning off bluetooth shuts down wireless as well

Post by orschiro » Tue Jan 16, 2018 10:51 am

I use the bluetooth icon in the panel. When I switch it to the off position, it disables both the bluetooth and wireless connections.
This sounds like a bug to me then. I would report it upstream. You are using Cinnamon right?

https://github.com/linuxmint/Cinnamon/issues/new

User avatar
djk2
Level 1
Level 1
Posts: 5
Joined: Mon Jan 15, 2018 3:32 pm
Location: New Jersey, United States

Re: Turning off bluetooth shuts down wireless as well

Post by djk2 » Tue Jan 16, 2018 10:53 am

orschiro wrote:
I use the bluetooth icon in the panel. When I switch it to the off position, it disables both the bluetooth and wireless connections.
This sounds like a bug to me then. I would report it upstream. You are using Cinnamon right?

https://github.com/linuxmint/Cinnamon/issues/new
Yes, Cinnamon.
Mint 18.3 x64 Cinnamon 3.6.7
HP Pavilion dm1z-4000
Dual core AMD E-450 APU with Radeon HD Graphics
SSD Crucial CT525MX3 525GB

User avatar
djk2
Level 1
Level 1
Posts: 5
Joined: Mon Jan 15, 2018 3:32 pm
Location: New Jersey, United States

Re: Turning off bluetooth shuts down wireless as well

Post by djk2 » Tue Jan 16, 2018 10:59 am

WiltshireJon wrote:To turn off Bluetooth:

Menu -> Preferences -> Bluetooth

It might be a coincidence but I think I had the same problem with Bluetooth turning off Wifi. Certainly something did and it wasn't me. I had trouble reconnecting: a reboot didn't help but the viewtopic.php?f=53&t=261724&p=1415202&h ... i#p1415202 third post, by czeekaj, worked for me.
Thanks for this. Unfortunately, after trying it, the issue remains.
Mint 18.3 x64 Cinnamon 3.6.7
HP Pavilion dm1z-4000
Dual core AMD E-450 APU with Radeon HD Graphics
SSD Crucial CT525MX3 525GB

User avatar
WiltshireJon
Level 1
Level 1
Posts: 47
Joined: Wed Nov 15, 2017 1:14 pm

Re: Turning off bluetooth shuts down wireless as well

Post by WiltshireJon » Tue Jan 16, 2018 11:35 am

Unread postby orschiro » Tue Jan 16, 2018 2:51 pm

I use the bluetooth icon in the panel. When I switch it to the off position, it disables both the bluetooth and wireless connections.


This sounds like a bug to me then. I would report it upstream. You are using Cinnamon right?

https://github.com/linuxmint/Cinnamon/issues/new
Done. https://github.com/linuxmint/Cinnamon/issues/7208

User avatar
djk2
Level 1
Level 1
Posts: 5
Joined: Mon Jan 15, 2018 3:32 pm
Location: New Jersey, United States

Re: Turning off bluetooth shuts down wireless as well

Post by djk2 » Sun Jan 21, 2018 1:05 pm

Do these things generally get resolved once they're sent upstream to Github?
Mint 18.3 x64 Cinnamon 3.6.7
HP Pavilion dm1z-4000
Dual core AMD E-450 APU with Radeon HD Graphics
SSD Crucial CT525MX3 525GB

orschiro
Level 4
Level 4
Posts: 230
Joined: Mon Dec 04, 2017 2:56 am
Contact:

Re: Turning off bluetooth shuts down wireless as well

Post by orschiro » Mon Jan 22, 2018 4:54 am

djk2 wrote:Do these things generally get resolved once they're sent upstream to Github?
If they are valid bugs, yes.

User avatar
WiltshireJon
Level 1
Level 1
Posts: 47
Joined: Wed Nov 15, 2017 1:14 pm

Re: Turning off bluetooth shuts down wireless as well

Post by WiltshireJon » Thu Feb 01, 2018 3:40 pm

this postt [SOLVED]

Things have moved on a bit and having updated the kernel I no longer have this error. Now I have another instead. journalctl gives this (among other stuff):

Code: Select all

Jan 30 09:20:46 jon-zenbook kernel: Bluetooth: hci0: Intel Bluetooth firmware patch completed and activated
Jan 30 09:20:46 jon-zenbook bluetoothd[848]: Failed to obtain handles for "Service Changed" characteristic
Jan 30 09:20:46 jon-zenbook systemd-udevd[5519]: Process '/bin/hciconfig hci0 up' failed with exit code 1.
Jan 30 09:20:46 jon-zenbook bluetoothd[848]: Not enough free handles to register service
Jan 30 09:20:46 jon-zenbook systemd[1]: Reached target Bluetooth.
Jan 30 09:20:46 jon-zenbook bluetoothd[848]: Error adding Link Loss service
Jan 30 09:20:46 jon-zenbook bluetoothd[848]: Not enough free handles to register service
Jan 30 09:20:46 jon-zenbook bluetoothd[848]: Not enough free handles to register service
Jan 30 09:20:46 jon-zenbook bluetoothd[848]: Not enough free handles to register service
Jan 30 09:20:46 jon-zenbook bluetoothd[848]: Current Time Service could not be registered
Jan 30 09:20:46 jon-zenbook bluetoothd[848]: gatt-time-server: Input/output error (5)
Jan 30 09:20:46 jon-zenbook bluetoothd[848]: Not enough free handles to register service
Jan 30 09:20:46 jon-zenbook bluetoothd[848]: Not enough free handles to register service
Jan 30 09:20:46 jon-zenbook bluetoothd[848]: Sap driver initialization failed.
Jan 30 09:20:46 jon-zenbook bluetoothd[848]: sap-server: Operation not permitted (1)
Jan 30 09:20:46 jon-zenbook bluetoothd[848]: Endpoint registered: sender=:1.53 path=/MediaEndpoint/A2DPSource
Jan 30 09:20:46 jon-zenbook bluetoothd[848]: Endpoint registered: sender=:1.53 path=/MediaEndpoint/A2DPSink
and looking at preferences>bluetooth shows that bluetooth is ON. I can't seem to switch it off, either from preferences or using the terminal:

Code: Select all

jon@jon-zenbook ~ $ sudo /etc/init.d/bluetooth stop
[sudo] password for jon: 
[ ok ] Stopping bluetooth (via systemctl): bluetooth.service.
but go back to preferences bluetooth and it still shows on. Try to start bluetooth via terminal gives this in journalctl:

Code: Select all

Feb 01 19:32:48 jon-zenbook bluetoothd[9632]: Bluetooth daemon 5.37
Feb 01 19:32:48 jon-zenbook systemd[1]: Started Bluetooth service.
Feb 01 19:32:48 jon-zenbook bluetoothd[9632]: Starting SDP server
Feb 01 19:32:48 jon-zenbook dbus[854]: [system] Activating via systemd: service name='org.freedesktop.hostname1' unit='dbus-org.freedesktop.hostn
Feb 01 19:32:48 jon-zenbook bluetoothd[9632]: Bluetooth management interface 1.14 initialized
Feb 01 19:32:48 jon-zenbook bluetoothd[9632]: Failed to obtain handles for "Service Changed" characteristic
Feb 01 19:32:48 jon-zenbook bluetoothd[9632]: Not enough free handles to register service
Feb 01 19:32:48 jon-zenbook bluetoothd[9632]: Error adding Link Loss service
Feb 01 19:32:48 jon-zenbook bluetoothd[9632]: Not enough free handles to register service
Feb 01 19:32:48 jon-zenbook bluetoothd[9632]: Not enough free handles to register service
Feb 01 19:32:48 jon-zenbook bluetoothd[9632]: Not enough free handles to register service
Feb 01 19:32:48 jon-zenbook bluetoothd[9632]: Current Time Service could not be registered
Feb 01 19:32:48 jon-zenbook bluetoothd[9632]: gatt-time-server: Input/output error (5)
Feb 01 19:32:48 jon-zenbook bluetoothd[9632]: Not enough free handles to register service
Feb 01 19:32:48 jon-zenbook bluetoothd[9632]: Not enough free handles to register service
Feb 01 19:32:48 jon-zenbook bluetoothd[9632]: Sap driver initialization failed.
Feb 01 19:32:48 jon-zenbook bluetoothd[9632]: sap-server: Operation not permitted (1)
Feb 01 19:32:48 jon-zenbook systemd[1]: Starting Hostname Service...
Feb 01 19:32:48 jon-zenbook pulseaudio[25766]: [pulseaudio] backend-ofono.c: Failed to register as a handsfree audio agent with ofono: org.freede
Feb 01 19:32:48 jon-zenbook bluetoothd[9632]: Endpoint registered: sender=:1.278 path=/MediaEndpoint/A2DPSource
Feb 01 19:32:48 jon-zenbook bluetoothd[9632]: Endpoint registered: sender=:1.278 path=/MediaEndpoint/A2DPSink
and whatever I do, bluetooth is dead...no other paired device finds it. Changing kernels within the same series gives the same error. Any thoughts? I'd like to stick with 4.13,xxx if possible as everything else works great...

Code: Select all

jon@jon-zenbook ~ $ inxi -Fxz
System:    Host: jon-zenbook Kernel: 4.13.0-32-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.3 Sylvia
Machine:   System: ASUSTeK (portable) product: UX360UA v: 1.0
           Mobo: ASUSTeK model: UX360UA v: 1.0 Bios: American Megatrends v: UX360UA.300 date: 06/17/2016
CPU:       Dual core Intel Core i5-6200U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9600
           clock speeds: max: 2800 MHz 1: 2400 MHz 2: 2400 MHz 3: 2400 MHz 4: 2400 MHz
Graphics:  Card: Intel Sky Lake Integrated Graphics bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: (unloaded: fbdev,vesa) Resolution: 3200x1800@59.70hz
           GLX Renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2)
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card Intel Sunrise Point-LP HD Audio driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.13.0-32-generic
Network:   Card: Intel Wireless 7265 driver: iwlwifi bus-ID: 01:00.0
           IF: wlp1s0 state: up mac: <filter>
Drives:    HDD Total Size: 512.1GB (22.8% used) ID-1: /dev/sda model: HFS512G39MND size: 512.1GB temp: 34C
Partition: ID-1: / size: 213G used: 33G (17%) fs: ext4 dev: /dev/sda5
           ID-2: swap-1 size: 8.48GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 36.5C mobo: N/A
           Fan Speeds (in rpm): cpu: 3100
Info:      Processes: 193 Uptime: 2 days Memory: 2340.4/7873.6MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
UPDATE: in kernel 4.4.0-112 the bluetooth works (similar errors as above(!) but other things don't, notably auto screen rotation. This is a 2-in-1 and I use it as a table regularly.

UPDATE UPDATED went back to 4.13...and bluetooth now works. Scratched head, shrugged, went for a beer...sorry if anyone has wasted time on this

Post Reply

Return to “Hardware Support”