Bluetooth on Mint 18.3 not working

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
Dos Santos
Level 1
Level 1
Posts: 3
Joined: Thu Jan 18, 2018 4:57 am

Bluetooth on Mint 18.3 not working

Post by Dos Santos » Thu Jan 18, 2018 6:09 am

Hey there!

I recently changed from Windows 10 to Linux Mint 18.3 Sylvia Cinnemon and I am really glad I did so. Win is still on an other partition though it deserves to be in the rubbish bin.
I've got only one problem: Though Bluetooth seems to be connected to my headphones they are not working in this setup.
The headphones (AKG Y50BT) are working on windows and on my smartphone so they are allright.
The bluetooth icon on the panel shows me that I am connected and the led on the headphones indicates that they are connected but still the sound comes from the computer.
Driver problem? I am using blueberry.
I am grateful for any suggestions...

more technical data:


System: Host: didi-SATELLITE-Radius-15-P50W-C-10J Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.6.6 (Gtk 3.18.9-1ubuntu3.3) dm: lightdm Distro: Linux Mint 18.3 Sylvia
Machine: System: TOSHIBA (portable) product: SATELLITE Radius 15 P50W-C-10J v: PSPVJE-00R06SGR
Mobo: FF40 model: 0692 v: 2.0 Bios: INSYDE v: 5.10 date: 09/21/2015
CPU: Dual core Intel Core i5-5200U (-HT-MCP-) cache: 3072 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 8779
clock speeds: min/max: 500/2700 MHz 1: 799 MHz 2: 848 MHz 3: 834 MHz 4: 801 MHz
Graphics: Card: Intel Broadwell-U Integrated Graphics bus-ID: 00:02.0 chip-ID: 8086:1616
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
Resolution: 1920x1080@60.02hz
GLX Renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2)
GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio: Card-1 Intel Wildcat Point-LP High Definition Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0 chip-ID: 8086:9ca0
Card-2 Intel Broadwell-U Audio Controller
driver: snd_hda_intel bus-ID: 00:03.0 chip-ID: 8086:160c
Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
Network: Card: Intel Wireless 3160 driver: iwlwifi bus-ID: 02:00.0 chip-ID: 8086:08b3
IF: wlp2s0 state: up mac: <filter>
Drives: HDD Total Size: 1000.2GB (10.5% used)
ID-1: /dev/sda model: HGST_HTS541010A9 size: 1000.2GB serial: 150820JD1009CC3K2Y0H
Partition: ID-1: / size: 406G used: 6.3G (2%) fs: ext4 dev: /dev/sda6
ID-2: swap-1 size: 8.50GB used: 0.00GB (0%) fs: swap dev: /dev/sda7
RAID: System: supported: N/A
No RAID devices: /proc/mdstat, md_mod kernel module present
Unused Devices: none
Sensors: System Temperatures: cpu: 53.0C mobo: 27.8C
Fan Speeds (in rpm): cpu: N/A
Repos: Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
deb http: //packages.linuxmint.com sylvia main upstream import backport #id:linuxmint_main
deb http: //archive.ubuntu.com/ubuntu xenial main restricted universe multiverse
deb http: //archive.ubuntu.com/ubuntu xenial-updates main restricted universe multiverse
deb http: //archive.ubuntu.com/ubuntu xenial-backports main restricted universe multiverse
deb http: //security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
deb http: //archive.canonical.com/ubuntu/ xenial partner
Info: Processes: 215 Uptime: 1 day Memory: 1917.4/7895.4MB
Init: systemd v: 229 runlevel: 5 default: 2 Gcc sys: 5.4.0
Client: Unknown python2.7 client inxi: 2.2.35

jwrober
Level 1
Level 1
Posts: 16
Joined: Thu Dec 21, 2017 12:17 pm

Re: Bluetooth on Mint 18.3 not working

Post by jwrober » Thu Jan 18, 2018 3:56 pm

Look in sound settings. I had to change these when I connected my external JBL flip3 bluetooth speaker for it work.

JeremyB
Level 19
Level 19
Posts: 9293
Joined: Fri Feb 21, 2014 8:17 am

Re: Bluetooth on Mint 18.3 not working

Post by JeremyB » Thu Jan 18, 2018 5:45 pm

If the headphones do not appear in sound settings, do

Code: Select all

pactl load-module module-bluetooth-discover
Then connect to the headset again

Dos Santos
Level 1
Level 1
Posts: 3
Joined: Thu Jan 18, 2018 4:57 am

Re: Bluetooth on Mint 18.3 not working

Post by Dos Santos » Fri Jan 19, 2018 6:55 am

Problem fixed! Thank you!
The way was:
Menu - Preferences -Sound - Output - Device: just activate with mouseklick.

Post Reply

Return to “Hardware Support”