How do you get 1-to-1 screen resolution back in 18.3 Cinnamon?

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
ywuw2486
Level 1
Level 1
Posts: 1
Joined: Thu Jan 18, 2018 11:29 am

How do you get 1-to-1 screen resolution back in 18.3 Cinnamon?

Post by ywuw2486 » Thu Jan 18, 2018 11:57 am

I've been a great admirer of Linux mint for many versions now, and it is, without question, my distro of choice. However I've encountered a problem with 18.3 cinnamon that I can't seem to reconcile.

First, I know that screens are getting higher and higher pixel densities and for that reason there has been a push to add features that allow the interface to be scaled larger so that it is easier to read.

My problem is the opposite, I see just fine, I like having the screen realestate, and I want my screen to be a 1-to-1 pixel ratio. 18.2 would use this mode by default, however the default for 18.3 seems to be somewhere between 1-to-1 and hi-dpi (which I think is 4-to-1). Everything is large and "fuzzy" so I'm pretty sure there is some filtering and aliasing gong on in the default mode.

My macbook screen is 2880x1800, and I'll admit, stuff looks tiny at 1-to-1, and I love it that way. My other screens are 2560x1440. 18.2 displays amazingly for me across all these screens in 1-to-1, but in 18.3 everything looks huge and I can't see nearly as much.

Everything I search for on the subject takes me to posts about making things scale larger. I thought that this post might have some promise if the correct ratio was chosen: viewtopic.php?t=159064 , however it seems like a lot to do to get back what used to be the default functionality.

I've moved carefully through the display and general settings options, and tried all manner of combinations, but can't get the screen resolution back down to the native 1-to-1. There is a good possibility I'm missing something, but any help on the subject would be appreciated.

User avatar
ClixTrix
Level 5
Level 5
Posts: 747
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: How do you get 1-to-1 screen resolution back in 18.3 Cinnamon?

Post by ClixTrix » Thu Jan 18, 2018 12:25 pm

To get best advise on your system, please run the following command from Terminal and post back the results.

Code: Select all

inxi -Fxz
Linux Mint 18.3 x64 Cinnamon Kernel 4.15.0-36-generic
Gigabyte GA-AB350M-D3H (F20) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 2x8GB / XFX HD5450-1GB
NVMe-SSD Samsung 960 EVO 250GB / SATA-HDD WD1600BEKT 160GB / SATA-SSD Toshiba OCZ VX500 512GB

User avatar
prestonR
Level 5
Level 5
Posts: 844
Joined: Wed Jan 07, 2015 12:24 pm
Location: Harare

Re: How do you get 1-to-1 screen resolution back in 18.3 Cinnamon?

Post by prestonR » Sat Jan 20, 2018 8:03 am

Not sure this will fix it since this sounds more of a dpi issue but to take charge of screen resolution I use this script https://www.linux-apps.com/content/show ... ent=134686

Put it in your taskbar for manual res-change or add something like
newrez 2880x1800
at startup

User avatar
Ozo
Level 5
Level 5
Posts: 765
Joined: Tue Dec 22, 2015 11:49 am
Location: Titusville, Florida USA

Re: How do you get 1-to-1 screen resolution back in 18.3 Cinnamon?

Post by Ozo » Sat Jan 20, 2018 11:36 am

ywuw2486 wrote: I've moved carefully through the display and general settings options, and tried all manner of combinations, but can't get the screen resolution back down to the native 1-to-1. There is a good possibility I'm missing something, but any help on the subject would be appreciated.
In the General settings (in system settings) is desktop scaling. General settings is the one with a wrench icon. Make sure scaling is not set at Double.

Image

Post Reply

Return to “Hardware Support”