Touchscreen stops working (HP Pavilion10X2)

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
Davdi
Level 1
Level 1
Posts: 15
Joined: Thu Jan 23, 2014 1:09 pm

Touchscreen stops working (HP Pavilion10X2)

Post by Davdi » Sat Feb 03, 2018 6:20 am

I've got a HP Pavilion 10x2 detachable (2GB/64GB) running Mint 18.2 Sonya 64 bit. on initial install the touchscreen works perfectly (I use it as a tablet sans keyboard quite often).
But after updating, the touchscreen stops responding, although the touchpad/'mouse' buttons are responding correctly.
I believe that one or more of the updates breaks touchscreen functionality. All help much appreciated.
As this is a recent phenomenon, I'll investigate further and post anything useful.
Just stop and think before you click that link.

User avatar
wallyUSA
Level 4
Level 4
Posts: 318
Joined: Thu Jun 08, 2017 2:31 pm
Location: Georgia Mtns USA (UTC-4/5)

Re: Touchscreen stops working (HP Pavilion10X2)

Post by wallyUSA » Sat Feb 03, 2018 8:00 am

Davdi wrote:I've got a HP Pavilion 10x2 detachable (2GB/64GB) running Mint 18.2 Sonya 64 bit. on initial install the touchscreen works perfectly (I use it as a tablet sans keyboard quite often).
But after updating, ...
updating is kind of vague. Can you give more details? This could mean h/w or s/w. Kernel or app?
Can you share the result of "inxi -Fx"?
The more you give, the more you get!
Mint 18.3 Sylvia Cinnamon 3.6.6 Kernel 4.13.0-32 (64 bit)
Please, if your query has been resolved, edit your first post and add [SOLVED] to the title.

Davdi
Level 1
Level 1
Posts: 15
Joined: Thu Jan 23, 2014 1:09 pm

Re: Touchscreen stops working (HP Pavilion10X2)

Post by Davdi » Tue Feb 06, 2018 1:49 pm

Here's the output:

Code: Select all

sue@sue-HP-Pavilion-x2-Detachable ~ $ inxi -Fx
System:    Host: sue-HP-Pavilion-x2-Detachable Kernel: 4.13.0-32-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Xfce 4.12.3 (Gtk 2.24.28) Distro: Linux Mint 18.2 Sonya
Machine:   System: HP product: HP Pavilion x2 Detachable v: Type1ProductConfigId
           Mobo: HP model: 813E v: 34.11 Bios: Insyde v: F.14 date: 08/29/2016
CPU:       Quad core Intel Atom x5-Z8300 (-MCP-) cache: 1024 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 11520
           clock speeds: max: 1840 MHz 1: 1440 MHz 2: 1440 MHz 3: 1440 MHz
           4: 1440 MHz
Graphics:  Card: Intel Device 22b0 bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1280x800@60.01hz
           GLX Renderer: Mesa DRI Intel HD Graphics (Cherrytrail)
           GLX Version: 3.0 Mesa 17.2.4 Direct Rendering: Yes
Audio:     Card Intel HDMI/DP LPE Audio driver: HdmiLpeAudio
           Sound: Advanced Linux Sound Architecture v: k4.13.0-32-generic
Network:   Card: Intel Wireless 3165 driver: iwlwifi bus-ID: 01:00.0
           IF: wlp1s0 state: up mac: 84:ef:18:29:be:a4
Drives:    HDD Total Size: NA (-) ID-1: /dev/mmcblk0 model: N/A size: 62.5GB
Partition: ID-1: / size: 55G used: 7.0G (14%) fs: ext4 dev: /dev/mmcblk0p2
           ID-2: swap-1 size: 2.06GB used: 1.62GB (79%) fs: swap dev: /dev/mmcblk0p3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 60.0C mobo: 26.8C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 200 Uptime: 2 days Memory: 1678.9/1916.1MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
Also, since the most recent Mint update, sound is not working either.
Just stop and think before you click that link.

Post Reply

Return to “Hardware Support”