Screen tearing after messing with graphic drivers

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
akshaybnair226
Level 1
Level 1
Posts: 1
Joined: Thu Feb 08, 2018 1:23 pm

Screen tearing after messing with graphic drivers

Post by akshaybnair226 » Thu Feb 08, 2018 1:31 pm

I accidently installed Nvidia driver on my machine using " Intel Device 1902 " (found from inxi -F command) .Now my display is very lagging and seems to have low frames per seconds. Playing videos are miserable and system animations look very horrible (even though i removed all nvidia packages) .
inxi -G looked like this

Graphics: Card: Intel Device 1902
Display Server: x11 (X.Org 1.18.4 ) drivers: intel (unloaded: modesetting,fbdev,vesa)
Resolution: 1600x900@59.98hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 510 (Skylake GT1) version: 4.5 Mesa 17.2.4



please help me guys

User avatar
prestonR
Level 5
Level 5
Posts: 844
Joined: Wed Jan 07, 2015 12:24 pm
Location: Harare

Re: Screen tearing after messing with graphic drivers

Post by prestonR » Thu Feb 08, 2018 5:17 pm

Your card should use the built-in modesetting driver, not the old intel. Uninstall it and reboot:

Code: Select all

sudo apt-get purge xserver-xorg-video-intel
I recon you installed that old intel and not an nvidia driver. You don't have a nvidia card; in case a nvidia driver does actually install I doubt it would have any effect at all.

Post Reply

Return to “Hardware Support”