<SOLVED> Reboot after wake up from suspend

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
User avatar
ciaobello07
Level 1
Level 1
Posts: 3
Joined: Fri Feb 09, 2018 7:55 am

<SOLVED> Reboot after wake up from suspend

Post by ciaobello07 » Fri Feb 09, 2018 8:14 am

Hi,

I have a trouble when I suspend my LinuxMint. I go in suspension mode typing systemctl suspend and all seen working correctly. When the PC wakes up from suspension it reboots and I lost everything.
Moreover, the hibernate mode (systemctl hibernate) works correctly. Could you help me?

Thank you!

Some generic system informations:
System: Host: rocco-N56JN Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3) dm: lightdm
Distro: Linux Mint 18.3 Sylvia
Machine: System: ASUSTeK (portable) product: N56JN v: 1.0
Mobo: ASUSTeK model: N56JN v: 1.0
Bios: American Megatrends v: N56JN.201 date: 02/06/2014
CPU: Quad core Intel Core i7-4700HQ (-HT-MCP-) cache: 6144 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 19155
clock speeds: min/max: 800/3400 MHz 1: 1200 MHz 2: 1200 MHz
3: 1200 MHz 4: 1199 MHz 5: 1195 MHz 6: 1200 MHz 7: 1195 MHz
8: 1040 MHz
Memory: No dmidecode memory data: try newer kernel.
Graphics: Card-1: Intel 4th Gen Core Processor Integrated Graphics Controller
bus-ID: 00:02.0 chip-ID: 8086:0416
Card-2: NVIDIA GM108M [GeForce 840M]
bus-ID: 03:00.0 chip-ID: 10de:1341
Display Server: X.Org 1.18.4 driver: nvidia
Resolution: 1920x1080@60.10hz
GLX Renderer: GeForce 840M/PCIe/SSE2
GLX Version: 4.5.0 NVIDIA 384.111 Direct Rendering: Yes
Audio: Card-1 Intel 8 Series/C220 Series High Definition Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0 chip-ID: 8086:8c20
Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller
driver: snd_hda_intel bus-ID: 00:03.0 chip-ID: 8086:0c0c
Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
Network: Card-1: Intel Wireless 7260
driver: iwlwifi bus-ID: 05:00.0 chip-ID: 8086:08b1
Drives: HDD Total Size: 750.2GB (36.7% used)
ID-1: /dev/sda model: ST750LM022_HN size: 750.2GB serial: S330J9EF211546
Partition: ID-1: / size: 74G used: 12G (17%) fs: ext4 dev: /dev/sda1
ID-2: /home size: 599G used: 230G (41%) fs: ext4 dev: /dev/sda3
ID-3: swap-1 size: 17.06GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID: System: supported: N/A
No RAID devices: /proc/mdstat, md_mod kernel module present
Unused Devices: none
Sensors: System Temperatures: cpu: 45.0C mobo: N/A gpu: 0.0:44C
Fan Speeds (in rpm): cpu: 2300
Last edited by ciaobello07 on Fri Feb 23, 2018 5:20 am, edited 1 time in total.

User avatar
ClixTrix
Level 5
Level 5
Posts: 747
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: Reboot after wake up from suspend

Post by ClixTrix » Fri Feb 09, 2018 8:41 am

Are you dual-booting with Win10 (or Win8) and have fast-boot enabled in BIOS? If so, disable and test.

Edit: I also checked your BIOS and it's not the most current.

https://www.asus.com/Laptops/N56JN/HelpDesk_BIOS/
Linux Mint 18.3 x64 Cinnamon Kernel 4.15.0-36-generic
Gigabyte GA-AB350M-D3H (F20) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 2x8GB / XFX HD5450-1GB
NVMe-SSD Samsung 960 EVO 250GB / SATA-HDD WD1600BEKT 160GB / SATA-SSD Toshiba OCZ VX500 512GB

User avatar
ciaobello07
Level 1
Level 1
Posts: 3
Joined: Fri Feb 09, 2018 7:55 am

Re: Reboot after wake up from suspend

Post by ciaobello07 » Fri Feb 09, 2018 12:56 pm

I have upgraded my BIOS and now suspension works fine!

Thank you! :D

Post Reply

Return to “Hardware Support”